two way authentication

  • Hallo Leute, bin nach ca. 4 Std suche in der Google oder hier im Forum mittlerweile ein wenig verzweifelt.
    Nach dem Joomlaupdate auf 3.6 (hatte vorher die Version 3.5.) funktioniert meine Two-Factor Authentication (2 Wege Authentifizierung) nicht mehr.
    Wenn ich den passenden Code in das Sicherheitsfenster eingebe, erscheint nicht mein Backend, es tut sich nichts, das sicherheitsfenster bleibt, aber ohne der eingegeben zahl.
    Gebe ich einen falsche Code ein, schreibt mir das Teil "falscher Code".
    jetzt habe ich per phpmyadmin alles disabled (von 1 auf 0 gestellt). jedoch erscheint mir immer noch dieses sicherheitsfenster. dann habe ich per ftp den ordner "twofactorauth" umbenannt auf
    "_twofactorauth" leider ohne wirkung, das sicherheitsfenster erscheint immer noch und ich komme nicht ins backend.
    vernünftigerweise habe ich leider vorher kein backup gemacht - ja ich weiss - bitte nicht verurteilen, habs in der hektik übersehen :-( ärgere mich eh schon selbst - bitte nicht schimpfen...
    bitte um eure hilfe, DANKE vielmals bereits im voraus.
    lg kirschi

  • Hallo,
    das Problem ist mir bekannt. Bei mir gab es Probleme mit den Zugriffsrechten der Kundeninstallation. Der Kunde war bei einem Unternehmen mit dem "S" am Anfang und hatte den Webschutz an. So das alle Änderungen nach dem Update wieder rückgängig gemacht wurden. Da ich jetzt nicht weiß ob du beim gleichen Provider bist, gebe ich dir mal ein paar Grundlegende Informationen ;-)


    Leider hast du auch nicht geschrieben ob der Yubikey oder Google genutzt wird. Ich gehe mal vom Yubikey aus und denke es ist der gleiche Weg. ;-)
    Ich gehe mal nicht davon aus das du Admintools einsetzt, oder ? Dann vergiss das da unten ;-)


    1.) Starte den PHPmyAdmin und gehe auf die Tabelle ?.users
    2.) Dort wählst du den betreffenden Anwender aus (Auf den Stift)
    3.) Und löscht den Inhalt der Tabelleninhalte otpKey & otep
    4.) speichern unten rechts


    Was mir auch schon passiert ist bei dem Provider "S" ist das das Benutzerpasswort leer war!


    1.) Gehe auf das Feld "password" in der Tabelle *.user
    2.) Stelle bei Funktion "MD5" ein
    3.) und trage das Passwort neu in das Feld "Wert" ein
    4.) speichern unten rechts


    Danach solltest du wieder Zugriff haben, in das Feld Sicherheitscode wird nichts eingeben!

  • morgen widmann-it,
    danke vielmals vorab für deine rückmeldung. mein Provider ist in Österreich und beginnt mit "A":-)
    *)ich verwende Google und habe keinen yubikey. ich bin zwar wie du beschrieben hast vorgegangen, aber bei otpKey & otep stand nichts drinnen, konnte daher auch nichts löschen.
    *)bei deiner zweiten variante muss ich sagen, da steht schon was im Passwort Feld unter "Wert" drinnen - zwar nicht das Passwort aber verschiedene andere zeichen, nehme an verschlüsselt (Buchstaben, zahlen etc. alles gemischt). traue mich das ding nicht löschen...


    vielleicht hast noch eine Idee oder vielleicht muss ich das Passwort wirklich neu eingeben?
    lg und danke einstweilen für deine antwort

  • danke für dein bemühen aber leider ohne erfolg,
    habe das passwort geändert - keine funktion
    uhrzeit stimmt bis auf 1 sekunde jetzt mit dem server überein - leider keine funktion


    ich komme wie gesagt immer auf das anmeldefenster von joomla und dann kommt das sicherheitsfenster - dort gebe ich den richtigen code ein, bestätige diesen und mein code verschwindet ohne fehlermeldung und müsste wieder einen neuen eingeben.
    ebenfalls habe ich den hersteller auch kontaktiert, aber bis dato noch keine antwort, nehme an die wollen nicht.
    vielleicht hast noch eine idee... wäre super
    lg

  • Hersteller von was ???
    Mich würde es mal Interessieren was passiert wenn du per phpMyAdmin einen neuen User anlegst und ob du dann reinkommst ins Backend. Es wird auch kein Akeeba Admintools oder eine andere Sicherheitslösung eingesetzt ?


    Ich bin ein kleinwenig verwirrt, im richtigen Anmeldefenster sieht es so aus :


    Username
    Password
    Secret Key


    da kommt kein weiteres Fenster mit einer Sicherheitsabfrage ??

  • Ok,
    da ich dieses Produkt nicht kenne und auch nicht weiß wie es funktioniert kann ich dir leider nicht weiterhelfen.
    Joomla bringt von Hause aus eine Zwei Wege Schutz mit, so das man keine Drittanbieter Erweiterungen benötigt wird.


    Jetzt Wundert mich auch nix mehr, da im Bereich Login einiges geändert wurde, die haben wohl nichts mitgekommen.