SSL/HTTPS entfernen

  • Hallo zusammen,
    ich betreibe seit Version 1.5 meine Seite http://myancestry.de mit Joomla.
    Als Readaktionssystem nutze ich EasyBlog.


    Im Zusammenhang mit der Migration auf Joomla 3.5 habe ich den Provider gewechselt und bin bei 1und1 gelandet. Hauptgrund war die kostenlsoe Bereitstellung von SSL-Zertifikaten und und die Cloudflare-Integration. Bis zum Wochenende hat auch alles prima funktioniert. Nun haben die aber die Cloudflare-Integration (natürlich ohne Kundeninformation) reduziert - es werden im Standard nur noch HTTP-Seiten ausgeliefert und für HTTPS-Seiten soll man fett zahlen. Nachdem ich der signigfikanten Verlangsamung der Ladezeiten auf den Grund gegangen bin, wollte ich mich aber nicht nötigen lassen. Also habe ich mit dem Support gesprochen und die haben wir empfohlen die SSL-Zertifikate zu entfernen. Was natürlich unbemekrt blieb... Joomla hatte aber forceSSL aktiviert. Auch gut, habe ich das in der configuration.pph geändert (ins Backend kam ich ja auch nicht mehr rein). Danach ging nichts mehr - nur zerrissende Seiten. Also habe ich SSL-Zertifikate wieder angestellt - es wurde noch schlimmer.


    Letzendlich habe ich ein Backup eingespielt und habe folgenden operativen Status:


    1. reaktivierte SSL-Zerifikate für die Dmonain "myancestry.de" und und die Subdomain "genealogie.myancestry.de" (Diese verweist auf myancestry.de/phpgedview)
    2. in der Configuration.php: public $force_ssl = '0';
    3. Die Seite wird sowohl mit http://myancestry.de wie auch https://myancestry.de ausgeliefert
    4. Claudflare ist entfernt
    5. Die seit langem problemlos genutzten Erweiterungen JotCache und JCH-Optimizer habe ich aus aktuellem Anlass DEaktivert (vorher alle Caches geleert).
    6. Caching im System ist komplett deaktiviert.
    7. Browser-Caches alle geleert
    8. Versuche mit Fireox, Safari oder Chrome zeigen alle dasselbe Verhalten


    Problem 1:
    Wenn ich http://myancestry.de nutze, werden bestimmte Links trotzdem als https-Links generiert.
    Beispiele:
    Hauptmenü>>Home erzeugt trotzdem <https://myancestry.de/>
    oder
    Hauptmenü>>Genealogie erzeugt trotzdem <https://myancestry.de/genealogie>


    Nur das manuelle Korrigieren in der Browser-Adresszeile führt zum korrekten Ergebniss,


    Problem 2:
    Der Menüeintrag Hauptmenü>>Genealogie <https://myancestry.de/genealogie> wird erzeugt, indem ich den iFrame-Wrapper nutze,
    Er ist wie folgt konfiguriert:
    Webadresse: http://myancestry.de/phpgedview
    Zielfenster: im gleichen Fenster


    Alternativ: (das hatte zu ForceSSL-Zeiten problemlos funktioniert)
    Webadresse: http://genealogie.myancestry.de
    Zielfenster: im gleichen Fenster


    Dennoch wird der Menüeintrag per HTTPS generiert und nicht per HTTP.


    Ich habe schon in der Datenbank geschaut, ob da irgendwelche Hard-Links in die Quere kommen, das ist aber nicht der Fall.


    Ich bin ratlos. Habt Ihr einen Tipp, wie ich die HTTPS-Links loswerde?


    End of the day will ich die SSL-Zertifikate wieder deaktiveren und die Seite soll trotzem laufen.


    Danke, MArko

  • Danke Flo, das wars!
    Man, das muss man erst mal vor Augen haben. Übrigens, die Option AUS hat auch nicht geholfen, erst IGNORIEREN hat Abhilfe geschaffen,


    Damit müsste ich doch jetzt SSL providerseitig deaktiveren können, ohne dass es mir die Seit erneut zerschießt. Oder muss ich noch an was denken?


    Herzlichst, MArko