Probleme mit Phoca Gallery

  • Guten Tag an alle Joomlaner.
    Ich habe einige Probleme mit der Phoca Gallery. Diese möchte ich zum ersten mal benutzen.
    Ich habe eine lokale Installation erstellt und die Phoca Gallery installiert.
    Dann habe ich mir eine neue Kategorie erstellt. Als nächstes dann einige Bilder hochgeladen.
    Im Verzeichnis Bilder kann man aber die Vorschau der Bulder nicht erkennen. Sie ist so klein
    wie ein Stecknadelkopf. Ich kann dieses kleine Bild jedoch anklicken und es wird mir die Originalgröße angezeigt.
    In den Optionen> Miniaturbilder ist der Punkt 'Miniaturbilderstellung aktivieren' auf ja gesetzt.
    Über einen neuen Menüpunkt habe ich die Kategorie mit den Bildern im Frontend in eine Schattenbox angezeigt.
    Leider sieht man auf der rechten Seite in der Box einen Scrollbalken.
    Weiterhin funktioniert auch die responsive Anzeige nicht, obwohl ich in den Optionen> Allgemeine Einstellungen: Responsive
    angewählt habe.
    Ich habe auch schon einige Threads des Users Benno durchgeackert, aber bin noch zu keinem Ergebnis gekommen.
    Für Hilfe bin ich sehr dankbar.
    Einen schönen Tag,
    Roland.

  • Hallo Roland,


    Leider wissen wir nicht, was Du alles schon ausprobiert usw. hast. Hier mal die Optionen: http://www.reisefotografien.eu…nstellungen-seit-joomla-3


    Über einen neuen Menüpunkt habe ich die Kategorie mit den Bildern im Frontend in eine Schattenbox angezeigt. Leider sieht man auf der rechten Seite in der Box einen Scrollbalken.


    Stell mal um auf: Schattenbox (nur Bilder). Und dann sehen wir weiter. Eine URL dazu, wäre auch optimal.


    Liebe Grüße, Christine

  • Vielen Dank für die Antworten
    Bisher habe ich das gemacht, was ich oben beschrieben habe,
    1. Phoca Gallery installiert incl. deutsch. Sprachdatei.
    2. Kategorie erzeugt.
    3. Mehrfaches Hinzufügen -neues Verzeichnis erstellt
    4 In diesem Verzeichnis 12 Bilder hochgeladen.
    5. Miniaturbilderstellung wurde durchgeführt.
    Sieht dann so aus:


    außerdem nach Videoanleitung im Web alles so nachgebaut und die Dokumentation von Benno gelesen.
    Er hat sich ja auch schon in einigen Threads dazu gebeldet, sowohl hier als auch im Phoca-Forum. Das habe ich mir natürlich auch schon alles durchgelesen.
    Ich hatte noch vergessen zu erwähnen, daß ich Joomla 3.6.5 verwende auf XAMPP 3.2.2 Php Version 7.1.1

  • Hi,
    welche Werte hast Du für die Größe der kleinen Miniaturbilder gesetzt?
    backend --> Komponenten --> Phoca Gallery --> Optionen --> Miniaturbilder --> Bilder und Detail Fenstergröße - Einstellungen -->
    Kleines Bild - Breite=
    Kleines Bild - Höhe=
    Standard ist da der Wert 50. Bei Dir sieht das aber eher nach 5 aus...
    Also neue Werte eintragen, die kleinen Miniaturbilder per FTP löschen und neu erstellen lassen.


    Freundliche Grüße,
    Benno

  • Hallo Benno,
    meine Einstellungen poste ich mal als Anhang.
    Due Bildgröße sollte ja stimmen. In meinem Ordner htdocs/meine_Seite/Images/phocagallery ist er Verzeichnisordner 'maritim'. Darin befinden sich die Bilder mit einer Größe 600px X 450px.
    In diesem Ordner befindet sich der Ordner thumbs. Darin sind dan nochmals alle Bilder jeweils mit den Größen 600px X 450px, 100px X 100px und 50px X 50px.

  • Hi,
    Deine Einstellungen sind völlig ok (ich würde noch die Seitenweise Miniaturbilderstellung auf Ja setzen), trozdem kann ich nicht glauben, das die Miniaturbilder, die in Deinem ersten Screenshot zusehen sind, 50x50px groß sind. Laß Dir mal die Eigenschaften von einem Bild anzeigen (rechte Maustaste --> Grafik-Info anzeigen)
    Da müßtest Du dann:
    Maße: 50px x 50px
    finden, wenn die kleinen Miniaturbilder tatsächlich mit diesen Maßen erstellt wurden.


    Freundliche Grüße,
    Benno

  • Öhhm, @Benno ist eigentlich der Wissende 8o
    Mal mit Vorsicht bitte. Den Ordner keinesfalls mit löschen.
    Versuch vorher mal im Backend:
    Komponenten > Phoca Gallery > Bilder.
    Dort alle Bilder in der Liste anzeigen lassen und markieren (Haken).
    Schaltfläche oben: "Miniaturbilder neu erstellen"

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Schau mal die thumbs-Ordner unter images/phocagallery/DeinOrdner an.
    Welche Größe haben denn die verschiedenen Thumbnails (gibt mehrere von jedem Bild)?
    Da Du die Einstellungen ja korrekt gestellt hast: Was passiert beim erneuten Hochladen einer Kategorie?


    (Bis morgen. Bye!)

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Habe ich oben schon geschrieben. Die Bilder haben die richtigen Größen und ich finde auch keine Bilder die zu 5px skaliert wurden.
    Ich habe auch schhon alles Mögliche versucht, z.B. alles deinstallieren, die Galerie wieder neu installieren, auf verschiedene Browser getestet.
    Es ist immer dasselbe.

  • wollt mich eigentlich da nicht mehr einmischen. Siehe bitte den Link oben. Da steht u.a.


    Zitat

    Kleines Bild - Breite Kleines Bild - Breite (Beachten Sie, ändern Sie diesen Parameter nur vor dem Erstellen von Miniaturbildern. Das bedeutet, dass dies nach der Installation der Phoca Gallery und vor dem Hochladen und dem Hinzufügen von Bildern in Kategorien erfolgen muss)


    Nachdem diese, lt. TE 0 0 px zeigen, müssen diese vor : "Miniaturbilder neu erstellen" gelöscht werden. Via FTP: ...../thumbs/phoca_thumb_s_img_blablub.jpg
    Die jeweilige Kategorie anvisieren (nachher beim Neugenerieren).


    Hallo Benno & Jörg.


    Christine

  • Hi,
    da passt was nicht... ?(
    Du schreibst:

    Zitat

    Du hast Recht, die Grafikinfo zeigt 0px × 0px (Skaliert zu 5px × 5px)


    und dann:

    Zitat

    Die Bilder haben die richtigen Größen und ich finde auch keine Bilder die zu 5px skaliert wurden.


    Wie heißt denn das Bild: 0px × 0px (Skaliert zu 5px × 5px) Bitte kompletter Pfad.


    OT: Beste Grüße, Christine, Jörg und Birger beer
    Freundliche Grüße,
    Benno

  • Guten Tag Benno,
    hab jetzt erst Feierabend.
    Es paßt wirklich etwas nicht. Die Grafikinfo im Backend zeigt:


    Adresse: http://localhost/livemusikduo-…32cb117c4d9805a8f22a8de1b
    Typ: JPEG-Grafik
    Größe: Unbekannt (nicht gecacht)
    Maße: 50px × 50px (Skaliert zu 5px × 5px)
    Zugeordneter Text: Bild vergrößern


    Im besagten Ordner finde ich dann das Bild mit der Bezeichnung:
    phoca_thumb_s_shantyduo1 und den Detailinformationen:
    Abmessung: 50 X 50
    Breite: 50 Pixel
    Höhe 50 Pixel
    Horizontale Auflösung: 96 dpi
    Vertikale Auflösung: 96 dpi
    Bittiefe: 24


    Ein Bild mit den Maßen 50 X 50 kann ich leider nicht finden.
    Gruß,
    Roland.

  • Hi,

    Zitat

    Ein Bild mit den Maßen 50 X 50 kann ich leider nicht finden.


    Hast Du doch gefunden:

    Zitat

    Breite: 50 Pixel
    Höhe 50 Pixel
    Horizontale Auflösung: 96 dpi
    Vertikale Auflösung: 96 dpi


    Ich finde eher das verwunderlich:

    Zitat

    Maße: 50px × 50px (Skaliert zu 5px × 5px)


    Ich bin da jetzt nicht so der Experte, weil das ja dein Browser macht, warum auch immer.
    Vielleicht mal den Browser Cache löschen ... ?(


    Freundliche Grüße,
    Benno

  • Hallo, die Bilder, die in Administration gezeigt sind, sind "Small Thumbnails" - solche sind auch in Frontend, in Categories View dargestellt (Setze Categories View, so es "Small Thumbnails" darstellt).


    So, wenn man die gleiche Grösse im Frontend sieht (gleich klein wie in Administration - NICHT 50px x 50px), dann sind die Thumbnails wirklich so klein und müssen neu hergestellt werden.
    Wenn man normale Grösse im Frontend sieht (50px x 50px), dies kann heissen, das die Bilder in Administration vielleicht bei einem spezifischen CSS beinflusst sind, da muss man dann alle CSS checken, ob irgendwo ein Regel ist, der es beinflusst.


    Jan