Ist EFSEO das Richtige?

  • Hallo,


    bin irgendwie am Verzweifeln und frage mich gerade ob denn EFSEO eigentlich die Richtige Erweiterung ist oder ob es Alternativen gibt? Oder wie macht Ihr das? Frage mich auch ob es nicht sinnvoller ist die ganze Suchmaschinenoptimierung ohne solche Erweiterungen selbst zu machen?


    Arbeite mit J3.7.5, also aktuell. Installiert ist Phoca Download, Phoca Duka als Template, JCE Editor, Xmap und eben halt auch EFSEO.


    Habe den Automatikmodus eingeschalten und sammle Einträge. Eingestellt ist alles nach der Vorgabe von "Kubik-Rubik" und eigentlich scheint ja alles ganz Easy zu sein. Gesammelte URL öffnen, Title, Description und Keywords eintragen sofern nicht schon vorhanden und speichern..... ABER: Meine Änderungen werden immer wieder überschrieben und ich habe jetzt wirklich unzählige Einstellungen ausprobiert. Sowohl im SEO-Plugin habe ich den Automatikmodus aus- und eingeschalten, Descrition oder Keywords überschreiben aus- und eingeschalten, das Titel-Attribut geändert, Blackliste aus- und eingetragen, habe globale Metadaten aus- und eingetragen, die Joomla-SEO mehrfach verändert, in den Menüeinträgen Seitentitel zugefügt und wieder entfernt, in den Beiträgen Metadaten ein- und ausgetragen sowie Browser-Seitentitel zugefügt und entfernt...... , was weiß ich was noch alles. Und ja - der Cache wurde sowohl in Joomla als auch im Browser immer wieder gelöscht.


    Wenn man im Internet nach SEO-Optimierung sucht stellt man fest das sich da die Geister scheiden. Unzählige Beschreibungen und jeder hat andere Ideen aber so richtig komme ich auf keinen Nenner welche Einstellungen denn die wirklich Richtigen sind.


    Aktuell habe ich die Site erstmal vom Netz genommen, deshalb jetzt mal ohne URL.


    Ich werfe jetzt mal den Hut in den Ring und hoffe auf weitere sinnvolle Ideen wo denn der Fisch begraben liegt.

  • Ja klar, wird geschrieben, ist da und irgendwann wieder weg. Arbeite seit 2004 mit Joomla und habe so ziemlich alle Höhen und Tiefen erlebt. Dache eigentlich das ich ganz gut zurecht komme aber im Moment trete ich einfach auf der Stelle und komme nicht mehr weiter.


    Noch mal zur anderen Frage - gibt es brauchbare Hilfen und Anleitungen was die SEO-Einstellungen sowohl in Joomla als auch in EFSEO betrifft?

  • Es gibt geschätzt eine Million brauchbare Hilfen für SEO mit Joomla - Vodeo-Tutorials, Vorträge, auch demnächst wieder auf der Joomla Konferenz in Königstein sind Spezialisten dabei. Für EFSEO weiss ich es nciht, ich setze keine Tools ein.


    Ich konnte nicht wissen seit wann du Joomla betreibst und welche Kenntnisse du hast. Wenn du noch xmap im Einsatz hast, das seit Jahren nicht mehr aktuell ist könntest du eventuell mit deinem Wissen etwas zurückliegen.

    Zitat

    Ja klar, wird geschrieben, ist da und irgendwann wieder weg.


    Generell würde ich sagen: Nichts verschwindet aus der Datenbank rein durch Zufall und ist irgendwann wieder weg.
    Wann ist irgendwann? Überschreibt eine neue Eingabe die alte?

  • Hallo zino66,


    ich meine mich zu erinnern dass ich das Phänomen auch mal hatte und EFSEO daraufhin wieder deinstalliert habe.
    Nach einer Neuinstallation zu einem späteren Zeitpunkt hat es dann aber funktioniert, und seit dem macht es was es soll:
    Nämlich ganz einfach und übersichtlich für jede URL die Möglichkeit Title, Description, Keywords und Robot-Einstellung eintragen und verwalten zu können, und die von Google gewünschte Zeichenanzahl dabei im Blick zu haben.


    Sinnfreie URLs habe ich dann händisch gelöscht und anschließend den Automatikmodus deaktiviert.


    VG Wolfgang

  • Arbeite mit J3.7.5, also aktuell. Installiert ist Phoca Download, Phoca Duka als Template, JCE Editor, Xmap und eben halt auch EFSEO.


    Hallo zino66,


    Xmap wird seit zwei Jahren nicht mehr weiterentwickelt und kann daher auch ein Sicherheitsproblem darstellen. Also mal Zeitnah nach einer Alternative umsehen.


    Was SEO betrifft, da komme ich bis jetzt mit der Joomlaeigenen bestens zurecht.

  • Na also, alles mögliche ausprobiert und keine Lösung. Daraufhin EFSEO deinstalliert und auch die Datenbank repariert, alle Cache nochmal geleert. EFSEO neu installiert und alles nochmal eingestellt, für den Moment funktioniert es jetzt. Danke für die Hilfen - wenigstens lag es wohl doch nicht an mir. :-)


    Allerdings habe ich jetzt ein neues "Problem" nachdem die Site wieder online ist - Fehlerhafte "hreflang"-Implementierung. Ich meine irgendwo etwas von Mehrsprachigkeit gelesen zu haben aber finde die Stelle absolut nicht wo was einstellbar wäre. Hat da jemand Hinweise für mich?

  • Alternativ kannst du auch OSMap nehmen. Ist aktuell und die Plugins für versch. Erweiterungen sind auch verfügbar.


    ja, sie Funzt. Jedoch solltest Du OSMap vorher auf einer Testinstallation installieren. OSMap bringt ein eigenes Framework mit. Dieses hat damals auf meiner Seite für einigen Ärger gesorgt, daher habe ich es wieder Deinstalliert. Wenn Du viele Seiten in einer Map verwalten möchtest, kann ich dir JSitemap empfehlen. Bei dieser kannst Du dich in den Einstellungen nach belieben Austoben, und sie bietet vieles mehr als die beiden genannten.

  • OSMap ist bei mir bei einer Seite mit sehr vielen Einträgen auch gescheitert. Weiß nicht, ob das am Virtuemart-Plugin liegt oder generell irgendein verstecktes Limit ist.


    Ja, mit Virtuemart ging dann irgendwann gar nichts mehr. Nach genauerem Hinsehen wurde in vielen Updates die Komponenete an das eigene Framework angepasst. Danach war zumindest mit VM Ende.


    Wie faro schreibt, nervt das Teil öfters mal extrem. Nach jedem Update prüfe ich erst mal die Sitemaps.


    Genau das Problem hatte ich auch. Nach jedem Update gab es Kopatibilitätsprobleme. Sogar mit der eigenen Sitemap. Auch hier vermute ich, dass das anpassen an das Hauseigene Framework der Grund war.

  • Ich habe mir jetzt mal JSitemap angeschaut und gekauft... Die 49 Euro sind gut angelegt! Kann ich nur weiterempfehlen.
    Funktionsumfang und Kompatibilität zu andern Erweiterungen ist mehr wie ausreichend. Tolle Erweiterung!!! Vielen Dank für den Tipp...


    Das ist eine gute Entscheidung :) Sie läuft auch bei mir bestens. XML Map. Bilder Map, Mobile map und RSS Map funktionieren auch bei großen Projekten bestens. Auch bei updates hatte ich bisher nie Probleme. Die gesamte Map bzw. Erweiterung macht geneu das, was sie soll.

  • Allerdings habe ich jetzt ein neues "Problem" nachdem die Site wieder online ist - Fehlerhafte "hreflang"-Implementierung. Ich meine irgendwo etwas von Mehrsprachigkeit gelesen zu haben aber finde die Stelle absolut nicht wo was einstellbar wäre. Hat da jemand Hinweise für mich?


    Unter 'Erweiterungen' -> 'Plugins' -> 'System - Sprachenfilter' sind hierzu einige Einstellungen, evtl. werden sie aber auch im Template (index.php) überschrieben...

  • Na also. endlich hab ich alles im Griff. Wie bereits beschrieben ist das Problem EFSEO nach einer Neuinstallation behoben. Keine Ahnung was da los war. Nach vielen Jahren mit Joomla bin ich dann doch nicht mehr so jungfräulich und planlos aber aus unerklärlichen Gründen ist jetzt alles gut.


    An dem hreflang-Problem war allerdings ich der Übeltäter, ich hatte einfach bei den Sprachen Deutsch noch nicht als Standard eingestellt. Manchmal ist man halt so doof.... Zu meiner Entschuldigung bleibt zu erwähnen das ich nach langem mal wieder ein neues Projekt begonnen habe und lange keine Grundeinstellungen mehr gemacht habe.


    Jedenfalls nochmal Danke für die Hilfe.