Darstellung in Firefox, Internet Explorer und Chrome

  • Hey Astrid,
    danke schonmal für deine Rückmeldung. Eigentlich ist das nicht gewollt, wüsste jetzt auch nicht wieso das so ist. Muss ich mir gleich mal anschauen.


    Beim Suchlauf der HTML sieht es ja garnicht allzu schlimm aus.
    Aber beim CSS-Teil =O ist es schon sehr sehr heftig.
    Wobei man jetzt aber auch sieht, dass der größte Teil von dem 'Ajax Plugin' kommt.


    Mit freundlichen Grüßen
    Graffa23

  • Hallo Graffa23,


    1) Das mit dem (mobilem) Menü, bzw. dass zurzeit nur ein Streifen da ist, ist u.a. deswegen:


    Du hast u.a. in der custom.css stehen: Schreib jetzt nur den Anfang her:


    Code
    1. @media all and (max-width:48.000em){
    2. .menu_container, .anchor-link { display: block; }


    was bedeutet denn: "max-width:48.000em?" Weiters: ".menu_container", oder: "left: -100%;" usw. usw. Von woher hast Du das?


    2) Wegen der Beitragtexte, habe ich schon im 1. post geschrieben. Sieht so aus, als ob Du word nimmst, sieht man an "schrägem": "xxxx" und mit diesem jck Editor formatierst. Es gibt immer noch (jetzt andere :-) Inline-CSSen.


    3) In der custom.css gibt's noch etliche Sachen, die Du dazugeschrieben hast? Das muss man sich auch noch ansehen.


    Sorry, aber ist nun schwierig,
    Liebe Grüße, Christine

  • Hallo Chrstine,
    danke für deine Hilfe.


    Zu 1) Ich kann mich garnicht erinnern, dies reingeschrieben zu haben. Ich werde später mal meine komplette custom.css posten um vllt. Licht ins dunkle zu bringen.
    Zu max-width etc wie gesagt kein Plan wo die her kommen?! :(


    Zu 2) Ja ich nehme die Texte aus Word, aber füge sie über den Extra Button in den Editor ein. Wie soll ich des denn sonst machen, wenn ich die Formatierung nicht so übernehmen kann? Irgendwie muss/will ich ja meinen Text formatieren.


    Zu 3) Ja da ich meine ganzen Änderungen eben dann nur noch in der custom.css stehen haben wollte. Wie gesagt ich poste später mal, was ich genau in die custom.css geschrieben habe. Dürfte dann vielleicht etwas leichter fallen.


    Liebe Grüße
    Graffa23

  • So hier bin ich wieder!
    Christine : Dieser Codeschnipsel ist jetzt draußen, warum der dort drin war weiß ich selbst nicht.


    Hier mal meine custom.css


    Liebe Grüße
    Graffa23

  • Zu dem Texte-kopieren-Problem. Diese Web-Editoren haben ihre Macken. Viellecht gibts bei deinem Editor eine Code-bereinigen-button, den du noch ausprobieren könntest. Es gibt aber eine "Handwerker" Methode, die immer und überall funktioniert:


    Ruf den Texte im Frontend auf
    Markiere ihn und mach copy (strg +c)
    Geh ins backend - inhalt beitrag neu
    Schalte dort um auf den html-modus, je nachdem welchen editor du hast ... bei mir ist es recht unten "toggle editor"
    Du bekommst einen Eingabebereich ganz ohne buttons und sonstigem zeug.
    Füg dort den Text ein (strg + v) - es ist purer Text
    Schalte den Editor wieder um.


    Nun hast du einen ganz sauberen Text, aber alles in einer Wurst. Jetzt kannst du formatieren.
    Aber vorsichtig! Am besten nur Zeilenumbrüche oder mal etwas "fett" alles andere sollte in die custom.css.
    Vor allem, gib keine Schriftart an. Wenn du eine bestimmt Schrift willst, schreib in die custom.css etwas wie
    p {font-family: "verdana" ; line-height: 150%; }
    oder was dir als Schriftart vorschwebt.
    Das wird schon ;)

  • Ha, da hat Christiane ja schon Vorarbeit geleistet - Holzhammer öhm, sorry Handwerker Methode ^^


    Somit schreib ich jetzt Phase 2:


    Du hast in der template.css / Zeile 190 (zumindest jetziger Status) ..... man weiß ja nie :-) folgendes:


    Code
    1. body {
    2. color: #333;
    3. font-family: "Helvetica Neue",Helvetica,Arial,sans-serif;
    4. font-size: 13px;
    5. line-height: 18px;}


    So, jetzt gibt es ja Deine custom.css wo Du Deiner Änderungen machst, da gibt es zurzeit:



    Wunderbar. Passt. Und da kannst Du jetzt Deine weiteren Formatierungen reingeben & Dich austoben, was halt noch so fehlt. Siehe die Formatierungen bei: template.css


    Du kannst z.B. in die custom.css >body schreiben:


    font-family: "Helvetica Neue",Helvetica,Arial,sans-serif; Jetzt willst Du aber z.B. eine andere probieren (welche zurzeit Inline-CSS ist) z.B.:
    font-family:verdana, geneva;


    Bist Dir aber noch nicht sicher & willst es ja nicht gleich löschen. Heißt: Du kannst auch eine Zeile "auskommentieren:
    /*font-family: "Helvetica Neue",Helvetica,Arial,sans-serif;*/


    Eigentlich wollte ich noch was schreiben, denke aber, wir sollten es schrittweise machen.


    Liebe Grüße, Christine


    Edit: seh erst jetzt, da ist noch ein Nachschlag gekommen. Soll ich wegen der font meines nun löschen?

  • Ich bin echt einfach sprachlos und so dankbar für eure Hilfe pardon


    firstlady :
    Ich habe diese "Methode" jetzt mal auf der Seite Herzlich Willkommen angewendet und jetzt müssten theoretisch und hoffentlich auch Praktisch aus der inline css draußen sein? Könnt ihr dies bestätigen?


    Christine :
    Okay, ich glaube ich habe verstanden das heißt das die Methode die ich gemacht habe (Dank eurer Hilfe natürlich) auf jeden Fall schon einmal richtig sein sollte wenn ich die Sache mit der Schrift mal außen vor lasse. Diese habe ich jetzt übrigens auch mal über die custom.css definiert. So müsste es passen?!
    Nochmal zu dem Quellcode vom custom.css den du gepostet hast, soll es so im Optimalfall aussehen? Weil meine "Schreibweise" ist ja bisher anders aufgebaut.


    Liebe Grüße und Danke(!!)
    Graffa23

  • Hallo Graffa23,


    Bestätige hiermit, dass keine Inline CSS mehr da ist. Zumindest die Seiten, die ich gesehen habe.
    Der Vorteil ist ja auch (siehe mein 1. post), dass Du jetzt keine so zerstückelten Texte mehr hast. Würde dann aber noch da & dort einen Zeilenumbruch machen.



    Diese habe ich jetzt übrigens auch mal über die custom.css definiert. So müsste es passen?!


    jawoll :-)


    Zitat

    Nochmal zu dem Quellcode vom custom.css den du gepostet hast, soll es so im Optimalfall aussehen? Weil meine "Schreibweise" ist ja bisher anders aufgebaut.


    Wusste zuerst nicht was Du damit meinst. Der Unterschied vom posting ist nur der: Du hast den Code (spoiler) im "Quelltext bearbeiten modus" kopiert & ich "ohne" Bearbeitungsmode.


    Jetzt brauch ma noch den Sanktus & das OK oder Veto? :-) von Christiane,


    Liebe Grüße, Christine

  • OK vielen Dank für die Bestätigung. :)
    Ja das stimmt allerdings, habe jetzt alles nur mal schnell eingefügt den Rest formatiere ich dann noch.


    Sehr gut :-) d.h. die ganze Definition oder Einstellungen der Schriftart wird empfohlen über CSS zu machen?


    Achso :-) Dann ist das ja in Ordnung dachte schon der Code wäre nicht bspw unsauber.


    Prinzipiell einfach eine Meinung/Kritik :D Ob gut oder schlecht als her damit ich brauche Kritik!


    --------


    Nochmal kurz zum dem CSS Validation und HTML Validation: Wisst ihr auch wie ich diese Fehlermeldungen beim validieren der CSS wegbekomme es werden sehr viele Sachen im Zusammenhang mit ajax plugin und arg bootstrap erwähnt?


    Mit freundlichen Grüßen
    Graffa23

  • Zitat

    Sehr gut d.h. die ganze Definition oder Einstellungen der Schriftart wird empfohlen über CSS zu machen?


    Das versuchen wir ja schon die ganze Zeit, Dir schmackhaft zu machen :-)
    Gibt natürlich etliche Möglichkeiten, sodass Du in einem "Aufwasch" einen CSS "Befehl" gibst, der eben, wie in Deinem Beispiel für: body gilt.


    Oder den von Anka für: ".header inner {deine formatierungen }" Farbe, Rahmen, alles was Du möchstest.


    Natürlich muss man auch aufpassen, dass nicht irgend eine CSS Anweisung eine andere "überschreibt". Vererbungssache.
    Ah, jetzt gefunden: Schau Dir dazu, die Erklärung von Christiane an (Mittwoch, 16.42h) Mir war der "Maler" in Erinnerung :-)


    Zitat

    Wisst ihr auch wie ich diese Fehlermeldungen beim validieren der CSS wegbekomme es werden sehr viele Sachen im Zusammenhang mit ajax plugin und arg bootstrap erwähnt?


    Also, darauf bin ich vorhin nicht eingegangen ..... Du willst es "kurz" wissen? :-) Lies mal hier: http://www.joomlaportal.de/joo…er-wo-kommen-die-her.html und hier: http://www.joomlaportal.de/joo…alidator.html#post1556218


    Das mit dem Ajax Plugin. Weiß nicht, brauchst Du unbedingt diesen CK Editor?


    Das wärs in Moment.


    Liebe Grüße, Christine

  • Ok dann habe ich aufjedenfall verstanden, einfacher ist es finde ich auch. Vorallem zusätzlich 100 mal übersichtlicher!
    Zu Christianes Antwort.. stimmt da war ja was :-)!


    hmm okay, scheint also ein Problem des Validitor zu sein, aufjedenfall schonmal gut zu wissen ^^


    Eigentlich nicht, ich werde mal versuchen noch was rauszuholen durch die Deinstallation des CK Editors.


    Auch hier nochmal ein herzliches Dankeschön an alle die mich in diesem Thread (aber auch natürlich in anderen) unterstützt haben und die Nerven mit einem ich sage mal Neuling behalten haben. Ich glaube ihr könnt jetzt schon stolz auf dieses Forum sein, auch wenn erst die Grundsteine gelegt sind!
    Natürlich ist dies eine Community und es ist leider schade, dass viele diese Leistungen und Beiträge/Hilfen anderer nicht wertschätzen können.
    Ich finde ich kann dies! Auf diesem Wege wünsche ich euch noch einen schönen Abend un setze diesen Thread ersteinmal auf gelöst (vorrausgesetzt es ist in Ordnung).


    Freundliche und Liebe Grüße
    Graffa23


    EDIT: Bevor ich es vergesse eine Frage habe ich noch.
    Rechts unten steht doch normalerweise "Zum Seitenanfang" oder "Back to top". Warum wird mir dort die Klasse angezeigt bspw "TPL_PROTOSTAR_BACKTOTOP". Bekomme ich das mit? Liegt das nicht an der Sprachdatei?

  • Hallo,


    zu den Sprachtexten


    In der Datei


    DEINJOOMLA!\templates\protostar\index.php


    Findest du relativ weit unten den Text

    PHP
    1. <p class="pull-right"> <a href="#top" id="back-top"> <?php echo JText::_('TPL_PROTOSTAR_BACKTOTOP'); ?> </a> </p>


    Falls du die englische Version einsetzt wird dieser in der Datei
    DEINJOOMLA!\templates\protostar\language\en-GB\en-GB.tpl_protostar.ini
    übersetzt. Ersetze für die deutsche Version einfach das en-GB in de-DE.

    Code
    1. ..
    2. TPL_PROTOSTAR_BACKTOTOP="Back to Top"
    3. ..


    Kann es sein, das sich bei dir irgendwo ein Tippfehler eingeschlichen hat?

    Viele Grüße
    Astrid

  • Hallo,


    Zitat

    okay, scheint also ein Problem des Validitor zu sein, aufjedenfall schonmal gut zu wissen


    ... oder unserer schnelllebigen Zeit :-)


    Ich finde es aber trotzdem immer hilfreich die angezeigten Fehler und Warnungen des W3C-Validators zu überprüfen und dann selbst zu entscheiden, wie man diese Fehler behandeln will. Und das nicht nur, weil man da auch viel bei lernt :-).


    Wichtiger ist aber natürlich, dass die Website überall so wie gewünscht angezeigt wird.


    Viele Grüße
    Astrid