Update auf PHP Version 7.1

  • Hallo!
    ich habe mit einer meiner Joomla Seiten ein Problem:
    Version Joomla 3.8.1 - Version php 5.6. - mit dieser Einstellung funktioniert alles tadellos!


    Wenn ich jedoch wie empfohlen auf die php version 7.1. oder 7.0 updaten will habe ich folgendes Problem - ich kann im Backend Bereich keine Beiträge mehr bearbeiten oder neu anlegen - wenn ich einen Beitrag anklicke erscheint nur mehr ein weißes Fenster. Habe bereits alle Plugins und Komponenten die nicht gebraucht werden deaktiviert, bzw. deinstalliert.
    Vielleicht kann mir jemand weiterhelfen? - Also im Voraus schon mal ein großes Danke!!

  • Es gibt immer noch Erweiterungen die mit PHP 7.0 oder 7.1 nicht kompatibel sind. Prüfe daher alle Versionen, insbesondere der Plugins, die hier Ursache sein können. Je nach Provider kann es auch sein, das unterschiedliche Techniken beim Webserver bei unterschiedlichen PHP-Versionen benutzt wird, so das hier auch eine zumindestens theoretische Ursache möglich ist. Vielleicht benutzt Du auch verschlüsselte Erweiterungen die ioncube benötogen - welches ebenfalls PHP-Versionsabhängig ist.
    Wenn keine Ursache zu finden ist, lass doch einfach 5.6 eingestellt.

  • Kannst ja mal testweise SEO und die .htaccess deaktivieren bzw. nur das Nötigste drin lassen!


    Auf welche Art und Weise hast du die PHP-Version umgestellt? Beim Hoster direkt? Global? Einzelnes Verzeichnis? Oder gar in der .htaccess selber.
    Wenn du die Umstellung beispielsweise durch einen Eintrag in die .htaccess realisierst, und global ist bereits die gleiche PHP-Version eingestellt, dann führt dies zu Problemen.


    Welcher Hoster?
    Wurde mit einer eventuellen globalen Umstellung auch OPcache aktiviert?
    Ist das Beitragsproblem das einzige Problem oder gibt es weitere?


    BTW: Caches auch immer leeren!

  • Also zuerst mal herzlichen Dank an alle, die sich mit dem Problem befassen!!


    Ich stelle die php Version beim Provider (world4you.at) direkt im Benutzerbereich um.
    Editor verwende ich den JCE Editor - ist aber noch Tiny installiert
    Was ist bitte SEO???
    Und ja - das ist das Einzige Problem!
    Inhalt der .htaccess Datei:
    # @package Joomla
    # @copyright Copyright (C) 2005 - 2017 Open Source Matters. All rights reserved.
    # @license GNU General Public License version 2 or later; see LICENSE.txt
    ##
    # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
    #
    # The line 'Options +FollowSymLinks' may cause problems with some server configurations.
    # It is required for the use of mod_rewrite, but it may have already been set by your
    # server administrator in a way that disallows changing it in this .htaccess file.
    # If using it causes your site to produce an error, comment it out (add # to the
    # beginning of the line), reload your site in your browser and test your sef urls. If
    # they work, then it has been set by your server administrator and you do not need to
    # set it here.
    ##


    ## No directory listings
    <IfModule autoindex>
    IndexIgnore *
    </IfModule>


    ## Can be commented out if causes errors, see notes above.
    Options +FollowSymlinks
    Options -Indexes


    ## Mod_rewrite in use.


    RewriteEngine On


    ## Begin - Rewrite rules to block out some common exploits.
    # If you experience problems on your site then comment out the operations listed
    # below by adding a # to the beginning of the line.
    # This attempts to block the most common type of exploit `attempts` on Joomla!
    #
    # Block any script trying to base64_encode data within the URL.
    RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
    # Block any script that includes a <script> tag in URL.
    RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
    # Block any script trying to set a PHP GLOBALS variable via URL.
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    # Block any script trying to modify a _REQUEST variable via URL.
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    # Return 403 Forbidden header and show the content of the root home page
    RewriteRule .* index.php [F]
    #
    ## End - Rewrite rules to block out some common exploits.


    ## Begin - Custom redirects
    #
    # If you need to redirect some pages, or set a canonical non-www to
    # www redirect (or vice versa), place that code here. Ensure those
    # redirects use the correct RewriteRule syntax and the [R=301,L] flags.
    #
    ## End - Custom redirects


    ##
    # Uncomment the following line if your webserver's URL
    # is not directly related to physical file paths.
    # Update Your Joomla! Directory (just / for root).
    ##


    # RewriteBase /


    ## Begin - Joomla! core SEF Section.
    #
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    #
    # If the requested path and file is not /index.php and the request
    # has not already been internally rewritten to the index.php script
    RewriteCond %{REQUEST_URI} !^/index\.php
    # and the requested path and file doesn't directly match a physical file
    RewriteCond %{REQUEST_FILENAME} !-f
    # and the requested path and file doesn't directly match a physical folder
    RewriteCond %{REQUEST_FILENAME} !-d
    # internally rewrite the request to the index.php script
    RewriteRule .* index.php [L]
    #
    ## End - Joomla! core SEF Section.

  • Herzlichen DANK an alle!
    Problem ist gelöst - Schuld war der JCE Editor - habe ihn deinstalliert, neu heruntergeladen und wieder neu installiert - jetzt funktioniert alles!


    Habe ein Akeeba Backup auf eine andere Instanz geladen, entpackt und dort einfach versucht alles zu deinstallieren, deaktivieren,. etc.. - So bin ich dem Problem auf die Schliche gekommen! -
    Danke Christian für den Tipp!!!
    Und "Joe Sixpack" hatte gleich die Idee mit dem Editor

  • Hallo zusammen,

    ich habe heute direkt bei meinem Provider auch von PHP 5.6.31 auf 7.1.10 akualisiert.

    Jetzt kann ich meine Website aber nicht mehr öffnen. Es kommt nur noch Fehler "Die Website kann diese Seite nicht anzeigen HTTP 500".

    Ich habe bisher Joomla! 3.8.8 installiert.


    Hat jemand eine Idee, wie ich das zum Laufen bekommen?


  • Gehe zurück auf PHP 5.6, dann aktualisiere alles (nicht nur Joomla) und teste anschließend erneut PHP 7.1.

    Wenn es weiter nicht funktioniert, deaktiviere Plugins oder Module, die möglicherweise veraltet sind und mit PHP 7.1 nicht mehr laufen. Auf diese dann verzichten bzw. eine Alternative suchen!

  • Ich habe gerade Fehler.log angeschaut, es kommt folgende Meldung:

    Warning: session_start(): Failed to read session data: user (path: /var/www/.../tmp) in /var/www/.../libraries/joomla/session/handler/native.php on line 260

    Error: Failed to start application: Failed to start the session

    Die Verzeichnisse in der configuration.php stimmen aber:

    public $log_path

    public $tmp_path

  • Du hast dich an einen Thread von vor einem Jahr angehängt, bei dem es um Version 3.8.1 ging und warhscheinlich um ganz was anderes.


    Aber du hast ja inzwischen von 3.8.8 auf 3.8.12 aktualisiert, und es gibt keinen 500 Fehler.

    Also gibt es die üblichen Maßnahmen:

    • In Backend - System -Configuration - Server die Fehlermeldung auf "Maximum" stellen
    • Cache löschen
    • Datenbank reparieren in Backend -> Erweiterungen -> Datenbank reparieren

    Dann schauen wir weiter

  • Ich habe diese Schritte gemacht und wenn ich die PHP-Version wieder hochsetze, dann kommt wieder die gleiche Fehlermeldung:

    Warning: session_start(): Failed to read session data: user (path: /var/www/.../tmp) in /var/www/.../libraries/joomla/session/handler/native.php on line 260

    Error: Failed to start application: Failed to start the session

  • Dann schau mal unter "Verwalten" -> "Plugins" die Plugins an, die eine ID > 10.000 haben. Eines dieser Plugins wird mit PHP 7.1 Probleme haben. Fang an zu deaktivieren! Aber keine mit ID < 10.000, nicht dass du dich aussperrst.


    Ähnliches auch mit Modulen von Drittanbieter-Erweiterungen. Oft sind es auch Frameworks mit denen manche Templates laufen.

  • Dann schau mal unter "Verwalten" -> "Plugins" die Plugins an, die eine ID > 10.000 haben. Eines dieser Plugins wird mit PHP 7.1 Probleme haben. Fang an zu deaktivieren! Aber keine mit ID < 10.000, nicht dass du dich aussperrst.


    Ähnliches auch mit Modulen von Drittanbieter-Erweiterungen. Oft sind es auch Frameworks mit denen manche Templates laufen.

    Uff, das sind bei mir 641 Einträge > 10000 :( :( :(


    Das ist ja wie die Nadel im Heuhaufen...


    Ich glaub, ich lass einfach PHP-Version „7.0.24“, dort läuft alles ohne Probleme.