Problem mit Darstellung im IE / Tabelle mit Bildern

  • Hallo.


    Ich habe das Problem, dass die Startseite nur beim Internet Explorer doof angezeigt wird; unter Firexox, Chrome und sogar Edge funktioniert es wunderbar.
    Auf der Startseite habe ich eine Tabelle mit 3 Spalten gemacht.
    Die linke Spalte hat 2 Zeilen, wo jeweils ein Foto drin ist. Die 2 restlich Spalten sind jeweils zusammengefügt; in der mittleren steht ein Text und in der rechten ein Bild.


    Ich habe jetzt eine 2. Startseite gebastelt, die im Internet Explorer gut aussieht; die sieht dann aber im Firefpx, Chrome etc. doof aus.
    Was kann ich tun? Gibt es die Möglichkeit eine Browserweiche nur für die Startseite zu machen; also das die Weiche dann auf einen bestimmten Beitrag hinführt?
    Oder welche Möglichkeiten gibt es noch? IE=Edge in den Meta-Eintrag reinschreiben hat nichts bewirkt.


    Die Seite um die es geht ist:


    http://bostonterrier-bernburg.de

  • ... Oder welche Möglichkeiten gibt es noch?


    Tabellen sind immer so eine Sache mit der (responsiven) Darstellung.
    Ich würde keine normalen Tabellen verwenden.


    Vielleicht hilfreich:


    https://extensions.joomla.org/extension/responsive-tables/


    https://extensions.joomla.org/extension/responsive-table/


    https://extensions.joomla.org/extension/vj-responsive-table/


    https://extensions.joomla.org/extension/ari-data-tables/

  • Ist das ein einfacher Beitrag der Auf der Startseite (als Hauptbeitrag) erscheint ?
    Wenn ja warum nimmst du da eine Tabelle? und fügst nicht einfach Bilder in den Beitrag ein...


    Ich hab kein Plan, wie ich das sonst realisieren soll; links 2 Fotos untereinander; Mitte ein Text und rechts nochmal 1 Foto.
    Habs ohne Tabelle probiert, aber nicht hinbekommen. Ich nutze den JCE-Editor.
    Ich schätze mal ohne Tabelle macht man das mit CSS?! Da hab ich aber keinen Plan wie man da die Bilder und den Text positioniert. Geht das überhaupt innerhalb eines Beitrages?
    Oder gibts noch eine einfachere Möglichkeit?

  • Scheinbar nicht. Ich hab verschiedene div-Sachen ausprobiert, das wird alles ignoriert und er schreibt alles untereinander. Ich nutze das AS 002032 FREE - Standard Template. Und ja, ich würde gern das kostenlose verwenden. Das reicht für den Zweck der Seite völlig aus.


    Responsive Tables sind wohl auch nicht empfehlenswert, wenn man wie ich Bilder verwendet?!

  • Scheinbar nicht. Ich hab verschiedene div-Sachen ausprobiert, das wird alles ignoriert und er schreibt alles untereinander. Ich nutze das AS 002032 FREE


    Dann machst Du was falsch.
    Das AS002032 verwendet Bootstrap3: https://www.astemplates.com/jo…mplate-details/109-002032 und da wird kein Unterschied zwischen Free und Commercial gemacht.

  • Hm, jetzt bin ich ratlos. Ich klicke im Beitrag auf Code und füge Beispiele ein, die ich im Netz gefunden habe. Wenn ich dann auf Preview gehe, werden die div-Sachen komplett ignoriert und alles steht nur untereinander.
    Auch wenn ich mir die Seite "normal" über den Browser anschaue, steht alles untereinander.

  • Hab jetzt auch mal mit img class -Sachen rumgespielt, das hat alles keinerlei Effekt. Nur das ich das nicht mißverstehe, Bootstrap ist automatisch im Template integriert; ich muß nix installieren/aktivieren oder so.
    Oder geht das irgendwie noch anders?

  • Hallo,

    Ich klicke im Beitrag auf Code und füge Beispiele ein, die ich im Netz gefunden habe.


    das würden wir gerne sehen, dass besser geholfen werden kann.


    Zitat

    Bootstrap ist automatisch im Template integriert; ich muß nix installieren/aktivieren oder so.


    Ja. Template (preview) und Deine Seite zeigen: div id="component" class="span12" also verwendest Du bootstrap 2. Siehe dazu 1. Link vom Tom.
    Könnte so in etwa aufgebaut sein:


    Bild links: span3 / Inhalt: span6 / Bild rechts: span3 oder
    Bild links: span2 / Inhalt: span6 / Bild rechts: span4
    gesamt muss es immer: 12 ergeben.
    so in etwa:
    <div class="startseite">
    <div class="row">
    <div class="span2">deine img zeile</div>
    <div class="span6">dein text</div>
    <div class="span4">dein img zeile </div>
    </div></div>
    Wahrscheinlich muss man dann noch CSSmäßig was machen. Kann man erst sagen, wenn wir Deine Aktionen sehen.


    Siehe auch dazu 1. Link vom Tom (bootstrap 2).


    Beim rechten Bild könnte ich mir eher vorstellen, dass man es in ein eigenes Modul gibt. Müsste man schauen, ob es dazu eine Position gibt.


    Liebe Grüße, Christine

  • Wollte ein Bild/Screenshot hier hochladen, aber funzt nicht.
    Es ist ja auch kein Hexenwerk; habe verschiedenste Beispiele ausprobiert und es steht immer alles untereinander.
    Bsp. von Christine:


    <div class="startseite">
    <div class="row">
    <div class="span2">deine img zeile</div>
    <div class="span6">dein text</div>
    <div class="span4">dein img zeile </div>
    </div></div>


    sieht dann so aus:



    deine img zeile
    dein text
    dein img zeile

  • Wahrscheinlich muss man dann noch CSSmäßig was machen. Kann man erst sagen, wenn wir Deine Aktionen sehen.


    Hallo,


    ich konnte Deinen Versuch auf der verlinkten Seite nicht entdecken. Bin ich da falsch.
    Nachdem ich einen blick in die bootstrap.css geworfen hatte, schließe ich mich der Meinung von Christine an.
    Ohne entsprechendes CSS stehen die DIVs natürlich untereinander (normales Verhalten bei Blockelementen).


    Christian

  • Du hast den Beitrag immer noch in Tabellen. Schmeiß das doch mal bitte komplett raus! Auch keine DIVs oder sowas. Brauchen wir alles nicht!
    Füge das Bild mit dem Editor ein und teile mit, dass es "links" stehen soll. Wenn du dann Text eingibst, fließt der automatisch rechts herum und wenn du das auf dem Handy dann anschaust, passt sich das alles auch automatisch an.


    Ein Bild darunter wird genauso eingefügt: Ausrichtung links. Ein Bild auf der rechten Seite mit "Ausrichtung: rechts" und der Text fließt links herum. Das passt dann auch alles auf allen Browsern.


    Keine Tabellen, keine DIVs!



    Axel


  • Das was du beschrieben hast funktioniert halt nicht, bzw. ich kriege es nicht hin. Problem ist das rechte Bild.
    2 Bilder untereinander und rechts daneben ein Text ist kein Problem; abgesehen davon, dass das Ende vom Text dann zwischen oberem und unterm Bild steht. Aber wie soll ich dann rechts neben dem Text nochmal ein Bild hinbekommen, was so ausgerichtet ist wie jetzt (mittig zu den beiden linken Bildern).
    Man kann doch den Text nur realitv zu einem Bild setzen und nicht zu zweien oder sogar 3?!

  • Das was du beschrieben hast funktioniert halt nicht, bzw. ich kriege es nicht hin. Problem ist das rechte Bild.
    2 Bilder untereinander und rechts daneben ein Text ist kein Problem; aber wie soll ich dann rechts neben dem Text nochmal ein Bild hinbekommen, was so ausgerichtet ist wie jetzt (mittig zu den beiden linken Bildern).


    dann halt so wie ich im vorigen post schon schrieb:


    Zitat

    Beim rechten Bild könnte ich mir eher vorstellen, dass man es in ein eigenes Modul gibt. Müsste man schauen, ob es dazu eine Position gibt.


    Das template hat ja sicher mehrere Positionen zur Verfügung. Schaust halt, wo es rechts eine Position gibt & der Startseite zuweisen.


    Liebe Grüße, Christine

  • Ich hab jetzt mal aus den linken beiden Bildern mittels Photoshop ein einziges Bild gemacht, aber es klappt trotzdem nicht.


    Aber man kann doch einem Beitrag keine Position zuweisen?! Die Idee hatte ich auch schon, aber nix gefunden, wo man das definieren kann.
    Und was für ein Modul gibt es, was lediglich ein Bild an gewünschter Position anzeigt?
    Oh mann, das alles nur für Leute, die noch nen alten IE nutzen. Chrome, Firefox, Edge, Smartphone, Tablet - überall funktioniert es, so wie es jetzt ist.