MIgration auf Joomla 3 - Fehlermeldung

  • Guten Tag,
    ich möchte meine Webseite über xampp local migrieren, sozusagen als Test. Habe xampp auf dem Rechner, alle Joomla - Dateien in htdocs abgelegt, die Datenbank per dumper auf xampp gespielt und dann die Migration probiert. Eine erste Fehlermeldung kam wegen dem JSNPoweradmin-Modul. Habe nochmal alles aufgespielt, dieses Modul deinstalliert und jetzt kommt wieder eine Fehlermeldung.

    Fatal error: Uncaught exception 'RuntimeException' with message
    'Unknown column 'header' in 'field list' SQL=SELECT
    `new_url`,`header`,`published`
    FROM `z7fp8_redirect_links`
    WHERE `old_url` = 'http://localhost/gastro/' LIMIT 0, 1' in
    C:\xampp\htdocs\gastro\libraries\joomla\database\driver\mysqli.php:610
    Stack trace:
    #0 C:\xampp\htdocs\gastro\libraries\joomla\database\driver.php(1239):
    JDatabaseDriverMysqli->execute()
    #1 C:\xampp\htdocs\gastro\plugins\system\redirect\redirect.php(86):
    JDatabaseDriver->loadObject()
    #2 [internal function]:
    PlgSystemRedirect::handleError(Object(RuntimeException))
    #3 {main}
    thrown in C:\xampp\htdocs\gastro\libraries\joomla\database\driver\mysqli.php on line 610

    Notice: Undefined property: LoginController::$input in C:\xampp\htdocs\gastro\administrator\components\com_login\controller.php on line 36
    Fatal error: Call to a member function set() on null in C:\xampp\htdocs\gastro\administrator\components\com_login\controller.php on line 36


    Einfacher Fehler???? Kann mir geholfen werden?
    Vielen Dank.

  • Dann will ich mal - es klingt etwas ungewohnt, was du schreibst. Und offen gestanden kann ich nichts damit anfangen (die anderen anscheinend auch nicht).


    Du hast deine Joomla-Installation (alle Dateien) in ein Verzeichnis unter htdocs deines xampp heruntergeladen?
    Danach deine Datenbank unter phpmyadmin eingerichtet. Kommst du mit phpmyadmin auf die Datenbank?
    Hast du deien confiuration.php angepasst?

  • Hallo @mistermint,


    @christine2 hat dir den richtigen Link herrausgesucht. Es scheint das bei dir das Datenbank update nicht geklappt hat.


    Wie in dem Link von @christine2 vorgeschlagen sollte das manuelle ausführen von


    Code
    1. ALTER TABLE `#__redirect_links` ADD header smallint(3) NOT NULL DEFAULT 301;
    2. ALTER TABLE `#__redirect_links` MODIFY new_url varchar(255);


    Auf der Datenbank das Problem beheben :)


    Zitat

    Notice: Undefined property: LoginController::$input in C:\xampp\htdocs\gastro\administrator\components\com_login\controller.php on line 36Fatal error: Call to a member function set() on null in C:\xampp\htdocs\gastro\administrator\components\com_login\controller.php on line 36


    Hier würde ich nocheinmal das 3.4.1 stable Paket entpacken und (ohne den Ordner installation) überspielen. Es scheint das einige Dateien in der Migration nicht richtig ersetzt worden sind.

  • Ich hatte mit meiner Seite auch Probleme, es von 2.5,28 auf 3.4.1 zu migrieren (Thema: weiße leere Seiten). Irgendwo hatte ich die Idee aufgeschnappt, vor dem Migrieren sämtliche Dritterrweiterungen zu deaktivieren bzw. deinstallieren. Und siehe da, dann hat es auch geklappt. Nun nach und nach die deaktivierten Extensions wieder aktivieren und dabei das Verhalten der Webseite beobachten. Muckelt es nach der Aktivierung einer Erweiterung, kennt man den Verursacher. Dann muss dieser erneuert werden (auf 3.4.x-Tauglichkeit achten!).