Eigenes Modul nicht mehr bearbeitbar

  • Hallo zusammen, ich schließe mich mal an, denn möglicherweise habe ich ein ähnlich gelagertes Problem
    (wenn nicht bitte gerne verschieben):


    Seit dem Update auf 3.8.1 habe ich bereits ein Update eines (selbst programmierten) Moduls problemlos aufspielen können. Bei einem andere lässt sich die default.php aber "ums verrecken" nicht aktualisieren. Joomla lädt ständig die alte Version, obwohl die gar nicht mehr auf dem Server ist! Alle anderen Moduldateien (php, js, css) werden aktualisiert, völlig mysteriös :-(


    Das habe ich bereits alles versucht:

    • komplette De- und Neuinstallation
    • Cache geleert (nach der Modul-Neuinstallation in der Verwaltung)
    • "Abgelaufenen Cache" geleert
    • Hosting-Support nach Serverspezifischen Einstellung abgeklopft

    Über einen Tipp wäre ich total dankbar!

  • Danke für die schnelle Antwort - ich schreibe jetzt erst mal in diesem Thread weiter - ok?


    Ja, es ist eine eigene Erweiterung, die bisher problemlos funktionierte. Ich musste eine Funktion hinzufügen, was auf meiner Testumgebung auch funktionierte. Habe auch kurzfristig php-Fehlermeldungen aktiviert, um hier gegf. Probleme ausschließen zu können.
    Auf dem Server liegt eine überarbeitete default.php im Verzeichnis tmpl/ es wird aber eine alte ausgegeben, die gar nicht mehr da sein dürfte/ist.
    Die neue Javascript-Datei und ein überarbetetes Stylesheet werden korrekt eingelesen.

    Zitat

    tmp-Ordner leeren als Einstieg.


    tmp-Ordner ist leer.
    Auch das leeren des Servereigenen tmp-Ordners hat nichts gebracht.


    Ich habe schon einige Komponenten und Module geschrieben, aber so etwas hatte ich noch nie.

  • ich schreibe jetzt erst mal in diesem Thread weiter - ok?


    Nein, siehe Forenregeln!
    Eigene Frage eigenes Thema, alles Andere ist "Thread kapern" und das ist nicht fein. Darum habe ich es in den passenden Bereich mit einem eigenen Thema verschoben.

  • Entschuldigung - ich war verunsichert, weil ich keine Benachrichtigung über das Verschieben erhalten hatte.


    Vielleicht hat trotzdem jemand Lust sich damit zu befassen, ich habe den Branch auf github aktualisiert:
    https://github.com/xinelope/jbarometer


    Ich komme nicht einfach weiter :-(
    Hier der Link zur Zielseite:
    http://www.stadtkirche-winnenden.de/spendenbarometer


    Im Moment wird ein JS-Fehler angezeigt, weil das DOM-Element wegen des fehlenden neuen Templates nicht gefunden wird.
    Vielleicht habe ich in der default.php einen Fehler eingebaut und bin einfach betriebsblind.

  • Im Moment wird ein JS-Fehler angezeigt,


    Mir wurde gerade kein JS Fehler angezeigt. Zumindest habe ich keinen gesehen.


    Bei einem andere lässt sich die default.php aber "ums verrecken" nicht aktualisieren.


    Was hat sich denn von der alten auf die neue Version genau geändert?