Problem beim Anzeigen der Bilder mit Sigplus

  • Hallo liebe Leute,


    ich möchte das Modul Sigplus (https://extensions.joomla.org/extension/sigplus/) zum Anzeigen von Fotos in Joomla nutzen.


    Meine vorhandene (noch aktive, aber in bezug auf Webdesign total veraltete) Vereinswebseite www.mcv-moemlingen.de hat tausenden von Fotos, die in Verzeichnissen und Unterverzeichnissen des Root liegen.

    Nun möchte ich die Webseite auf Joomla umstellen, habe hierfür eine Test-URL eingerichtet (test.mcv-moemlingen.net). Allerdings möchte ich nicht alle Fotos in den Image Order des Joomla Verzeichnisse kopieren.

    Deshalb habe ich bei sigplus unter "Bilderordner" den relativen Pfad zu den vorhandenen Fotos eingestellt (in diesem Fall: ../../Fotoalben/1953/fotos/):




    Sigplus zeigt mir nun die Fotos auch als Thumbnails an.

    Sobald ich aber auf einer der Fotos klicke um die Slideshow zu starten bzw. das Foto in groß zu sehen, erhalte ich nur ein Warnzeichen:




    Das ganze kann live auf meiner Testseite http://test.mcv-moemlingen.net/index.php/1953 angeschaut werden.


    Hat evtl. jemand eine Lösung für mich oder muss ich tatsächlich die ganzen Fotos in das Joomla-Verzeichnis umkopieren?


    Vielen Dank im Voraus für Eure Hilfe und Tipps


    Kurt

  • Deine Foto-Vorschau liegt im Cache.


    Was bedeutet im relativen Pfad?


    Liegen die Fotos im Joomlaroot oder noch irgendwo auf der alten Seite?


    Auf der alten Seite ist es eine .jpeg-Datei.

    Die fehlt aber in deiner neuen Installation.


    Ich würde alle Bilder in den Ordner /joomla/ wie-auch-immer kopieren und dann darauf verlinken.


    Dann sollte es funktionieren.

  • Hallo Elwood,


    die Fotos liegen außerhalb des Joomlaroot, noch auf der alten Seite:


    Joomla Installation: <root>/joomla_05/

    Fotos: <root>/Fotoalben/1953/fotos/


    Wie erwähnt, wollte ich die Fotos nicht alle in das Joomlaroot umkopieren, da die "alte Seite" ja noch so lange weiter laufen soll, bis ich die Joomla Seite fertig gestellt habe

    Es sind ja auch sehr viele Daten (Fotos), die umkopiert werden müssten und diese würden dann erst einmal doppelt auf dem Server vorhanden sein und natürlich auch sehr viel Speicherplatz in Anspruch nehmen.

    Deshalb dachte ich, dass ich mit den Angaben des Speicherorts auch auf die Fotos zugreifen kann. Sigplus liest sie ja für die Thumbnails auch aus... ??

  • Hi Re:Later,


    ich muss mit meinen 59 Jahren noch viel dazu lernen und erst mal die Sachen kapieren, die ihr Experten da so schreibt dance


    auf der Seite https://perishablepress.com/us…nks-without-shell-access/ habe ich mir noch einmal die Vorgehensweise durchgelesen.


    Die gewünschten Fotos liegen im Rootverzeichnisses meines Webspaces unter "Fotoalben/1953/fotos/"

    Das Joomlaroot ist ist dort unter "joomla_05/" erstellt.


    Ich habe eine PHP-Datei mit folgendem Inhalt angelegt und in diese in das root-Verzeichnis meines Webspaces kopiert:


    PHP
    1. <?php symlink('/Fotoalben/1953/fotos/', '/joomla_05/images/fotoalben/1953/fotos'); ?>


    Dann habe ich über den Browser diese Datei angeklickt. Es erschien eine leere, weiße Seite.


    (Zitat: Next, trigger the function by calling the PHP file via your browser. If you see a blank page, you are good to go.)


    Als Pfad in sigplus habe ich "fotoalben/1953/fotos" eingegeben, bekomme aber diese Fehlermeldung im Frontend:


    [SIGPLUS_EXCEPTION_SOURCE] Die Bild-Quelle muss eine vollständige URL oder ein Pfad relativ zum Basis-Ordner sein wie im Backend angegeben. Aber /fotoalben/1953/fotos ist weder eine URL noch ein Pfad relativ zu einer existierenden Datei bzw. Ordner.


    In Filezilla wird im joomlaroot unter "images/fotoalben/1953" das Verzeichnis "fotos" jedenfalls nicht angezeigt :(

    Allerdings weiß ich nicht, ob symlink tatsächlich eine sichtbare Datei erstellt wird und diese im FTP-Programm sichtbar ist...


    Jetzt weiß ich nicht, ob


    a.) mein Provider STRATO kein Symlink zulässt

    b.) ich einen Fehler in der PHP-Datei gemacht habe oder

    c.) ich den falschen Pfad in Sigplus eingegeben habe.

    d.) ich komplett falsch liege


    Ich muss mich also morgen nochmals damit beschäftigen.


    Falls Du den Fehler hieraus auslesen kannst, wäre es schön, wenn Du ihn mir nennen könntest.


    Schönen Abend noch und vielen Dank!

    Kurt





  • Allerdings weiß ich nicht, ob symlink tatsächlich eine sichtbare Datei erstellt wird und diese im FTP-Programm sichtbar ist

    Ja. Sieht in FielZilla bspw. so aus


    Zu deiner Codezeile. Das sind nicht absolute Pfade deines Servers, die du da angibst!


    Gehe in die Joomla-konfiguration und spicke dir aus den Feldern Tmp-Verzeichnis oder Log-Verzeichnis den vorne noch fehlenden Teil ab, damit du den absoluten Serverpfad bis zum Joomla-ROOT hast.


    Bei SIGPLUS kenne ich mich nicht besonders aus. Wenn als voreingestellter Wert images in dem Feld drinnen steht, müsste es bei dir dann images/fotoalben/1953/fotos sein. Also ohne Slash vorne.


    Sollte es /images sein (glaub ich eher nicht), dann /images/fotoalben/1953/fotos


    Oder halt fotoalben/1953/fotos.


    Mit Schrägstrich vorne ist das kein RELATIVER Pfad, sondern wird als ABSOLUTER interpretiert.


    Aaaber: Ehrlichgesagt glaube ich nicht, dass du an dem Feld irgendwas ändern musst. Es sollte reichen, images drinnen zu haben. SIGPLUS geht es um das Startverzeichnis der Bilder.

  • Hallo Re:Later


    vielen Dank für den Tipp zum absoluten Serverpfad.

    Ich habe den entsprechend eingetragen und die Codezeile sieht jetzt so aus:

    PHP
    1. <?php symlink('/mnt/web024/c0/70/52030670/htdocs/Fotoalben/1953/fotos/', '/mnt/web024/c0/70/52030670/htdocs/joomla_05/images/fotoalben/1953/fotos'); ?>

    Damit konnte ich auch den Symlink durchführen und es funktioniert.


    Allerdings sehe ich bei mir in FileZilla das Pseudoverzeichnis nicht, wie auf Deinem Screenshot als Ordnerverknüpfung.

    Es wird Im Pfad "Joomla_05/images/fotoalben/1953/" kein Ordner "fotos" angezeigt):



    Da ich allerdings sehr viele Foto-Ordner der letzten 66 Jahre in verschachtelten Unterordner auf dem Server liegen habe und ich diese Unterordnerstruktur im joomlaroot wieder abbilden will, müsste ich sehr viele Symlinks mittels php-Dateien durchführen.


    Daher wäre der Vorschlag von Elwood, alle Fotos in den Joomla-Ordner umzukopieren soweit ok, aber ich finde kein Programm mit welchem ich direkt auf dem Server das Umkopieren vornehmen könnte.

    Die einzige Möglichkeit wäre die Fotos per FTP herunter zu laden und dann ins neue Verzeichnis hoch zu laden. Auch das ist eine sehr umständliche Methode.

    Schön wäre es, wenn es ein Photo-Gallery Programm gäbe, in welchem man einfach den Pfad zu Dateien außerhalb des Joomla Verzeichnisses eingeben könnte.

    Aber da auch Phoca Gallery das nicht kann habe ich wenig Hoffnung.


    Vielen Dank nochmal an Dich und Elwood für die schnelle Hilfe!


    Kurt


    PS:

    Ich werde bestimmt noch viele Fragen haben, bis die Homepage umgestaltet ist, aber dadurch lerne ich auch viel dazu.

    Hoffentlich nerve ich Euch Experten damit nicht zu sehr.