.htaccess - trailing slash wird nur auf der Hauptseite entfernt?

  • Hallo,

    ich habe auf meiner Website das Problem, dass der trailing slash nur auf der Startseite entfernt wird, aber nicht auf den Unterseiten. Ich bin wirklich mit der .htaccess total überfordert, bei mir geht da alles nur nach try & error Prinzip. Viele der vorgeschlagenen Lösungen im Netz scheinen ohnehin bei mir nicht zu funktionieren, eine von 5 vielleicht.


    Ich habe joomla 3.8.x und wichtig sind in der .htaccess folgende Sachen:

    - überschreiben von http zu https

    - das entfernen von /index.php/ in der URL

    - die trailing slash am Ende der Seiten entfernen


    Alles soll meinen seo score verbessern und doppelt erkannte Seiten vermeiden.


    Dies ist meine derzeitige .htaccess:

  • Das Entfernen von /index.php hat zwar keinen Einfluss auf dein Ranking, schadet aber nicht. Doch das mit dem Trailing Slash und Duplicate Content ist Quatsch. Das ist kein DC, solange es unter der gleichen Domain ist. Abgesehen davon erfindet Google keine URLs, wie soll er also plötzlich auf URLs mit zwei oder gar drei Trailing Slashes kommen?


    Man kann seine Webseite auch zu Tode optimieren ;)

  • Hallo anka,

    das sehe ich anders. Sämtliche SEO tools melden hier doppelte inhalte. Seobility tut es, ryte auch etc. Diese werden als kritisch bzw. schwerwiegend klassifiziert.


    Was allerdings seltsam ist - es handelt es sich schon wieder um die Unterseite /fotos die schon vorher Probleme verursachte (wir sprachen darüber; diese Probleme sind immer noch nicht behoben).


    Andere Unterseiten werden nicht als problematisch gemeldet obwohl auch dort man die Seite mit und ohne das "/" am Ende aufrufen kann.

  • Lass an deine URLs mal eine Datei-Endung ranhängen! Dann gibt es sogar 3 Möglichkeiten. Mache ich seit Jahren. Negative Auswirkungen = 0.


    Teils werden in den Analyse-Tools sogar Dinge bemängelt, die man rein technisch gar nicht ausführen kann. Negative Auswirkungen = 0.


    Warum du die "Rüge" nur bei "/fotos" bekommst, kann ich dir nicht sagen. Vielleicht kommen die anderen ja noch.

  • Das sind nicht doppelte Inhalte, sondern doppelte Seitentitel. Meines Wissens ist das aber nicht weiter tragisch. Google ist nicht ganz doof. Er merkt ganz genau, wenn eine Seite mit einem CMS aufgebaut ist und weiss, dass dann eine Seite u.U. über mehrere URLs zu erreichen ist. Das wird unter normalen Umständen nicht abgestraft.


    Ich kann mich nur wiederholen: Man kann seine Webseite auch zu Tode optimieren!


    PS:

    Um herauszufinden, warum die Foto-Unterseiten verschiedene URLs produzieren (s.hier), müsste man sich im Backend mal genauer umschauen. So aus der Distanz kommt man da nicht weiter.

  • Hallo,


    Trailing slash DC etc. dazu hat ja Anka schon erklärt. Huch, sehe gerade, gibt neue posts.


    Was mich persönlich eher stört bzw. stören würde, ist dieser Pre-loader & dass die Seite(n) lange zum Laden braucht.


    Bin schon wieder weg, denn mit SEO kenn ich mich nicht aus.


    Liebe Grüße
    Christine

  • Also vielleicht ist es nicht so schlimm, nur die melden es halt und man möchte natürlich möglichst das beste Ranking haben, zumindest so um die 80%.


    JoomlaWunder

    Bei mir wird es immer von no-www auf www umgeleitet. Jedes mal. Kein Problem.


    christine2

    Ja, diese Ladezeiten sind echt krass teilweise. Das liegt wohl an diesen Baukastensystem "SP Page Builder" den ich nutze, der gibt mir zwar viele gute Möglichkeiten, aber es belastet das System auch um einiges mehr als normales Joomla. Ich will das künftig auf normales nach und nach Joomla umändern, doch das würde jetzt zu lange dauern und ich weiß nicht ob ich alles davon umsetzen können werde.


    anka

    Ich kann ja bei Gelegenheit eine Kopie der Seite erstellen und dann kannst du dich dort austoben wenn du möchtest.

  • JoomlaWunder

    Bei mir wird es immer von no-www auf www umgeleitet. Jedes mal. Kein Problem.

    Nun ja..... gestern wurde der Nicht-WWW-Aufruf auf https://www\. weitergeleitet. Heute scheint es zu funktionieren. Was mir auch noch aufgefallen ist, Es wurden teils Bilder geladen, die 900kB hatten. Insgesamt würde ich die Seite abspecken. Was das mp4 mit 178 MB auf der Startseite zu suchen hat oder hatte, ist mir auch schleierhaft.....


    Insgesamt könntest du noch einiges optimieren! Die vielen Scripte/CSS habe ich mir dabei noch nicht einmal angeschaut.

  • Nun ja..... gestern wurde der Nicht-WWW-Aufruf auf https://www\. weitergeleitet. Heute scheint es zu funktionieren. Was mir auch noch aufgefallen ist, Es wurden teils Bilder geladen, die 900kB hatten. Insgesamt würde ich die Seite abspecken. Was das mp4 mit 178 MB auf der Startseite zu suchen hat oder hatte, ist mir auch schleierhaft.....


    Insgesamt könntest du noch einiges optimieren! Die vielen Scripte/CSS habe ich mir dabei noch nicht einmal angeschaut.

    Das kann durchaus sein, dass es kurzfristig gestern so gewesen ist. Ich hatte nämlich verschiedenes ausprobiert. Das Video wird noch gekürzt, allerdings hätte ich es schon gerne drin. Dafür ist diese Funktion da um im Hintergrund ein Video laufen zu lassen.


    Das ganze basiert auf dem SP Page Builder Lite Baukastensystem und somit weiß ich selbst nicht wie ich die Scripte optimieren sollte. Mit normalen Joomla Beiträgen kann ich wohl so etwas wie mit dem SP PB nicht erschaffen. Zumindest ich nicht.

  • 19thai89 es reicht wenn Du erst mal die Bilder besser komprimierst und nicht so hochauflösend verwendest und das Video auch.
    Für Skripte und CSS gibt es z.B. den JCH-Optimizer.


    Pagebuilder haben leider von Haus aus einen Coderoverhead. Schlanke, schnell ladende Seiten, schreibt man selber.

  • Ich habe das Video verändert, jetzt sind es "nur" noch 99 MB. Habe dafür andere Szenen eingebaut. Allerdings werde ich es wohl noch weiter verkleinern und verkürzen.


    Zusätzlich habe ich noch das plugin "Jch" installiert was die Site weiterhin beschleunigt hatte.