Problem mit Joomla! Backend (Joomla!-Version 3.4.3) Backend Funktionalität mit SSL ( https ) nicht mehr möglich

  • Liebe Forum Teilnehmer und Leser,


    nachdem ich mit !Joomla mich doch ganz gut auskenne und bereits einige Installationen erfolgreich am Laufen habe, bin ich mit meinem jüngsten Projekt heute auf ein Problem gestoßen, dass ich bislang so nicht kannte. Daher meine Bitte an Euch, mir an dieser Stelle zu helfen:


    1. Anzeichen: Der berühmte weiße Bildschirm im Backend - Zugang zum Backend war nicht mehr möglich: https://www.meinedomain.de/administrator führte nur noch ins Leere. Das Problem ist im Netz ja groß diskutiert und ich habe mich über Stunden auf die Fehlersuche begeben - mit Erfolg! Ursache ist die Umleitung auf SSL, das Joomla dazu veranlasst, den weißen Bildschirm zu zeigen.


    2. Fehleranalyse (https://www.meinedomain.de/administrator: Element untersuchen im Browser Chrome):


    Mixed Content: The page at 'https://www.meinedomain.de/administrator/index.php' was loaded over HTTPS, but requested an insecure stylesheet 'http://www.meinedomain.de/media/system/css/modal.css'. This request has been blocked; the content must be served over HTTPS.


    Mixed Content: The page at 'https://www.meinedomain.de/administrator/index.php' was loaded over HTTPS, but requested an insecure script 'http://www.meinedomain.de/media/jui/js/jquery-noconflict.js'. This request has been blocked; the content must be served over HTTPS.


    Es ist mir klar, woran das Problem liegt, nur habe ich leider hierfür keine Lösung.


    Ich habe meine .htaccess wieder geändert und die RewriteCond zur Umleitung auf https für das Unterverzeichnis 'administrator' wieder heraus genommen.


    Das Administrator Backend läuft unter http fehlerfrei. Aber die Verschlüsselung für das Backend ist für uns in diesem Fall unumgänglich.


    Was habe ich geändert seit gestern? Die RewriteCond, die ich letztendlich wieder rückgängig gemacht habe.


    Was habe ich geändert in letzter Zeit? Update von Version 3.4.1 auf 3.4.3, Installation von JCE Editor (derzeit nicht aktiviert im Template), Aimy Canonical (aktiviert), NoNumber Modules Anywhere (aktiviert)


    Trotz der Installationen lief alles noch einige Tage fehlerfrei weiter, bis heute morgen plötzlich das Backend nicht mehr navigierbar wurde. Die Icons im Backend wurden nicht mehr geladen und Javascript funktionierte nicht mehr (keine Links waren mehr aktiv).


    Zur Server-Konfiguration:
    PHP Version: 5-55STABLE-STANDARD
    MySQL Version: 5.6.19


    Für Eure Unterstützung sage ich herzlichen Dank im Voraus.


    Beste Grüße
    Stefan

  • Code
    1. Ich habe meine .htaccess wieder geändert und die RewriteCond zur Umleitung auf https für das Unterverzeichnis 'administrator' wieder heraus genommen.


    Versteh nicht ganz. Warum konfigurierst nicht Jomla für SSL, sondern machst das per Rewrite via .htaccess? Dann musst halt auch mühsam die eingebundenen Dateien "rewriten".


    Sollte das aber der Fall sein (Joomla korrekt konfiguriert), dann reiche es als Bug ein.

  • Hallo Later, vielen Dank für Deine Nachricht.


    Ich habe beides probiert, mit gleichem Ergebnis. Ob ich SSL durch das Backend erzwinge, oder es über .htaccess rewrite, führt zum gleichen Ergebnis.


    Zwischenzeitlich bin ich auf etwas gestoßen, was die Ursache (mit) sein könnte: Im Backend wird in der Seite keine base URI im <Head> ausgegeben. Womöglich liegt es daran, dass die CSS und JS Dateien als http und nicht als https geladen werden.


    Kannst Du mir sagen, wir ich einen Bug melden kann?


    Vielen Dank!

  • Zitat

    Kannst Du mir sagen, wir ich einen Bug melden kann?


    Mit ausreichenden Englischkenntnissen (muss nicht perfekt sein): https://github.com/joomla/joomla-cms (registrieren, Issues klicken, New ODER falls du schon eine Codelösung hast via Pull requests. Nachvollziehbare Testanleitung (gemachte Einstellungen) ist A und O. (Vor)Tester dort kommen nicht nur aus dem Coder-Bereich.)


    Deutsch: http://www.joomla-bugs.de/
    Auch hier Testanleitung nicht vergessen, damit schnell reagiert werden kann.


    EDIT: Vielleicht kann wer die Anleitung für Github-PullRequests nachreichen? Ich meine die einfache per Browser ohne mehrtägige ;-) Einrichtung einer Entwicklungsumgebung. Bei mir macht das immer ein Kumpel für mich, der besser Eng kann.

  • Die Ursache ist nun identifiziert.


    Es sind definitiv unsichere Inhalte im Backend, die im Browser nicht unter https geladen werden können, weswegen alle Browser, die Webkit verwenden, an dieser Stelle aussteigen und den berühmten weißen Bildschirm zeigen. Safari steigt an dieser Stelle beispielsweise nicht aus.


    Da das Problem nur im Backend auftritt und auch nur mit dem Isis-Administrator-Template, kann es nur ein Bug in der Joomla! Version 3.4.3 sein. Eine andere Erklärung habe ich dafür nicht.


    Die Frage, die sich jedoch stellt, wieso der Fehler plötzlich und unerwartet aufgetreten ist. Ich werde den Bug entsprechend melden.

  • Hallo Later,


    zwischenzeitlich, nach einem längeren Gespräch mit meinem Hoster, sind wir auf die Ursache des Problems gekommen.


    Um duplicated Content zu verhindern, wurde uns geraten, alle Seiten im Frontend auf http umzuleiten, da Google einzelne https Seiten im Index geführt hat. Das habe ich getan, indem ich die Verzeichnisse 'administrator' und 'analytics' durch eine RewriteCond ausgeschlossen habe, und alles andere zwingend auf http umgeleitet habe.


    Mit dieser Regel habe ich aber auch die Unterverzeichnisse 'media', etc. von https ausgeschlossen. In /media/jui/ u.a. liegen aber entsprechende Skripte, die nun nicht mehr unter https geladen werden konnten, wodurch dieses Problem entstanden ist.


    Also kein Bug, sondern ein selbst inszeniertes Problem, das mich und Euch wertvolle Zeit gekostet hat. Sorry! Dennoch herzlichen Dank für die Unterstützung und das Mitdenken. Das Problem ist somit gelöst!

    • Hilfreich
    Zitat

    Um duplicated Content zu verhindern, wurde uns geraten, alle Seiten im Frontend auf http umzuleiten, da Google einzelne https Seiten im Index geführt hat.


    Google bevorzugt mittlerweile https-Seiten. Klare Empfehlung seitens Google. Man behält sich noch vor zu entscheiden, wie sehr sich damit Ranking-Vorteile erzielen lassen.


    Leichte Vorteile für https-Seiten aber bereits jetzt schon (ungeprüft aus dem Gedächtnis).


    Und in diesem Zusammenhang von "duplicated Content" zu reden (wie so oft), ist schlicht falsch, wenn damit zu befürchtende, angebliche Abwertungen gemeint sind. Die Google-Algorithmen sind ja nicht doof, kennen die Eigenheiten der CMS-Systeme, kennen SSL, werten innerhalb der selben Domain nicht ab etc. pp.. Darfst natürlich kein Proxy-Zertifikat über andere Domain verwenden.