Nach Joomla Update auf 3.8.6 - website bringt HTTP 500 Error

  • Hallo community


    Ich brauche Hilfe. Nach einem Update auf auf 3.8.6 bringt meine Website einen HTTP 500 Error, was bedeutet: ich habe ernsthaft ein Problem, denn ich bin wirklich ein N00b. Ich befürchte, dass die Datenbank ein Problem hat oder weiss der Henker sonst was im Argen liegt, auf jeden Fall komme ich an dieser Stelle überhaupt nicht mehr weiter.

    In der Global Configuration -> Site Settings SEO Settings hab ich die Search Engin Friendly URL bereits deaktiviert, bringt auch nichts (damit hatte ich früher mal ein Problem, daher kannte ich den Tick noch). Aber da hört mein Latein auch schon auf.


    Gibt es hier im Forum jemanden, der mir helfen kann?

    Tausend Dank im Vorraus!

  • Wenn du ins Backend kommst, hat die Datenbank erst mal kein Problem.

    Trotzdem unter Erweiterungen > Datenbank den Reparieren-Button klicken.


    Wenn du eh ins Backend kommst, mach doch auch gleich das Update auf 3.8.10.


    Stelle zuvor auf das Protostar-Template um.


    Poste hier einen Link.


    Stelle in der Konfiguration "Fehler berichten" auf "Maximum".


    Aktiviere zusätzlich den Debug-Modus für "Seite", nicht "Sprache".


    Prüfe, dass MySqli (endendes i ) in der Datenbankeinstellung gewählt ist.


    Schau dann, ob dir eine ordentliche Meldung angezeigt wird.

  • Hallo zusammen, danke schon mal für die Tipps!


    Hab grade gesehen, dass der Update auf 3.8.6 wohl gar nicht geklappt hat?! (obwohl Meldung gestern "Erfolgreich"):


    =============

    System Information

    =============

    php: Linux n3plcpnl0007.prod.ams3.secureserver.net 2.6.32-773.26.1.lve1.4.46.el6.x86_64 #1 SMP Tue Dec 5 18:55:41 EST 2017 x86_64

    dbversion: 5.6.39-cll-lve

    dbcollation: latin1_swedish_ci

    dbconnectioncollation: utf8mb4_general_ci

    phpversion: 5.6.36

    server: Apache

    sapi_name: litespeed

    version: Joomla! 3.6.5 Stable [ Noether ] 1-December-2016 22:46 GMT

    platform: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

    useragent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36


    Und noch besser: Als ich grade einloggte wurden mir dieselben Update packages wieder angeboten, die ich gestern angeboten bekommen hatte (Anhang).

    Unter Extensions/Warnings habe ich folgende Fehlermeldungen gefunden:


    The PHP temporary folder is not set.
    The PHP temporary folder is the folder that PHP uses to store an uploaded file before Joomla can access this file. Whilst the folder not being set isn't always a problem, if you are having issues with manifest files not being detected or uploaded files not being detected, setting this in your php.ini file might fix the issue.

    Maximum PHP file upload size is too small: This is set in php.ini in both upload_max_filesize and post_max_size settings of your PHP settings (located in php.ini and/or .htaccess file).
    The maximum file size for uploads is set to less than 8MB which may impact on uploading large packages.



    Re:Later : dbtype ist mysqli. Habe das Error Reporting auf Maximum gestellt.

    Allerdings frage ich mich grad schon, was das eigentliche Problem ist... zumal gar kein Upgrade durchgeführt worden ist. Und ich hab keine Ahnung, wo suchen..


    @Indigo: Ausgangsversion war (und ist demnach immer noch) Joomla 3.6.5. Wie gesagt, ich bin ein blutiger Anfänger, in der Regel führe ich ein Update durch, wenn ein Update Package Update angezeigt wird, nicht einfach auf eigene Faust.

  • Generiere mit einem Editor (PSPAD oder ähnliches) mal ein phpinfo.php mit folgendem Inhalt:

    PHP
    1. <?php
    2. phpinfo();
    3. ?>


    Lege diese ins Joomla-Verzeichnis und rufe diese auf, also http://www.example.de/phpinfo.php


    Welche Werte stehen bei upload_max_filesize und post_max_size?


    Sie könnten zu niedrig sein, um ein Update erfolgreich durchzuführen. Diese müssten dann erhöht werden.

  • Hallo zusammen


    Danke erneut für Eure Inputs!

    @Indigo: ich habe ich ja gestern den Update gemacht (ohne Fehlermeldung) und heute seh ich - der wurde nicht durchgeführt. Daher nein, habe ich nicht nochmals versucht, einen Update zu machen. Stattdessen habe ich die Fehlermeldungen gefunden und ja... das würde ja vielleicht (aber nur vielleicht), erklären, warum der Update nicht durchgeführt worden ist?


    JoomlaWunder : mache ich gleich und versuche ein Ergebnis zu bekommen - poste ich gerne hier, denn ich weiss ja mal wieder nicht, wo ich diese Änderungen machen müsste.


    Aber einen ganz neuen Update habe ich. Und ich hoffe ganz fest, dass jemand von Euch mir damit helfen kann, denn es ist ein konkreter Ansatz, ich versteh nur einfach rein gar nichts von PHP:


    Wenn ich die Site jetzt aufrufe kommt folgender Fehler:


    Fatal error: Using $this when not in object context in /home/adminsucht/public_html/libraries/joomla/filter/input.php on line 141


    Hab mir das File input.php runter geladen und finde da in Zeile 141 den fraglichen string:

    138 public function clean($source, $type = 'string')

    139 {

    140 // Strip Unicode Supplementary Characters when requested to do so

    141 if ($this->stripUSC)

    142 {

    143 // Alternatively: preg_replace('/[\x{10000}-\x{10FFFF}]/u', "\xE2\xAF\x91", $source) but it'd be slower.

    144 $source = $this->stripUSC($source);

    145 }


    Was bedeutet das? Respektive, was muss ich ändern?

    Das ganze input.php File ist im Anhang.


    Danke für Eure Hilfe!!!

  • Also... habe das phpinfo.php file erstellt und ins joomla Verzeichnis gestellt. Ich rufe die Site auf wie gesagt, aber es kommt nur die eben schon beschriebene Fehlermeldung:

    Fatal error: Using $this when not in object context in /home/adminsucht/public_html/libraries/joomla/filter/input.php on line 141




    Das File selber bleibt leer (Ansicht des Files in meinem Webhosting Backend):




    Nur um sicher zu gehen: joomla Vereichnis ist "public_html/libraries/joomla" ?



  • ja, habe ich schon gesehen. M.W. kann es aber auch sein, dass eine zu 3.8.6 bzw. 3.8.10 inkompatible Extension Ärger beim Update von Joomla verursachen kann.


    Versuche mal die php.info in dem Folder public_html auzurufen (dies ist in deiner konfi das Joomla Root-Verzeichnis).


    anka war schneller.

  • Habe grade zu dem Fehler noch gesucht im Netz.

    In der Joomla Global Configuration -> Server -> Server Settings ist das tmp Verzeichnis folgendes:

    /home/example/public_html/tmp


    Dazu hat der Betreffende geschrieben: "I have now fixed the problem by adding the correct path in the Joomla Global configuration server setting and also increasing the upload_max_filesize in .htaccess file (with php_value prefix)"


    Allerdings finde ich in meinem htaccess File nichts, was mit *upload* zu tun hätte.

    Hier mein htaccess File:


    ##

    # @package Joomla

    # @copyright Copyright (C) 2005 - 2016 Open Source Matters. All rights reserved.

    # @license GNU General Public License version 2 or later; see LICENSE.txt

    ##


    ##

    # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!

    #

    # The line 'Options +FollowSymLinks' may cause problems with some server configurations.

    # It is required for the use of mod_rewrite, but it may have already been set by your

    # server administrator in a way that disallows changing it in this .htaccess file.

    # If using it causes your site to produce an error, comment it out (add # to the

    # beginning of the line), reload your site in your browser and test your sef urls. If

    # they work, then it has been set by your server administrator and you do not need to

    # set it here.

    ##


    ## No directory listings

    IndexIgnore *


    ## Can be commented out if causes errors, see notes above.

    Options +FollowSymlinks

    Options -Indexes


    ## Mod_rewrite in use.


    RewriteEngine On


    ## Begin - Rewrite rules to block out some common exploits.

    # If you experience problems on your site then comment out the operations listed

    # below by adding a # to the beginning of the line.

    # This attempts to block the most common type of exploit `attempts` on Joomla!

    #

    # Block any script trying to base64_encode data within the URL.

    RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]

    # Block any script that includes a <script> tag in URL.

    RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]

    # Block any script trying to set a PHP GLOBALS variable via URL.

    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]

    # Block any script trying to modify a _REQUEST variable via URL.

    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})

    # Return 403 Forbidden header and show the content of the root home page

    RewriteRule .* index.php [F]

    #

    ## End - Rewrite rules to block out some common exploits.


    ## Begin - Custom redirects

    #

    # If you need to redirect some pages, or set a canonical non-www to

    # www redirect (or vice versa), place that code here. Ensure those

    # redirects use the correct RewriteRule syntax and the [R=301,L] flags.

    #

    ## End - Custom redirects


    ##

    # Uncomment the following line if your webserver's URL

    # is not directly related to physical file paths.

    # Update Your Joomla! Directory (just / for root).

    ##


    # RewriteBase /


    ## Begin - Joomla! core SEF Section.

    #

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    #

    # If the requested path and file is not /index.php and the request

    # has not already been internally rewritten to the index.php script

    RewriteCond %{REQUEST_URI} !^/index\.php

    # and the requested path and file doesn't directly match a physical file

    RewriteCond %{REQUEST_FILENAME} !-f

    # and the requested path and file doesn't directly match a physical folder

    RewriteCond %{REQUEST_FILENAME} !-d

    # internally rewrite the request to the index.php script

    RewriteRule .* index.php [L]

    #

    ## End - Joomla! core SEF Section.

  • 8MB bzw. 2MB sind schon ziemlich spartanisch.

    Bei PHP-Version 5.6.x sind diese Werte bei einem anderen Hoster für:

    post_max_size auf 48MB und

    upload_max_filesize auf 32 MB

    bei PHP-Version 7.0 auf

    post_max_size auf 48MB und

    upload_max_filesize auf 64 MB

    bei PHP-Version 7.1 auf

    post_max_size auf 76MB und

    upload_max_filesize auf 64 MB

    gesetzt.