Plugin Ladefehler

  • Und hat sich was gebessert?


    Wenn nein, Folgendes: Sonst muss ich aus der Ferne passen.


    1) In der Datei configuration.php die Zeile anpassen

    Code
    1. public $debug = '1';

    Beim Hochladen darauf achten, dass FileZilla unten keine "Fehlgeschalgene Übertragung" anzeigt. Wenn doch, auf Server Dateirechte (per Rechtsklick > Dateiberechtigungen...) für configuration.php auf 777 setzen. Alle Lesen/Schreiben/Ausführen und noch mal.


    2)


    Wie in Post #8, aber mit folgendem aufwändigeren Code:

    Es geht um die Login-Seite im Backend(!)

    Beim ersten Durchlauf ist maximal diese Fehlermeldung erlaubt:



    3.)

    Nach dem erneuten Laden der Login-Seite sollte stehen:


    4.) Code wieder entfernen.


    5.) Browser-Caches und Cookies löschen.


    6) Seite neu laden. Ggf. ist auch 2x nötig wegen der zuvor geleerten Session-Tabelle.


    7) Loginversuch.


    Falls Fehlermeldung




    runterscrollen:


    Unter "Protokollnachrichten" und betreffende Call Stacks zu den Meldungen posten



  • Also noch einmal vielen Dank.

    Aber wie bereits in meinen vorletzten Post geschrieben, hat nach dem FULL Paket alles wieder einwandfrei funktioniert.

    Hier noch mal meine Frage: Hast du eine Idee woran das gelegen haben könnte, damit ich verhindern kann, dass das wieder vorkommt?

  • Hast du eine Idee woran das gelegen haben könnte, damit ich verhindern kann, dass das wieder vorkommt?

    Kann schon mal vorkommen.


    Ich habe keine Ahnung, wie Euer Server konfiguriert ist. Erste Vermutung ist bei mir immer erst mal:

    Läuft deine Webseite unter fast-cgi, fcgi oder ähnlich genannt?

    Würde man unter Systeminformationen > Tablutator Systeminformationen sehen. Eintrag PHP-Interface für den Webserver


    Ein Muss ist das zwar nicht unbedingt, aber man sollte sich dann auch gut auskennen, damit Konflikte zwischen FTP-Usern (FileZilla) und PHP-Usern (Joomla) vermieden werden.


    Dann ist natürlich der Sprung 3.8.6 > 3.8.11 recht groß, deshalb, weil sich in Joomla derzeit sehr viel tut. Dateien werden verschoben, Lademechanismen optimiert/geändert und anderes, damit später ein Update auf Joomla 4 nicht zu kompliziert wird.


    Da kann es dann reichen, dass veraltete Dateien nicht gelöscht werden oder eben neue nicht hochgeladen wurden oder beides.


    Das Drüberbügeln eines FULL-Pakets mit anschließendem Reparieren ist bei mir immer erster Standardschritt, wenn ich defekte Kundenseiten bekomme. Hochladen dauert zwar etwas, aber man hat eine Fehlerquelle eben schon mal ausgeschlossen, wenn man darauf achtet, dass bei Übertragung der Dateien keine Fehler auftreten.


    Ganz kurz:

    - Backups (mindestens) vor Updates machen und immer ein paar lokal aufheben.

    - Zeitnah Joomla und Erweiterungen updaten. Bei komplexeren Erweiterungen auch Backup zuvor.

    - Reparieren-Button nach Joomla-Update auch klicken, wenn keine Fehler angezeigt werden (weil diese sich nur auf die DB beziehen, nicht aber veraltete Dateien).


  • Hallo


    Könntest du mir auch bitte weiterhelfen?


    Ich hab mich ebenfalls aus dem Admin ausgesperrt und auf der eigentlichen Seite fehlt einiges.


    Eigentlich wollte ich zwecks DSGVO das Plugin von Richeyweb verwenden, da ich nichts anderes gefunden habe, um Cookies vor Akzeptierung zu sperren und erst bei OK freizugeben.


    Irgendwie hab ich ein Plugin nach dieser Anleitung zuviel bearbeitet und jetzt komm ich nicht mehr ins Backend!


    Bin deine Anleitung durchgegangen (login.php bearbeiten, Full-Package raufspielen) und ging auch.

    Aber da dies alles nichts brachte, hab ich auch das aus Beitrag #21 versucht.


    Ich bekomm folgende Meldung nach einfügen des Codes in login.php.


    Code
    1. Fehler mit Plugins
    2. Meldungen: Array
    3. (
    4. [0] => plg_authentication_joomla ist nicht installiert oder nicht aktiviert.
    5. [1] => plg_authentication_cookie ist nicht installiert oder nicht aktiviert.
    6. )


    Auch nach mehrmaligem Reload der Seite kommt nichts anderes.


    Was könnte ich noch probieren?

    Danke für deine Hilfe!

  • Re:Later


    Es funktioniert wieder!

    Danke für den Beitrag!!


    PS: Da ja mit 1. 10. 2019 entschieden wurde, dass vor Cookie-Akzeptierung noch keine gesetzt sein dürfen und den Besuchern nicht den Zugang zu einer Seite verwähren darf, wenn sie den Cookie ablehnen bin ich auf der Suche nach einer LKösung, die opt-in/opt-out kann und auch wirklich die Cookies nicht setzt wenn es verlangt wird. Ausserdem muss der Besucher jederzeit wieder die Möglichkeit haben, Cookies doch zu akzeptieren.


    Wäre toll, wenn du dazu Tipps hättest.


    DANKE