Kein Einloggen ins BackEnd möglich

  • Grüß euch alle miteinander :)


    bei mir ist folgendes Problem aufgetreten:

    Sobald ich mich ins Backend einloggen will kommt folgende Fehlermeldung:


    Weis jemand darüber Bescheid? Bei "Zurück zum Kontrollzentrum" komm ich wieder zu der Login-Oberfläche.


    Danke schon mal im Voraus :)

    lg

  • Hallo und Willkomen im Forum !


    Grundlegend immer wichtig!:

    Welche Joomlaversion nutzt du?

    Welche PHP version läuft?

    Was hast du zuletzt geändert?

    Hast Du deinen Provider angeschrieben ob er evt. was geändert hat (z.b. die php version)

    funktioniert dein FE noch?

    Welche erweiterungen hast du installiert?

    Hast du zuletzt ein update von irgendwas gemacht?

  • Danke^^


    Joomla-Version: 3.8.8

    PHP-Version: 7.2


    Habe eigentlich ziemlich lange nichts geändert. Ich betreue nämlich die Homepage unserer lokalen Feuerwehr und da hat sich in den letzten zwei Monaten nichts getan. Und bis dahin hat immer alles funktioniert.

    Frontend funktioniert noch einwandfrei (ich nehm mal an, dass FE = Frontend)


    Die Erweiterungen hab ich mir leider nicht gemerkt so wirklich fällt mir grad auf :-/
    Auf die schnelle würde mir nur das iCagenda (Kalender) und die Galerie einfallen


    nein hab keine Updates gemacht... hab durch einen tippfehler die aufforderungsmails zum aktualisieren nicht bekommen und dadurch seit zwei monaten ca von nichts ein update gemacht

  • Nein

    als ich heute ins BE eben nicht einsteigen konnte hab ich einmal bei wolrd4you nachgesehen und dort wurde mir angezeigt ich muss auf 7.2 aktualisieren

    was ich dann auch gemacht habe

    funktioniert aber trotzdem nicht

    kann es sein, dass das einfach längere zeit braucht? kann ich mir eigentlich nicht wirklich vorstellen

  • Ändere mal in der configuration.php Zeile

    Code
    1. public $debug = '1';
    2. public $error_reporting = 'maximum';

    Ob dir dann ein CallStack, Backtrace oder wie auch sonst genannt angezeigt wird (= der Weg zum Fehler).


    Beim Hochladen der configuration.php per FTP darauf achten, dass dir kein Übertragungsfehler angezeigt wird. Dann musst erst via FTP die Dateirechte auf 777 ändern (auf der Serverseite), damit du die geänderte Datei hochladen kannst.

    (Wenn du dann ins Backend später wieder reinkommst, 1 x die Konfiguration speichern, damit die Dateirechte wieder richtig gesetzt werden.)

  • Hallo,

    ... und dort wurde mir angezeigt ich muss auf 7.2 aktualisieren

    müssen musst Du gar nicht. Ist ein Aktualisierungsvorschlag. Ich selbst habe es noch bei 7.1 belassen.

    Kann sein, dass bestimmte Erweiterungen (noch) nicht mit 7.2 klarkommen.


    Fatal error: Call to a member function get() on null > da fehlt noch, wo .... eventuell (?):

    administrator/components/com_login/models/login.php


    Du bist auf Joomla 3.8.8. Es gab etliche Fixes bei J 3.8.9 / J 3.8.10 / J 3.8.11.

    Mach mal das update auf: J 3.8.12 - dann sehen wir weiter. Bleibe auf PHP 7.1 einstweilen.


    Auch iCagenda und Galerien hatten updates.


    Liebe Grüße

    Christine


    Edit: nächstes Mal bitte ein lautes Piepsen Re:Later - unsere posts haben sich überschnitten :-)

  • Du bist auf Joomla 3.8.8. Es gab etliche Fixes bei J 3.8.9 / J 3.8.10 / J 3.8.11.

    Mach mal das update auf: J 3.8.12 - dann sehen wir weiter. Bleibe auf PHP 7.1 einstweilen.


    Auch iCagenda und Galerien hatten updates.

    naja... ich komm ja nicht ins backend, wie kann ich dann das system aktualisieren?


    bin nicht grad der beste bei joomla ?(

  • Wo genau stellst du denn die PHP-Version um?

    Könnte es sein, dass in deiner .htaccess (falls vorhanden) bereits eine PHP-Versionseinstellung erfolgt, die möglicherweise mit der Hostereinstellung kollidiert.

    Oft kann man die PHP-Version beim Hoster global oder für jedes Verzeichnis einzeln einstellen. Abweichend davon kann man eine Änderung per .htaccess-Eintrag vornehmen, welche dann Vorrang hat.

    Beide Einstellungen sollten nie auf die gleiche PHP-Version eingestellt sein, da der Server sonst Probleme bekommen kann.

    Ich denke auch, dass es ein Problem mit der PHP-Version ist.


    Lege mal eine phpinfo.php mittels Notepadd++ oder PSPAD oder...... an mit folgendem Inhalt:

    <?php

    phpinfo();

    ?>


    Diese Datei schiebst du in dein Joomla-Verzeichnis und rufst sie auf: http://www.example.com/phpinfo.php

    (natürlich mit deiner Domain)

    Welche PHP-Version wird angezeigt?