Speichern fehlgeschlagen! Fehler: The table '#__finder_tokens' is full

  • Beim Speichern meines Hauptbeitrags im JCE Editor kommt es zur Fehlermeldung "Speichern fehlgeschlagen! Fehler: The table '#__finder_tokens' is full". Die Quittierung mit dem "Abbrechen"-Button führt dann trotzdem zum Speichern des Beitrags. Insofern ist der Leidensdruck begrenzt - trotzdem wüßte ich gerne, was die Ursache ist.

    (System: Win10 Pro, Joomla min. 3.6, soweit ich erinnere bis aktuell 3.8.12)

  • Dies scheint der richtige Weg zu sein. Nach Deaktivieren der Einträge Suchindex_Inhalt und Inhalt_Suchindex kam es nicht mehr zu der Fehlermeldung. Kann man den Suchindex auf Dauer inaktivieren (mit welchen Folgen?), die entprechenden Tabellen händisch löschen oder leeren und wo finde ich die Tabellen?

  • Bin gerade nicht Online, aber die Einträge solltest Du unter Erweiterungen - Suchindex oder so ähnlich sehen. Die Einträge dann einfach anhaken und auf "Löschen" klicken.


    Wenn Du das Plugin deaktivierst, passiert gar nichts. Es wird dann halt nur nichts mehr gloggt.

  • Auswirkungen des Deaktivierens? Falls du im Frontend eine Smart-Search-Suche verwendest, funktioniert die nicht mehr.


    Ob du eine verwendest, kannst du prüfen, indem du die Module durchsiehst und schaust, ob eines vom Typ "Suchindex" für das Frontend aktiviert und eingerichtet ist.

    Und, indem du deine Menüeinträge durchsiehst, ob einer aktiviert ist mit der Kennzeichnung "Suchindex » Suche" in der Menüeinträge-Übersicht.



    Du kannst im Suchindex-Bereich alles löschen. Das hat keinen Einfluss auf die indexierten Inhalte selbst. Der echte Beitrag bleibt also unberührt.



    Um Ruhe vor Suchindex zu haben, gehe nach Erweiterungen > Verwalten. Suche nach "Suchindex" und deaktiviere alle zugehörigen Erweiterungen.

    Es reicht allerdings grundlegend das Plugin "Inhalt - Suchindex" im Verzeichnis "content" zu deaktivieren, wie oben schon gesagt.

    Wenn du alles deaktivierst, verschwindet auch der Menüeintrag im Backend unter "Komponenten > Suchindex".

    Auch das Modul, wenn du unter Module "Neu" klickst.


    Nebenbei: Hiobs-Botschaft für Joomla 4. Es wird nur noch die Indexsuche geben. Die normale Suche (com_search) wird entfernt. Wir werden dann also alle mit unverhälnismäßig aufgeblasenen Datenbanktabellen leben müssen, wenn wir eine joomlaeigene Suche verwenden wollen. Auch das mal eben ein eigenes Suchplugin Hinzuprogrammieren fällt dann unter den Tisch. finder-Plugins sind weitaus komplizierter zu verstehen und zu erstellen. Gnaah!

    Datenbankexporte > -importe werden noch öfter per phpMyAdmin hängen bleiben, wenn man vorher nicht den Index leert. Dann muss man ihn aber wieder neu erstellen. Na ja...

  • Man muss einfach beim mysql server max_heap_table_size ändern. Standard ist 16MB ändere diese auf 20MB oder mehr und das Problem ist wirklich gelöst.. nicht irgendwelche komische Workarounds mit Plugins deaktivieren etc. Die Tabelle auf der DB hat das Limit erreicht. Es ist kein Joomla Problem!

  • nicht irgendwelche komische Workarounds mit Plugins deaktivieren

    Das Deaktivieren von Plugins und Erweiterungen, die sinnlos sind und nur Performance fressen, ist keinesfalls "komischer Workaround".

    einfach beim mysql server max_heap_table_size ändern

    Wenn's "einfach" ist, natürlich eine Option, vorausgesetzt man benötigt Suchindex. Andernfalls bläst man diesen Suchindex bzw. Datenbank nur noch weiter auf und zwingt seine Seite unnötigerweise in die Knie

    Wenn man's gar nicht darf, ist es halt nicht "einfach".


    Außerdem vermisse ich bei deiner Antwort, wie man das macht. Das könnte anderen helfen, die auf diesen Thread stoßen und ein Standardpaket bei einem Normalprovider haben.

  • Ich indexiere 240 PDF Dateien, das sind 1.5 Mio Einträge.. deshalb würde bei mir auch das Deaktivieren der anderen Plugins nichts nützen. Es ist eine Default-Limitierung der MySQL Datenbank.. ;-) Wie das gehen soll, kann ja dann jeder selber Googlen. Das ist immerhin ein Joomla Forum und nicht ein Serveradmin Forum.

  • Von "anderen Plugins" deaktivieren war nie die Rede. Wer Suchindex nicht benötigt, soll es deaktivieren. Und da reicht grundlegend das Master-Plugin des Suchindex. Sauberer ist alles deaktivieren. Anstatt an der DB rumzuschrauben, wenn man überhaupt darf.


    Post #12 klärt ja jetzt den Rest. Das habe ich eben zuvor vermisst. "Wer Suchindex braucht, kann versuchen....".


    Zurück zu Joomla. Bei einem Standard-Hoster und da laufen nun mal die meisten Seiten von Leuten, die hier Fragen stellen, wird zwar per phpMyAdmin mit SQL-Befehl

    Code
    1. select @@max_heap_table_size;

    zwar vermutlich die richtige Zahl ausgegeben (meist 16777216), aber ein

    Code
    1. set @@max_heap_table_size=25165824;

    wird ohne Fehlermeldung in's Leere laufen. Weitere Möglichkeiten haben die meisten Joomla-User eben nicht außer Hoster bitten und/oder größere (= teurere) Pakete.

  • Vielen Dank für den Beitrag. Als Ergänzung, meistens funktioniert es über phpmyadmin nicht, da "root" deaktiviert ist. Am zuverlässigsten, sofern man SSH Zugriff hat:


    Datei /etc/mysql/my.cnf Bearbeiten oder ggf. Erstellen und folgendes hinzufügen:


    2G (durch eigenen Wert ersetzen)

    Code
    1. [mysqld]
    2. tmp_table_size=2G
    3. max_heap_table_size=2G

    danach


    Code
    1. service mysql stop
    2. service mysql start