Kein Backend Anmeldung möglich

  • Abend zusammen,


    hoffe das ist in Ordnung, dass ich für mein Problem ein neues Thema eröffnet habe.


    Das Problem ist aus dem Titel ja schon ersichtlich, wenn ich meine Daten eingebe passiert nichts.


    Ich habe bisher folgende Schritte probiert:


    - verschiedene Browser benutzt und Browsercache gelöscht

    - jos_session in der Datanbank geleert

    - Cache Verzeichnis im PHP geleert

    - Plugins sind beide aktiviert


    Was mir aufgefallen ist:

    - selbst bei fehlerhafter Eingabe meiner Daten kommt keine Fehlermeldung.

    - In meiner htacces Datei finde ich nichts mit "session"

    - jos_session bleibt weiterhin leer auch wenn ich mich versuche einzuloggen.


    Mein Provider ist 1&1 und ich habe dort auch mal auf PHP 5.6 gestellt dies hat aber auch nichts bewirkt.


    Ich hoffe Ihr könnt mir weiterhelfen.

  • Hallo,


    erst einmal werden ein paar Grundinfos benötigt:

    Hast du ein Joomla neu installiert oder läuft dieses bereits längere Zeit fehlerfrei?

    Welche Joomla-Version?

    Hast du vielleicht einen vorgeschalteten zusätzlichen Passwortschutz für das administrator-Verzeichnis (Backend), welcher andere Zugangsdaten benötigt? Kann direkt beim Hoster eingestellt sein oder auch über eine .htaccess und .htpasswd im administrator-Verzeichnis.

    Welche PHP-Version hattest du zuerst getestet?

    Hast du mal einen Link zur Seite? Dann sieht man bereits mehr.

  • Ich sehe ganz normal den Backend Login, wenn ich meine Daten eingebe lädt die Seite und beide Felder wieder leer.


    Ich habe ganz normal an der Seite gearbeitet und nichts neues installiert.


    Habe nur Cookies akzeptiert und das sich Nutzer nicht mehr registrieren können, da viele fake accounts erstellt wurden.


    Joomla 2.5 http://www.hotel-gasthaus-kraft.de/index.php


    Vorher war PHP 3.x aber das hatte auch noch ohne Probleme funktioniert. Habe es nur aktualisiert weil ich mich nicht einloggen konnte.


    Ich melde mich nur ganz normal über Joomla Admin ein, habe auch in der Datenbank einen neuen User erstellt und es damit versucht.

  • Das sind natürlich alles sehr alte Dinge (Joomla-Version, PHP-Version und sicherlich dann auch die eingesetzten Erweiterungen). Sicherheitstechnisch geht das leider gar nicht mehr. Dass du da Probleme bekommst ist kein Wunder.

    Joomla wird mir teils in der Version 3.6.2 angezeigt. Hast du versucht zu updaten?

    War es wirklich PHP 3, womit du Joomla betrieben hast?


    Die Webseite muss dringend auf einen aktuellen Stand gebracht werden, also Joomla 3.8.12 mit PHP 7.1 / 7.2.

    Ebenso sind alle Erweiterungen zu aktualisieren und gewisse Sicherheitsvorkehrungen gegenüber Hackangriffen vorzunehmen.


    Dein Problem ist momentan der Login-Loop. Google mal danach! Da kommt mehreres als Ursache in Frage. Oft liegt es auch daran, dass der Hoster irgendetwas umgestellt hat. Ist so aus der Ferne schwer zu beurteilen.


    EDIT: Vielleicht hilft dir erst einmal folgendes: Login Loop

  • Stimmt ich hatte versucht es mal zu aktualisieren, könnte das Probleme gemacht haben ?


    Das Template ist nur für Joomla 2.5 heißt ich müsste ein neues kaufen und die Seite neu gestallten, dass wollte ich gerne zu einem späteren Zeitpunkt machen.


    Grad nochmal geschaut war PHP 4.0



    Das klingt so als müsse ich alle Dateien sichern und das neue Joomla 3.8 installieren.

  • In aller Regel laufen 2.5-Templates mit Joomla 3. Allerdings sollte man besser mit aktuellen Templates arbeiten. Du könntest das in Joomla beiliegende Protostar verwenden oder eines der vielen anderen kostenlosen oder Bezahltemplates. Das ist aber zunächst nicht dein Problem.

    Generell hast du 2 Möglichkeiten. Entweder ein neues Joomla installieren (z.B. auf einer Subdomain), Menüpunkte anlegen, Inhalte per Copy&Paste übernehmen...... usw. oder aber das jetzige Joomla langsam updaten bis 3.8.12.

  • Okay, ich lese mich mal in deinem Link durch und schaue ob ich rein komme.


    EDIT: wenn ich die configuration.php öffne steht bei cookie-domain was drin mit datenschutzerklärung und bei error steht ein default drin.


    Wenn ich beides ändere und hochladen will, sagt er mit permission denied :/

  • Schau zunächst vorsichtshalber nochmal in die Datenbank in die Tabelle "extensions". Ist "plg_athentication_joomla" auf "enable"?


    Cookie_domain sollte leer sein!


    Für error könntest du z.B. none oder Maximum angeben! Glaube aber nicht, dass es weiterhelfen wird.


    Kontrolliere die Datei und Verzeichnisrechte! Gibt es seitens des Hoster eine Beschränkung?

  • In der Datenbank steht bei publisch "1", finde ich dies auch auf dem FTP-Server ?


    Kann leider nur einen Benutzer einrichten und dann das Verzeichnis wählen. Da habe ich das oberste genommen damit er alle Unterordner hat. Ich sehe bei der Verzeichnis Wahl leider nicht das Verzeichnis wo joomla drin ist.


    In der Datenbank gibt es dann jos_plugins wo Authentifikation drin steht und published aus "1" ist.

  • Geschafft !!


    Habe über den Provider den Webspace genutzt und die Datei mit 744 freigegeben, so dass ich sie bearbeiten konnte.


    Dann habe ich die Cookie-Domain gelöscht und nun funktioniert es wieder :)


    Danke dir viel mals ! Jetzt kann ich die Seite upgraden.

  • Die configuration.php kannst du auf 644 setzen!

    Scheinbar war die Cookie-Domain das Problem.

    Was in der DB steht, findest du nicht auf dem FTP-Server. Da kommst du nur über phpmyadmin rein.

    Tipps:

    Unter Verwalten->Datenbank gibt es den Button "Reparieren". Diesen solltest du nach Aktualierungen regelmäßig anklicken.

    Und mach regelmäßig Sicherungen, nicht dass du immer wieder von vorne anfangen musst. Kann ein steiniger Weg sein bis zum aktuellen Joomla.