• Hallo in die Runde,


    ievtl. kann ein Admin dieses Thread ggf. an eine besser passende Stelle verschieben.

    Ich wollte an diesem verregneten Samstag mal mit J4 eine lokale Installation "wagen".

    Zuerst habe ich das Paket Alpha 4 gefunden und damit installiert, was auch ohne Probleme funktionierte, aber beim Speichern des ersten Beitrages Fehler.

    Tante Google befragt und siehe da, ich fand Alpha5. Damit eine neue Installation versucht, was aber nicht wegen Database-Zugriff nicht funktionierte (???).

    Also wieder zu Alpha 4 und das Update-Paket für Alpha 5 rüberkopiert und anschließend Datenbank repariert, soweit so gut.

    Nun bekomme ich beim Speichern eines Beitrages die Fehlermeldung "No default workflow available, please define one or contact an administrator".

    Wieder bei Google vorbeigeschaut, aber ehrlich gesagt, dass was ich da noch gefunden habe, verstehe ich nicht.
    auch erschließt sich mir die Struktur bei github.com nicht.

    Ich habe auch wild im Backend herumgeklickt, ob ich da etwas mit "Workflow" finde, aber bisher Fehlanzeige.


    Vielleicht kann mich Jemand "erhellen".


    Christian


    btw. mit PHP7.2.9 versucht

  • Ausschließlich diese Pakete nehmen:

    https://developer.joomla.org/nightly-builds.html


    Es ist nicht immer gewährleistet, dass dann für die nächsten Tage die Updatepackages der Nightly-Seite (via "Upload und Update" zu installieren) reibungslos funktioniern. Dann sollte man gleich neu installieren. War bei mir heute der Fall., dass mein J4 eeeeeigentlich aktuell war, aber halt doch nicht.


    Workflows sind dann im Bereich Content/Inhalte im Menü links.

  • auch erschließt sich mir die Struktur bei github.com nicht

    Im Unterschied zu Joomla 3 nützt einem die Github-Struktur auch gar nix mehr, was Neuinstallationen anbelangt. Es gibt die Releases für J 4, die ewig verbuggt hinterherhinken (deshalb die nightly Builds, die aber u.U. auch mal überraschende Macken haben können (nur als Warnung; lieber gleich aktuelleres Nightly installieren, als lang rumsuchen, außer du willst Issues einreichen)).


    Der Button "Clone and Download" für den J4-Branch auf GitHub enthält nur noch ein unvollständiges, nicht installierbares Gerüst.

    Für Interessierte, wie's damit trotzdem geht, also man sich damit ein komplettes, aktuelles Paket zusammenpacken kann, hat firstlady hier ein Tutorial für Windows 10 gedingst:

    https://www.wicked-software.de…-0-win10-composer-und-npm


    Für Linux habe ich in durchweinten Nächten gelernt, muss man einiges rumprobieren, bis die Versionen für die Tools (v .a. composer, npm) so mit Joomla zusammenspielen wie erwartet. Die in den diversen ausprobierten Distros enthaltenen Pakete sind irgendwie alle nicht geeignet oder man wird mit 100en Meldungen zuhieroglyphisiert, die ein gewisses Maß an Unsicherheit beim Anwender hinterlassen ;-)


    Virtuelle Maschinen oder das eigentlich geniale WSL (Windows 10 Subsystem for Linux) war, egal mit welcher Linux-Distribution, so frustrierend, dass ich nach nur 3 Tagen ;-) das Handtuch geschmissen hatte.


    Also alten Jaule-Rechner aus Keller neu aufgesetzt und schon hatte ich nach nur wenigen Tagen ;-) ein System mit dem ich jetzt auch fertige Joomla-Pakete erstellen lassen kann, wenn mir ein aktuelleres Nightly Build zu lange dauert.


    Für mich haben die Joomla-Modernisierer einen gewaltigen Vogel. Huch...

  • Moin,

    Ausschließlich diese Pakete nehmen:

    https://developer.joomla.org/nightly-builds.html

    Gesagt getan, dort fand ich Versionen von heute morgen, somit gleich die Update-Version über meine Installation >>> keine Besserung.

    Beim Versuch mit dem Vollpaket eine Neuinstallation zu machen. bekam ich anstatt des Startbildschirmes für die Installation folgende Meldung:

    "Environment Setup Incomplete

    It looks like you are trying to run Joomla! from our git repository. To do so requires you complete a couple of extra steps first."


    Workflows sind dann im Bereich Content/Inhalte im Menü links.

    Ähhh, da finde ich nichts!
    Wahrscheinlich sehe ich den Wald vor lauter Bäume nicht, den bekanntlich sitzt das Problem immer vor dem Bildschirm.


    Außerdem bin ich bei meiner Suche bei "Content > Media" auf folgende Fehlermeldung gestossen:

    Class 'Joomla\Plugin\Filesystem\Local\Adapter\LocalAdapter' not found


    Mein Frustlevel ist ziemlich gestiegen.


    Ansonsten einen schönen Sonntag


    Christian

  • Hallo Christian,


    zunächst mal: Hatte gestern mit Absicht unserem Re:Later den Vortritt gelassen - in der (auch weiteren) Hoffnung, sich zu dies & das zu melden. Danke schön 8)


    Hatte mit Joomla 4 in Juli begonnen. Tja was soll ich sagen:

    Mein Frustlevel ist ziemlich gestiegen.

    bist damit nicht alleine ;)


    Kann daher nur ein wenig aus dem gestrickten Nähkissen plaudern:


    Workflows: Da gab es mal das da: https://issues.joomla.org/tracker/joomla-cms/21978. Sollte bei Deiner neuesten Version erledigt sein. Dennoch, schau mal in der Datenbank ob Du das da hast:


    https://github.com/joomla/joom…0b8458be3609484ae4acc4cef

    SQL
    1. INSERT INTO `#__workflow_associations` (`item_id`, `stage_id`, `extension`) SELECT `id`, CASE WHEN `state` = -2 THEN 3 WHEN `state` = 0 THEN 1 WHEN `state` = 2 THEN 4 ELSE 2 END, 'com_content' FROM `#__content`;


    Zwischen Juli und September hatte ich auch nightly builds update gemacht. Dann waren auf einmal meine Beiträge futsch. Hatte mir dann ein fully package drüber gebügelt (configuration.php, user.css auf die Seite), also neu installiert.


    U.a. hatte mir obige SQL Datei gefehlt. Es sollte (ca) dann so aussehen:




    Schau auch im backend bei: System > Update > Joomla > Options, ob Du das so hast:




    Ach ja, wegen der 1. Fehlermeldung: diese hatte ich noch nicht, daher ev. die Frage: Hast Du Beispieldaten (mit) installiert?


    Liebe Grüße

    Christine

  • Beim Versuch mit dem Vollpaket eine Neuinstallation zu machen. bekam ich anstatt des Startbildschirmes für die Installation folgende Meldung:

    "Environment Setup Incomplete

    It looks like you are trying to run Joomla! from our git repository. To do so requires you complete a couple of extra steps first."

    Ja, du hast recht, das heutige Paket ist Sch....



  • Es ist wirklich schwierig und ich fluche auch jedesmal wenn ich wieder die Anwendung neu bauen muss. Aber sag mir immer: Jede Technik ist erst mal schwer bis man Routine hat, wenn ich mal an alles denke was ich Lauf der Jahre zuerst verflucht habe und dann doch zu schätzen lernte. Ich sag nur mal git ...

    Also "Augen zu und durch".


    Die nightly build Version ist normalerwese genau so installierbar wie jede andere Joomla Version auch. Heute habe ich es nicht probiert, meine letzte stammt von vorgestern. Dort ist auch der Workflow drin.

    Lui_brempt wenn du nicht gerade unersetzlich wertvolle Daten in der V4.0 Testdatenbank hast dann lösch lieber mal die alte Applikation mit samt der alten Datenbank und fang mit einer (hoffentlich korrekten) nightly build neu an.


    Falls jemand den neuesten Patchtester sucht: https://github.com/joomla-extensions/patchtester/releases - die beta4 ist eine gute Version

  • Grübel,grübel,

    also ich habe bisher noch die Beispieldaten mit installiert!
    Auch existiert auch in keinem der Pakete, die ich heruntergeladen habe die Datei sample_testing.sql.


    Also das Formular für den update-Source habe ich.
    Was kann ich damit "ausrichten"?

    Wie lautet ggf. die dort einzutregende Url?


    Christian


    Edit. Ich warte jetzt wohl erst einmal

  • Noch zu den Beispieldaten: Ich würde erst mal ohne Beispieldaten installieren.

    Dann wenn die Installation durch ist, kann man bei Bedarf erst einmal die Mehrsprachigkeit aktivieren.

    Auf dem Dashboard gibt es zwei Buttons - man kann dann entscheiden ob man Beispieldaten installieren will, für die einsprachige oder eine mehrsprachige Seite.

  • Also das Formular für den update-Source habe ich.
    Was kann ich damit "ausrichten"?

    Wenn du damit die BE-Ecke Joomla-Update > Upload&Update meinst. Hier kannst du die Upload packages von der Nightly-Seite installieren. Die musst du aber vorher lokal runterladen, dann über den Button "Browse" hochladen (Dann Geduld! Dauert!).


    Der automatische Updateserver (siehe Tipp von christine2 ) meldet sich erst, wenn dann eine alpha6 oder betaX an den Start geht (derzeit sind wir ja bei alpha5).


    Und wie schon oben gesagt, installiert lieber immer mal wieder neu, als zu lange auf die Update-Features zu vertrauen. Manche Änderungen sind so gravierend, dass die Updates fehlerhaft sind, was man dann erst merkt, wenn man im Issue Tracker gemeckert hat ;-)

    ich habe bisher noch die Beispieldaten mit installiert

    Die "großen" Testdaten während der Installation hat mal kurz funktioniert, dann wieder nicht, dann wieder doch, dann ... und mittlerweile funktioniert auch das zugehörige Sampledata-Plugin nicht mehr, das eigentlich dafür gedacht war, aus dem Backend nachzuladen. Bleibt also nur das Blog-Sample-Data wie firstlady oben sagt (nach der Installation zu klicken). Minimal, aber das FE sieht dann schon mal halbwegs so aus wie gedacht, was ohne nicht immer der Fall ist, habe ich gelernt...

    n meiner Alpha 4 habe ich kein Workflow im Content Menü.

    Mit der Version bist du sowieso gänzlich verloren. Kannst den Updateserver-Link von christine2 ausprobieren. Dann sollte dir Update auf alpha5 im Kontrollzentrum angezeigt werden und dann wie oben beschrieben die Nightlies-Updates für die nächsten Tage, aber fraglich, ob man mit diesen Schritten glücklich wird, wenn man nur rumschauen will und nicht im Detail testen (was ja auch gut wäre, wenn Updates nicht funktionieren).

  • Guten Abend!
    Jetzt habe ich mir mal das Template Cassiopeia angesehen und ausprobiert.

    Nun wollte ich die Beiträge für die Startseite in zwei Spalten anzeigen lassen.

    Jedoch werden die diesbezüglichen Einträge in den Beitragsoptionen bzw. auch in den Layouteinstellungen des Menüpunktes nicht berücksichtigt.

    Und jetzt die Frage: Bug oder Feature?


    Ich setze J4alpha5 vom 23.09.2018 nachmittags ein.


    Christian


    btw. Schön finde ich, dass man nicht nav-p... benötigt für ein horizontales Menü.

  • Moin,

    die Meldung betrifft m.E. genau "meinen" Sachverhalt, aber was dann da so diskutiert wurde, hatte auf mich den Anschein eines "Glaubenskrieg".

    Man kann sich sicherlich trefflich darüber streiten, ob die Spalten sinnvoll sind oder nicht, jedoch würde ich erwarten, wenn die Einstellmöglichkeien vorhanden sind, dass zumindest im Standardtemplate von Joomla entsprechendes realisiert ist.


    Vielleicht denke ich da auch zu prakmatisch.


    Christian