proxy_fcgi:error

  • Ich habe zur Problematik folgenden Thread gefunden, leider steht keine Lösung dabei:

    Unerreichbarkeit meiner Seite


    Aber gut. Es handelt sich dabei um eine firmeninterne Webseite die von außen nicht erreichbar ist, also Intranet. Da ich den Server aber selber verwalte habe ich auch die Macht. vain


    Am Server selber habe ich ein paar Einstellungen geändert:

    • in der "mpm_prefork.conf" des Apache habe ich die "MaxRequestWorkers" hochgesetzt: erst auf 500, dann auf 1000 default sind 256. (Habe es aber wieder auf 256 gesetzt.) Als die Seite startete hatten wir gleiches Problem, aber da hat mein Kollege den Wert auf 500 gesetzt und dann lief der Server knapp sechs Monate ohne Probleme. (ich habe die Änderungen inzwischen aber wieder auf Standard gestellt.)
    • Anfang der Woche hatte ich Probleme mit der Verbindung zu einem MS SQL-Server, nach einem PHP Update (7.0.x auf 7.2.X). Nachdem ich die Verbindung wieder hergestellt hatte und Daten auch da waren, machte der Server morgens um kurz nach sechs die Grätsche ....;( (da habe ich dann die MaxRequestWorkers hochgesetzt mit dem Erfolg das heute morgen der Server erneut ausgestiegen ist.

    Ich habe jetzt die Apache Error-Log durchforstet, bekomme auch "Indizien" wo das Problem liegt, aber ich denke ich übersehe - wieder einmal - irgendetwas.

    Leider komme ich mit meiner Macht nicht weiter und muss den Server in dieser Woche schon des öfteren durchstarten. Den Apache-Service alleine restarten hilft nicht.

    • was hat der proxy_fcgi-Error da mit zu tun?
    • Die PHP Warnings verstehe ich nicht, denn die Module arbeiten richtig - zumindest bekomme ich die Daten aus der MSSQL-DB.
    • die mpm_prefork:notice sagt mir das alles in Ordnung ist - naja, ist es auch , aber - und das wundert mich am meisten - zur exakt gleichen Uhrzeit nämlich um 05:55:55 war die Seite nicht mehr erreichbar...

    In den Apache Error- und Acces Logs steht Folgendes

    Liegt es an der Verbindung zur MSSQL-DB? Mit der PHP7.0.X und den Treibern für SQL gab es keine Probleme. Da war es aber noch die 13er Version und nicht die unter PHP7.2 aktuelle 17er ...

    Dazu bin ich nach dieser Anleitung vorgegangen:

    https://docs.microsoft.com/de-…drivers-on-debian-8-and-9


    Alle Ideen sind gerne Willkommen ! :/:*