Problem bei PHP Update 7.0.28 -> 7.1x

  • Hallo,


    ich habe hier eine Seite, die unter Php Version 7.0.28 tadellos läuft. Nun steht im Backend die Benachrichtigung, die Php Version zu updaten.


    Zitat


    Die verwendete PHP-Version „7.0.28“ erhält derzeit nur Sicherheitsaktualisierungen aus dem PHP-Projekt. Das bedeutet, dass diese PHP-Version bald nicht mehr unterstützt wird. Es wird empfohlen zeitnah eine Aktualisierung auf die aktuellere PHP-Version durchzuführen, bevor die verwendete Version zum 03.09.2018 nicht mehr aktualisiert wird. Joomla! wird mit einer neueren PHP-Version schneller und sicherer sein (PHP 7.x wird empfohlen). Der Webhoster kann bei der Aktualisierung unterstützen.

    Wenn ich nun die Php Version auf die nächst Höhere (7.1.6) stelle, bekomme ich im Frontend folgende Fehlermeldung.


    Zitat

    Die angeforderte Seite konnte nicht gefunden werden!

    Fehler: 0 - Using $this when not in object context

    Wenn ich die Version zurückstelle, läuft wieder alles wie geschmiert.


    Das Template ist: http://www.icetheme.com/themes/it-corporate-2

    Ich habe schon per Twitter und per E-Mail gefragt, ob es eine neuere Version gibt, aber bis jetzt hat mir keiner geantwortet. Man sieht auch auf der Seite keine Versionsnummer.

    Alle verwendeten Erweiterungen/ Plug-ins, sollten auf dem neuesten Stand sein. Jedenfalls werden mir keine Updates angeboten.


    Unter anderem wird verwendet:

    Widgetkit ZOO : 3.1.0

    ZOO: 3.3.32

    Akeeba Backup 6.2.1

    DD YouTube Video (EU Privacy) 1.0.0.7

    Google Structured Data 3.1.9

    Regular Labs - Advanced Module Manager 7.7.1

    Sitemap Generator 1.2.1

    IceCarousel 3.0.2 <- noch ältere Version

    IceMegaMenu 3.0.2 <- noch ältere Version

    IceSlideShow 3.0.3 <- noch ältere Version


    Zur noch älteren Version : Ich habe die neuesten Versionen installiert. Dann hat zwar der Slider nicht mehr korrekt funktioniert, dass Php Problem war, aber danach noch immer da.

    Die Seite habe ich dann wieder auf die alte Version (lauffähig) zurückgestellt.


    Hier ist die Seite: klickme


    Irgendwelche Ideen wie man es beheben kann?


    Grüße

  • Hallo,


    ich habe den debug Modus und Max Fehleranzeige eingestellt.


    Dann habe ich folgende Fehler erhalten.


    Notice: Only variables should be assigned by reference in /kunden/401334_13088/webseiten/modules/mod_icemegamenu/helper.php on line 272


    Notice: Only variables should be assigned by reference in /kunden/401334_13088/webseiten/modules/mod_icemegamenu/helper.php on line 109


    Deprecated: call_user_func_array() expects parameter 1 to be a valid callback, non-static method modIceMegamenuHelper::buildXML() should not be called statically in /kunden/401334_13088/webseiten/libraries/src/Cache/Controller/CallbackController.php on line 173


    Notice: Only variables should be assigned by reference in /kunden/401334_13088/webseiten/modules/mod_icemegamenu/libs/menucore.php on line 76


    Deprecated: Non-static method Joomla\CMS\Application\SiteApplication::getMenu() should not be called statically in /kunden/401334_13088/webseiten/modules/mod_icemegamenu/helper.php on line 46


    Deprecated: Non-static method Joomla\CMS\Application\CMSApplication::getMenu() should not be called statically in /kunden/401334_13088/webseiten/libraries/src/Application/SiteApplication.php on line 275


    Ich habe auch schon in dem vorgeschlagenen Forum geschaut. Das sieht aber ziemlich verwaist aus. Ob da überhaupt noch jemand was macht? Idk!


    Zum Rest, ja, konnte ich mir schon denken. Ich habe soweit es mir möglich war, alle installierten Erweiterungen auf Aktualität überprüft. Bis auf die Ice Erweiterungen, "sollte" eigentlich alles passen. Ich werde aber Mal eine Anfrage in dem Forum dropen.


    Ps: Mit dem Standard Template funktioniert die Umstellung auf Php 7.1x.



  • Bis auf die Ice Erweiterungen, "sollte" eigentlich alles passen.

    Und die scheinen es nach den Fehlermeldungen zu sein. Habe die lange Liste nur überflogen, aber:

    /mod_ice_carousel/ und /mod_icemegamenu/ sind genau Deine Kandidaten.

    Genauer kann ich auch nicht helfen.

    Habe hier ähnliche Probleme mit Widgetkit lite von Yootheme. Scheint es nicht mehr zu geben.

    Da mein Template gekauft ist werde ich aber erstmal bei der Schmeide nachfragen.


    Edit:

    Wie von firstlady (Grüß Dich :saint:) schon gemacht: den Spoiler findest Du im der Symbolleiste dieses Editors ...

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Ja das ist echt schade. Ich konnte es mir aber schon denken. Gekauft ist das Template auch, nur die Template Pflege ist wohl nicht mehr gegeben.

    Wie lange kann man eigentlich noch mit der veralteten Php Version fahren? Bevor ich es an den Besitzer weiterleite.


    /mod_ice_carousel/ und /mod_icemegamenu/ Schaue ich mir Morgen oder demnächst noch Mal genauer an.


    Danke und Grüße

  • Mir ging es ausschließlich um die Fehlerseite auf der dir

    Zitat

    Die angeforderte Seite konnte nicht gefunden werden!

    Fehler: 0 - Using $this when not in object context

    angezeigt wird und dort auch nur der Teil der auf die Fehlermeldung folgt. Da sollten dann einige durchnummerierten Zeilen erscheinen:

    0 - irgendwas

    1- sonstwas

    2 - irgendsonstnochwas


    Die ganzen Notices und Warnings sind nicht von Interesse.


    Deshalb auch der Hinweis, die error.php umzubenennen, da dann sichergestellt ist, dass die keine Menüs und Kram lädt, die zu viele andere Meldungen produzieren.

  • Hi, also ich hatte es eigentlich schon geschrieben, ist aber wohl igw. verloren gegangen.


    Also noch Mal: Php Vers. 7.1.10 - debug an - Fehler auf Max. - error.php umbenannt


    Notice: Only variables should be assigned by reference in /kunden/401334_13088/webseiten/modules/mod_icemegamenu/helper.php on line 272
    Notice: Only variables should be assigned by reference in /kunden/401334_13088/webseiten/modules/mod_icemegamenu/helper.php on line 109


    Wie jetzt gerade im Frontend angezeigt. Ich stelle es später zurück.

  • Ich hatte Templates von ICE auch schon mal verwendet und da gibt es definitv ein Problem mit PHP 7.1 und dem Megamenü.

    Ich hatte das mal gefixt und eine Installaton daraus geschnürt. Probiere mal aus ob es bei Dir funktioniert: mod_icemegamenu.zip
    Im Zweifelsfall das alte Modul erst deinstallieren. Backup vorher nicht vergessen.

  • Wenn du dich rantraust:

    In der Datei

    modules/mod_icemegamenu/helper.php

    und Datei

    modules/mod_icemegamenu/libs/menucore.php


    alle Vorkommen (ich zähle 4) von

    Code
    1. &JSite::getMenu()

    austauschen gegen

    Code
    1. JFactory::getApplication()->getMenu()

    Fehler berichten auf "Keine".

    Dann hast etwas Ruhe denke ich. Aber Rest wurde dir ja schon gesagt, dass das icemenu total veraltet ist und von alleine irgendwann sterben wird, falls die Macher kein Update rausbringen.


    EdIT: Ah, sehe gerade da war Indigo66 schneller ;-)