Update von 3.7.3 auf 3.8.13 zerschießt das Design - Menüs fehlen, lediglich der mittlere Bereich der Startseite bleibt erhalten

  • Hallo,


    ich habe leider ein riesengroßes Problem:


    Gestern wollte ich einige Updates - wie Joomla auf den neusten Stand bringen - durchführen


    Zuvor hatte ich Version 3.7.3 im Einsatz. Das Update bzgl. PHP-Version 7.2 wollte ich im Anschluss machen.


    Ich habe ganz normal vor dem Update ein Backup gemacht. Doch leider durch (so vermute ich) den Mehrfachklick auf Neuinstallation der Kerndaten ist mein Backup verschwunden. Ich sehe unter Akeeba wohl noch den Eintrag, aber die Sicherungsdatei ist weg und ich habe nur zu neue Backups.


    Auch mein Provider kann mir wohl den Webspace vom Vortag liefern, auch ich weiß nicht in wie weit die DB durch die Updates geändert wurde. Noch mehr möchte ich mir logischerweise nicht zerstören. Wenn es mit dem Wiederherstellen des Webspaces getan ist, will ich das gerne machen. Nur brauche ich natürliche dann eine Updatestrategie.


    Wie kann ich die Module (Menüs) wieder anzeigen? Aktuell ist die Seite auf den Header (Foto) und die Haupteintrage auf der Startseite beschränkt. Sämtliche Menüs (bspw. ein horizontal Menü unter dem Header fehlen.


    Ich habe das Template Allrounder Version 1.1 im Einsatz. Auch der Wechsel des Templates bewirktl leider nichts.


    Hätte nicht gedacht, dass es so kompliziert ist.


    Ich freue mich auf Eure Antworten und dass es nur eine kleine Stellschraube ist, die man drehen muss, um den Seiteninhalt wieder zu vervollständigen.


    Wer Ihre weitere Details benötigt, um eine Hilfestellung zu geben, bitte meldet Euch.


    VG

    Jan

  • Funktioniert das Backend?


    Für Joomla 3.8 mussten viele Erweiterungen nachgebessert werden. Hast du also vor dem Joomla-Update alle Erweiterungen auf Aktualität überprüft und gegebenenfalls geupdatet? Erst dann sollte Joomla aktualisiert werden.

    Insbesondere Plugins und Template-Frameworks waren betroffen.

    Schau im Backend mal die Drittanbieter-Erweiterungen (also ID>10.000) durch, ob es da alte Versionen gibt!

    Ebenso kannst du alle Drittanbieter-Plugins mal deaktivieren (dann könnte die Seite laufen) und nacheinander wieder aktivieren, um zu sehen, worin die Problematik besteht.

    Kannst auch mal unter "Module" anfangen, Module zu deaktivieren, die auf der Startseite benutzt werden.


    Caches wirst du sicherlich alle geleert haben (Joomla und Browser) und auf "DB reparieren" hast du bestimmt auch schon mal geklickt, oder?


    EDIT: Welche PHP-Version nutzt du aktuell?

    Wenn dein Hoster dir Webspace und Datenbank von gestern herstellen kann (also bevor du mit den Updates anfingst), dann wäre das auch eine Lösung. Anschließend dann nochmal Backup machen und runterladen! Dann Erweiterungen aktualisieren und zum Schluß Joomla. Abschließend PHP auf 7.2 und hoffen, dass alle Erweiterungen kompatibel zu PHP 7.2 sind. ;)

    Zukünftig die Aktualisierungen immer zeitnah ausführen! Dann sind es in aller Regel höchstens Kleinigkeiten. Von 3.7.3 auf 3.8.13 sind doch einige Änderungen vorhanden, insbesondere jetzt, wo alles auf Joomla 4 zusteuert.


    Ansonsten kannst du mir gerne mal deine Zugangsdaten schicken. Vielleicht ist es nur eine Kleinigkeit.

  • Hi JoomlaWunder,


    besten Dank für Deine Antwort. Ich habe Deine Hinweis umgesetzt und siehe da, die Menüs sind wieder da. :-)


    Was habe ich genau gemacht?

    1. Advanced Module Manager war veraltet, Update von auf 4.18.6 auf 7.8.0 durchgeführt

    2. Nach dem Update kam ein Hinweis, dass man NoNumber Framework deinstallieren soll, dies habe ich getan.


    Und siehe da, die Seite läuft wieder.


    Mit dem Update von Akeeba habe ich bewusst gewartet, weil ich beim letzten Mal ein Backup mit einer alten Version von Akeeba und ein Update von Akeeba. Bei der Wiederherstellung kam es Fehlern.


    3. Backup erstellt und direkt herunterladen, damit man für die Zukunft ein Ass im Ärmel hat

    4. Akeeba Update installiert


    In Kürze werde ich das PHP-Update machen, jetzt läuft erstmal die Seite wieder.


    Nochmals besten Dank für den schnellen Support.


    VG

    Jan

  • Nur als Hinweis, da Akeeba-Voreinstellungen immer wieder zu unerwartetem Verlust von Backups führen. Noch leichter, wenn man das Akeeba-Plugin "automatische Backups vor Joomla-Updates" aktiviert hat.


    In der Profile-Konfiguration kann man Quotas einstellen oder deaktivieren. Anzahl von Backups, die aufgehoben werden sollen und/oder max. Speicherplatz, der für Backups genutzt werden darf. Wenn man eh üppig Speicherplatz hat, sollte man die Quotas deaktivieren und sich einfach angewöhnen, dann immer mal wieder ältere Backups auszuputzen.


    Voreingestellt ist Akeeba auf 3 Backups aufheben. Mir meist viel zu wenig. Gerade bei so Update-Aktionen, wo ich gerne Zwischenschritte festhalte.