Nach Update auf 3.9 Fehlermeldung bei aufruf von Rockgalery

  • Hallo, nach Update auf Joomla 3.9 bekomme ich jetzt keinen zugriff mehr auf die Komponente '' Rockgalery'',

    bekomme dafür die Fehlermeldung:

    ''Unserialization of filetags failed.''

    Da ich jetzt vieles vergessen habe, da ich die Seite vor Jahren eingerichtet habe und eigentlich immer die selben Verrichtungen mache,

    Bilder und Kurztexte eingeben und von Joomla und den Komponenten die Updates tätige,

    weiss ich jetzt nicht wie ich die Fehlermeldung bereinigen kann.

    Tritt anscheinend nur bei der Komponente Rockgalery auf.

    Wäre toll wenn da jemand was weiss zum bereinigen dieser Fehlermeldung.

    MfG

  • ahh PHP das weiss ich genau, das ist die 7.2 version :)

    Und zu Tante Google, ja hab ich auch gefragt,

    aber da find ich nur sehr alte Angaben vor über 4 Jahren und auch nur auf englisch (und da hab ich schon wieder ein Problem, das kann ich nicht gut und nicht viel )

  • Hallo zusammen,

    kurze Rückmeldung im Bezug auf der Fehlermeldung mit Rokgallery:


    da ich gar nicht mehr weiter mir zu helfen wusste, habe ich beim Hoster nachgefragt, ob die mir mein Joomla nicht auf ein vorheriges Backup zurück setzen könnten.

    Dies haben die dann auch gemacht :) zurück auf Joomla 3.8.12 mit Rokgallery 2.44 (ja da hatte ich die schon die aktuellste)

    NUR auch da die selbe Fehlermeldung bekam.

    Folgendes dann gemacht habe:

    - nachgeschaut wo was nicht geht, sprich: Konnte keine Bilder einfügen per Rokgallery im Backend, ein einziger Ordner mit Bilder im Frontend nicht mehr zugänglich ist.

    immer noch selbe Fehlermeldung bekomme.

    - Updaten von Rokgallery, sprich beides neu runtergeladen und installiert habe von Rogallery.

    Fehlermeldung besteht immer noch

    - Updaten von Joomla auf 3.9

    Fehler immer noch vorhanden :(


    Habe jetzt nach einiger Zeit des suchens,

    endlich den Ordner gefunden wo anscheinend alle Bilder drin sind ,

    die ich per Rokgallery in meine Seite eingebunden habe,

    habe die jetzt per FTP mal alle zurück auf meinen PC kopiert.

    Noch durchschauen muss ob auch wirklich alle da sind :o


    Da ich nicht finde wie ich den Fehler loswerde, denke ich ist es Zeit was neues zu nehmen und Rokgallery ins Nirvana zu senden.... das Ding nervt mich jetzt :(

    Was haltet ihr von Sigplus?

    Oder kennt ihr eine noch bessere Free Gallery?


    Jetzt noch Fragen an euch:


    - Kann ich Rokgallery vorerst so im Joomla belassen und eine andere Photo Gallery (zB Sigplus) in mein Joomla installieren???

    zu späterem Zeitpunkt dann,

    wenn ich alles durchgeschaut habe und alle Bilder in die andere Photogallery neu eingebunden habe,

    Rokgallery deaktiviere und deinstalliere...


    - nebenbei noch eine Frage: möchte gerne den ganzen Style etwas verändern,

    heisst, das ''alte LESS Allrounder'' Template ersetzen, doch die einzelnen Menüpunkte im Frontend sollten erhalten bleiben,

    Kann ich das so einfach machen? ist mir schon klar das ich bei einem neuen Template, die einzelnen Menüpunkte neu zuweisen muss,

    aber sehe ich die wenn ich ein neues Template aufspiele oder muss ich die dann alle neu erstellen, die Module, Menüs usw???


    MfG

    Vitz

  • Moin,
    ich würde das Ganze entweder lokal oder in einer Subdomain umbauen, d.h. Entfernen der "alten" Galerie etc.


    Durch den Wechsel des Templates werden keine Menüeinträge, Beiträge, etc. geändert oder gelöscht.
    Ggf. ist es erforderlich, die verwendeten Module, z.B. das Menümodul, anderen Modulpositionen zuzuweisen, da der Templateentwickler frei in der Benennung der Posionen ist.

    Dafür gibt es die möglichkeit der Anzeige der Modulpositionen mit ?tp=1, wenn man die Möglichkeit vorher in den optionen aktiviert hat.


    Christian

  • Moin Christian,

    denke werde das mal zuerst lokal testen, denn mit Subdomaine steh ich schon wieder vor einem Buch mit sieben Siegel :o

    bin schon froh wenn ich mich da zurecht find im Adminbereich von Joomla ;)

    Und da das ja auch schon so lange her ist das ich das alles gemacht hab, zuerst mich nochmal zurück finden in dem ganzem Kram ;)

    Aber Danke dir für die Auskunft

    MfG

    Vitz

  • Hallo,

    Indigo66 hat dir einen Link zur RokGallery gepostet; Post #2. Da findest hinter dem Download-Button 2 Erweiterungen zum Download. Die installierst/aktualisierst du in deinem Joomla, um die aktuellste Version zu bekommen, auch von rokcommon.

    nachgefragt: Hast Du auch rockcommon auf 3.2.6 (wie es oben steht) upgedated bzw. installiert? Siehe auch hier:

    https://rockettheme.com/forum/…-released?start=0#1391078 wo steht, dass das RockCommonPlugin nicht mehr in RockGallery integriert ist. Download, siehe #2


    Liebe Grüße

    Christine

  • Hallo Christine,

    habe weiter oben schon auf Indigo's Links geantwortet, ja beide neu installiert, Fehler bleibt hartnäckig bestehn,

    und ja wie beschrieben installiert,

    und wie auch bei Rokcommon erwähnt, braucht das Common Paket PHP 7 minimum, ich bin schon lange auf PHP 7.2,

    beide Pakete Rokcommon und Gallery liefen schon unter Joomla 3.8.12 mit PHP 7.2 und da einwandfrei,

    erst mit dem Update auf Joomla 3.9 fing der Ärger an...

    Aber danke dir für die Nachfrage

    MfG

    Vitz