Erweiterungen überprüfen... führt zu Fehlermeldung "Unbekannte Erweiterungen..."

  • Hallo zusammen,


    Ich habe mit einer Neuinstallation (3.9.0) ein Problem im Kontrollzentrum im Unterpunkt "Wartung" mit den Erweiterungen. Diese werden zunächst so wie immer überprüft und nach einer Weile wird mir die Meldung "Unbekannte Erweiterungen" ausgegeben:



    Wenn ich die Meldung anklicke dauert es wieder eine ganze Weile und ich bekomme vom Server die folgende Fehlermeldung:


    Hat jemand einen Lösungsansatz für diese (ich nehme an) Serverproblematik? Vielen Dank für Eure Mithilfe...

  • In den Aktualisierunsquellen habe ich jetzt "Wiederherstellen" ausgeführt und ich hatte mal kurzzeitig die Meldung: Alle Erweiterungen sind aktuell. Beim Klick darauf kommt allerdings wieder die Time-Out Meldung vom Server.


    Zudem werden auch einige Quellen wieder auf "Deaktiviert" (rotes Kreuz) gesetzt nachdem ich diese wieder aktiviert habe (grüner Haken). Es sind dann immer wieder andere Quellen deaktiviert die zuvor aktiviert waren. Geht also endlos so weiter...


    Installierte Erweiterungen:

    Akeeba Backup v6.3.0

    JCE-Editor v2.6.33

    JCH-Optimize v5.2.7

    J-Events v3.4.48

    Joomshaper SP PageBuilder v3.3.6

    Joomshaper Helix Ultimate Template v1.0.4

    Web 357 – Cookie Notification Bar v3.6.2

    Fox Contact – Kontaktformular v3.9.1

    YooTheme – Widgetkit v2.9.2

    Unite Slider v5.0.16


    Das sollten alles die aktuellen Versionen sein...

  • Versuche mal, die Quellen zu löschen, und dann wiederherstellen zu lassen. Ggf die Quellen, die bemeckert werden, auch mal anklicken, also die Links, die zu den Aktualisierungen führen, ob sie denn überhaupt vorhanden sind. Manche Entwickler nehmen es da nicht so genau...


    Wenn diese funktionieren, kann es an der PHP Konfiguration des Webspace/Servers liegen. Da hilft dann ein Blick in das Errorlog, da dürfte der 504er irgendwo auftauchen.

  • Vielen Dank für Deinen Hinweis j!-n > Das löschen und wiederherstellen, der Aktualisierungsquellen hat nichts bewirkt. Problem mit den unbekannten Erweiterungen besteht weiterhin. Für den 504 Time-Out habe ich unter folgendem Link einen Lösungsansatz gefunden wie man in der nginx.conf folgende Werte eintragen soll:

    Code
    1. proxy_connect_timeout 600;
    2. proxy_send_timeout 600;
    3. proxy_read_timeout 600;
    4. send_timeout 600;

    Habe ich gemacht und nach restart des Servers, kein Erfolg. Ein weiterer Ansatzpunkt wäre auch die Anpassung der max_execution_time = 300 in der php.ini > Bei mir war 30 eingestellt. Auch hier kein Erfolg nach restart.



    Da hilft dann ein Blick in das Errorlog, da dürfte der 504er irgendwo auftauchen.

    Die Seite liegt auf einem Webserver der mit Debian eingerichtet ist und es ist kein klassisches Hostingpaket. Ich habe den weder eingerichtet, noch bin ich tiefer gehend damit vertraut.

    Wie kann ich hier die Errorlogs einsehen, bzw. das Problem erkennen? Eingerichtet ist folgende PHP-Version: 7.2.11-4+0~20181106031630.10+stretch~1.gbp789850 Liegt in der PHP-Version vielleicht das Problem?

  • Glaube ich weniger. Und ich weiß nicht, wo nginx die Errorlog-Datei der Domäne ablegt. Wenn die Links in den Aktualisierungsquellen funktionieren, bleibt der Server als Fehlerquelle, bzw die PHP Umgebung.


    Du kannst versuchen, die Seite auf einen anderen Webspace / Server / lokal zu kopieren, und dort zu testen. Oder aktualisieren, und wieder zurück spielen.

  • Du kannst versuchen, die Seite auf einen anderen Webspace / Server / lokal zu kopieren, und dort zu testen. Oder aktualisieren, und wieder zurück spielen.

    Danke j!-n, ich werde diesen Lösungsansatz verfolgen und natürlich das Ergebnis rückmelden. Der PHP-Ansatz könnte vielleicht wirklich die richtige Richtung sein.


    Was passiert, wenn du unter "Erweiterungen" -> "Verwalten" -> "Überprüfen" mal schaust? Wird da noch was gefunden?

    Danke JoomlaWunder... Nein, leider wird beim überprüfen nichts gefunden. Die Liste ist leer... > Meldung: "Keine übereinstimmenden Ergebnisse"

    Ich habe auch die gesamten Erweiterungen durchsucht und nichts gefunden was dort nicht hingehört oder vergessen wurde zu deinstallieren.

  • Kannst du auf die Datenbank und damit umgehen?

    Hallo Christiane, Ja ich kann auf die Datenbankdateien (#_extensions sowie #_update_site_extensions) zugreifen und bin auch in der Lage diese einzusehen. Von Veränderungen habe ich allerdings keine Ahnung...


    An welcher Stelle kann ich etwas einsehen, was mich eventuell weiterbringt?


    Ich sehe z.B. in der #_extensions > com_installer bei den Params hintendran den Eintrag: {"show_jed_info":"1","cachetimeout":"6","minimum_s...

  • Diese Stelle ist schwer zu testen daher rate ich jetzt, ohne Gewähr!


    In der Tabelle #_update_site_extensions hält Joomla die IDs der extensions, die aktualisiert werden sollen (extension_id).

    Diese IDs zeigen auf einen Eintrag in #__extensions, also auf die Erweiterungen, die Joomla kennt.


    Ich interpretiere das jetzt so, dass es Einträge in #_update_site_extensions mit ID's gibt, zu denen in #__extension kein passender Satz gefunden wird.

    An dieser Stelle könnte die Fehlermeldung erzeugt werden.


    Falls du solche Einträge in #_update_site_extensions findest könntest du ein Datenbank-Backup machen und die betreffenden Sätze dann löschen.