htaccess joomla-security.de Version: 3v1 BETA mit Joomla! 3.4.3 funktioniert nicht.

  • Hallo,


    ich habe auf einem Raspberry 2 die aktuelle Raspbian Distribution und den Apache2 laufen. Dort habe ich die aktuelle Joomla! Version 3.4.3 installiert. In den Systemeinstellungen im Adminbereich habe ich standardmäßig https aktiviert. Der Administrator Bereich ist über eine .htaccess Datei mit einem Passwort zusätzlich geschützt.
    Alles läuft einwandfrei.
    Jetzt wollte ich zur Sicherheit noch die .htaccess Datei von joomla-security.de in das Dokumenten root installieren.
    Leider kommt dann nur noch die Fehlerseite 500.
    mod rewrite habe ich aktiviert. In den beiden /etc/apache2/sites-enabled Konfigurationsdateien habe ich "AllowOverride All" gesetzt.
    Apache selbstverständlich neu gestartet.


    In der Apache Logfile steht folgendes drin.

    Code
    1. [Sun Aug 09 21:31:46 2015] [alert] [client 192.168.xxx.xxx] /var/www/xxx/.htaccess: RewriteEngine not allowed here


    Ich habe jetzt stundenlang Gegoogelt und ausprobiert. Ich weiß mir keinen Rat mehr. ?(hmm
    Hat jemand noch einen Tipp für mich, wo der Fehler liegen könnte?


    LG Joomlafan

  • Hallo und vielen Dank für die Antworten.


    Der Tipp mit der original Joomla htaccess Datei hat mich zum Ziel geführt.
    Die hat bei mir nämlich ebenfalls nicht funktioniert.
    Auszug aus der Apache2 error.log


    Code
    1. [alert] [client 192.168.xxx.xxx] /var/www/xxx/.htaccess: IndexIgnore not allowed here


    Daraufhin habe ich in der htaccess die Zeile auskommentiert.


    Code
    1. # IndexIgnore *


    Das liegt daran, dass das entsprechende Modul bei mir nicht aktiviert ist.


    Selbes Problem trat dann noch mit der htaccess von joomla-security.de Version: 3v1 BETA auf.
    Dort habe ich es auch wieder auskommentiert. Dann kam noch die Fehlermeldung


    Code
    1. [alert] [client 192.168.xxx.xxx] /var/www/xxx/.htaccess: DirectoryIndex not allowed here


    auch gleich auskommentiert...


    Code
    1. # DirectoryIndex index.php index.html


    ...und siehe da. alles geht.
    Vielen Dank!!! ;)


    Ps.: Ich habe noch kein Zertifikat für meine Domain erworben. Habe ein selbst signiertes. Funktioniert trotzdem. :thumbsup:

  • Halt, eins habe ich noch vergessen. Ich habe noch in dem Ordner /etc/apache2/sites-enabled die beiden Dateien wie folgt geändert.


    Code
    1. <Directory /var/www/>
    2. Options Indexes FollowSymLinks MultiViews
    3. AllowOverride None
    4. Order allow,deny
    5. allow from all
    6. AllowOverride FileInfo Options AuthConfig
    7. </Directory>


    Das wichtige ist hierbei der Inhalt der Zeile 6.