Fehlerhafte Sprachangabe. Die Sprache ist nicht im HTML Markup angegeben.

  • Hallo allerseits,


    nachdem ich meine neue Seite nun annähernd fertiggestellt habe, habe ich sie mal einem Online-SEO-Test unterzogen.

    Einige Dinge habe ich schon optimiert, einige muss ich noch...


    So wird mir z.B. (u.a.) angezeigt, dass die Sprache der Seite nicht erkannt wird. Genauer: "Die Sprache ist nicht im HTML Markup angegeben."


    Also meine Seite ist die hier: http://www.tbo-computerservice.de

    Die Seite mit der ich sie getestet bzw. analysiert habe, ist diese: https://www.seobility.net/de/seocheck/


    Dazu gibt es auch einen Tipp, was man diesbezüglich machen soll. Aber ich komm da nicht weiter. Hab schon gegoogelt und ausprobiert ohne Ende.

    Ich benutze das Template Astroid Framework von JOOMDEV und den Pagebuilder Quix von ThemeXpert (da will und werde ich auch nichts dran ändern).


    Könnte mir bitte jemand sagen, wie und wo ich da den HTML-Code, so wie hier beschrieben

    https://www.seobility.net/de/wiki/Sprache_einer_HTML_Seite

    einfügen kann? In Joomla selber habe ich alles auf Deutsch stehen und finde auch keine weitere Einstell-Möglichkeit.


    Vielen Dank in Voraus!

  • Wenn man sich den Quelltext deiner Website ansieht, dann steht die Sprachangabe ganz zu Beginn.


    <html lang=de-de ...


    Ich glaube das muss aber so lauten:


    <html lang="de-de" ...


    Also mit Anführungszeichen.


    Dies ist sicher in der index.php deines Templates änderbar. Falls du unsicher bist, kannst du im Standardtemplate Protostar abgucken: https://github.com/joomla/joom…/protostar/index.php#L130

  • Oh, da legt man sich gerade mal ein Stündchen auf's Ohr, und dann sind hier schon 4 Antworten :-)


    Vielen Dank erst mal!

    Ich hab jetzt mal Firebug in meinen Fuchs installiert und (tatsächlich) der zeigt mir sogar "de-de" mit Gänsefüßchen an (siehe Screenshot). Und das auch auf allen Unterseiten.


    Heißt also mit anderen Worten, dass ich mir da keinen weiteren Kopf drum machen brauche, oder? Was soll ich da jetzt noch suchen und testen. Google wird es wohl richtig erkennen, denke ich.


    Auch folgende Aussage werde ich wohl ignorieren können: "Leiten Sie Anfragen mit und ohne www. auf die gleiche Seite per HTTP 301 Redirect weiter." Oder was meint die Fachwelt hier?

    Denn ich komme mit und ohne www immer auf meine Seite...


    Vielen Dank noch mal für eure Hilfe!


    Edit: Ich sehe gerade, dass die Sache in Google Chrome auch mit "de-de" angezeigt wird (siehe 2. Screenshot). Allerdings anders, sodass wohl sogar mehrfach die Sprache angegeben ist?!

  • Du musst bzgl. Sprache gar nichts ändern!!


    Sowohl die Angabe

    lang=de-de

    als auch

    lang="de-de"

    ist korrekt!


    Dein Template schreibt

    lang="de-de"


    Das Plugin JCH-Optimize entfernt in diesem Fall aber die Gänsefüßchen, um die Seite so schmal wie möglich zu halten. Auch das ist korrekt.


    Das SEO-Tool macht einen Fehler, nicht du oder deine Seite!!! JCH solltest du auch nur zum Testen deaktivieren, falls du das missverstanden hast. Darfst ruhig weiterlaufen lassen, weil sonst werden dir im SEO-Tool wieder andere Sachen angezeigt, die dann tatsächlich bedenklich sind/sein können bzgl. Ladezeiten.

  • Wegen www. Da ist die Meinung neuerdings nicht ganz einheitlich, ob man das nun tun muss oder nur darf. Ich bevorzuge seit je her, das per .htaccess-Datei festzulegen, ob sie immer mit oder ohne www angesteuert werden soll. Für was man sich entscheidet, ist egal.


    Egal, was ein Nutzer eingibt, mit oder ohne, kommt er "trotzdem richtig raus".


    Wenn du SSL (https) einrichtest und dafür bezahlen musst und du evtl. sogar bei einem Provider bist, bei dem du sowohl für eine Domain mit und eine ohne www bezahlen musst (gibt es tatsächlich), wenn du beide verwenden willst, solltest du erst diese Erzwingen-Geschichte eingerichtet haben und dann das Zertifikat entsprechend deiner Entscheidung bestellen. Damit du nur 1x zahlen musst und es nicht zu blöden Meldungen in Browsern kommen kann.


    Zwar kann man in Google einstellen, ob das die Seite immer mit oder www in den Suchergebnissen anzeigen soll. Trotzdem gibt es ja noch andere Suchmaschinen, die, wenn du das nicht erzwingst, Seiten ggf. doppelt anzeigen, mit und ohne www.


    Wenn du es mit htaccess erzwingst, sollte die Einstellung in Google analog sein, was ja nur ein Klick ist.