500 Internal Server Error; kein Zugriff mehr auf Webseite, Strato: angbl. Joomla/PHP-Problem

  • Danke für Eure Tipps!


    - das mit dem regelmäßigen updates sehe ich ein.
    - Und auch der Tipp, lokale backups zu machen ist gut.


    - Mein Paket bei Strato ist zehn Jahre alt "Basic Web XL". Der SSH Zugriff wird aber nur ab "Power Web" angeboten. Ich habe mit denen telefoniert: die einzige Lösung sei, auf ein anderes Paket upzugraden, das aber deutlich teurer wäre - ganz schön unverschämt, fand ich... Nun, es ging dann ja ohne lokale DB-Installation durch das Einspielen eines älteren Strato-backups.


    Jetzt sehe ich heute morgen, dass ich wieder den gleichen 500 Internal Server Error bekomme und wieder weder Webseite noch Joomla-Backend erreichbar sind!
    Dienstag Abend, nach Rückspielung des älteren Backups vom 8.8. (noch vor der ersten fatal error-Meldung), als ich wieder Zugriff auf das backend hatte, habe ich sofort auf das neueste Joomla geupdatet.


    Jetzt sehe ich im errorlog von Strato keine fatalen Fehler, die nach dem upgrade aufgetreten wären. Die jüngsten fatalen sind von Dienstag morgen. - Ich versteh das nicht!
    Die fatalen von Dienstag morgen, vor dem backup und dem anschließendem upgrade:


    18.08.2015 09:12:19 xxx.de [client 80.187.102.0] PHP Warning: require_once(/mnt/web1/b2/12/51094212/htdocs/joomla3/includes/defines.php): failed to open stream: No such file or directory in /mnt/web1/b2/12/51094212/htdocs/joomla3/index.php on line 28, referer: http://www.bing.com/search?q=b…irst=11&FORM=PERE&PC=APPL
    18.08.2015 09:12:19 xxx.de [client 80.187.102.0] , referer: http://www.bing.com/search?q=b…irst=11&FORM=PERE&PC=APPL
    18.08.2015 09:12:19 xxx.de [client 80.187.102.0] PHP Fatal error: require_once(): Failed opening required '/mnt/web1/b2/12/51094212/htdocs/joomla3/includes/defines.php' (include_path='.:/opt/RZphp5/includes') in /mnt/web1/b2/12/51094212/htdocs/joomla3/index.php on line 28, referer: http://www.bing.com/search?q=b…irst=11&FORM=PERE&PC=APPL
    18.08.2015 09:19:18 xxx.de [client 66.249.64.0] PHP Warning: require_once(/mnt/web1/b2/12/51094212/htdocs/joomla3/includes/defines.php): failed to open stream: No such file or directory in /mnt/web1/b2/12/51094212/htdocs/joomla3/index.php on line 28
    18.08.2015 09:19:18 xxx.de [client 66.249.64.0] PHP Fatal error: require_once(): Failed opening required '/mnt/web1/b2/12/51094212/htdocs/joomla3/includes/defines.php' (include_path='.:/opt/RZphp5/includes') in /mnt/web1/b2/12/51094212/htdocs/joomla3/index.php on line 28
    [...] Dienstag, 18.8., habe ich abends geupdatet.
    18.08.2015 20:37:55 xxx.de [client 87.142.77.0] Premature end of script headers: index.php, referer: http://www.xxx/administrator/index.php
    19.08.2015 08:48:54 xxx.de [client 130.180.15.0] (131)Connection reset by peer: Error reading request entity data, referer: http://www.xxx.de/index.php/ve…der=i.start_date&start=25
    20.08.2015 16:32:56 yyy.de [client 207.241.101.0] Premature end of script headers: index.php
    [danach jede Menge ähnlicher Meldungen]


    Jetzt ist es so:
    Joomala 3.4.3
    die DB hat Version 5.5.44
    das PHP 5.3.29
    Bei Strato kann ich zwischen 5.3, 5.5 und 5.6 wählen - was ist hier das richtige?


    Ich bitte noch mal um Eure Hilfe!


    Viele Grüße
    Tobias

  • Hallo Tobias,


    bei Ellwood und mir funzt es mit php 5.3.


    Mein Vorgehen wäre: Die problematischen Daten und auch ein Export der Datenbank lokal herunterladen und dort mit xampp das Problem versuchen zu bearbeiten.
    In der Zwischenzeit auf dem Webspace erst einmal eine neue "unberührte" Installation vornehmen (3.4.3), wirklich auszuschlißen, dass hier doch ein Konfigurationsfehler vorliegt.


    Christian

  • @tniemann Zur PHP Version: Du solltest PHP 5.6 nehmen. Joomla! läuft damit und alle modernen Erweiterungen, sollten auch ohne Probleme laufen. Wenn nicht, dann ist das schonmal ein Hinweis darauf, was noch so veraltetes in der Seite steckt. Ansonsten beantrage bitte bei Strato einen Tarifwechsel. Meistens bekommt man dadurch auch einen Server Wechsel und höhere Leistungen zum selben Preis. Um dein Problem zu lösen, würde ich folgendes versuchen: Bennene in deinem Joomla Root Ordner folgende Unterordner: plugins und libariers und lade nur diese wieder hoch (aus einer frischen Joomla 3.4.3 zip Datei) und schau was dann passiert. Sollte danach die Seite gehen, dann hast du das Problem schonmal eingegränzt. Ich würde zuerst die libraries umbennen und erneut hochladen und schauen ob es geht. Wenn nicht dann das selbe mit den Plugins. Bitte achte auch bei deinem FTP Programm darauf, das wirklich alle Dateien hochgeladen wurden. Strato verschluckt sich da sehr gerne.