OsMap Free - Sitemap xml - Google Search Console

  • Windows 10 (64bit)
    Joomla 3.9.2


    Hallo zusammen


    Ich habe folgendes Problem.


    Die mit der Extension OsMap Free erstellte Sitemap gibt folgenden xml Link aus:
    example.org/component/osmap/?view=xml&id=1


    Diesen Teil des Links: component/osmap/?view=xml&id=1

    trage ich bei der Google search Console (ehemals Webmaster Tools) hinter der

    Domain ein example.org/component/osmap/?view=xml&id=1
    und lade ihn hoch.

    Crawling
    Sitemaps
    Sitemap Hinzufügen/Testen


    Die Seite wird jedoch nicht angenommen.

    Die Fehlermeldung lautet:
    Beim Versuch, auf Ihre Sitemap zuzugreifen, ist ein Fehler aufgetreten. Bitte vergewissern Sie sich, dass Ihre Sitemap unseren Richtlinien

    entspricht und unter der angegeben Adresse zu finden ist, und reichen Sie sie dann erneut ein.


    Ich habe mich das ganze Wochenende mit diesem Problem befasst und auch mehrfach Beiträge im www. gefunden wo genau dieses Problem geschildert wird.
    Ein zielführender Lösungsvorschlag war allerdings nicht zu finden.


    Es wäre schön, wenn einer der Forenteilnehmer hierzu einen Lösungsweg vorschlagen könnte.


    Danke
    MfG

  • Hallo Tom


    Danke für Dein Feedback


    Ja, wenn ich die xml im Browser aufrufe funktioniert selbige Fehlerfrei.


    Wenn Du das Ganze gestern praktiziert hast, meine Frage:
    Welchen Teil des von OsMap Free erstellten Links hast Du in der Searchkonsole hinter die vorgegebene Domain eingetragen?


    component/osmap/?view=xml&id=1


    Ich schicke Dir mal einen screenshot der Fehlermeldung der Google Searchkonsole mit



    Der Hinweis darauf, dass die URL durch die robots.txt eingeschränkt ist bringt mich auch nicht weiter,

    ehrlich gesagt habe ich auch nicht ausreichend Hintergrundwissen um sagen zu können ob und falls ja

    was in der robots.txt das Hochladen der sitemap.xml möglicherweise verhindern könnte.

    robots.txt


    Versuchsweise habe ich aus der robots.txt die Zeile
    Disallow: /component/

    entfernt und die robots.txt mit ftp auf den Server hochgeladen

    Gebracht hat das auch nichts die Fehlermeldung der Google Searchkonsole blieb die gleiche.


    Grüsse

  • Versuchsweise habe ich aus der robots.txt die Zeile
    Disallow: /component/

    entfernt und die robots.txt mit ftp auf den Server hochgeladen

    Gebracht hat das auch nichts die Fehlermeldung der Google Searchkonsole blieb die gleiche.

    Das kann etwas dauern, bis Google darauf reagiert. Vielleicht lässt es sich damit etwas beschleunigen.

  • Hallo Ihr Beiden


    Vielen Dank für Eure Unterstützung.


    Der Auslöser für das Problem war tatsächlich die robots.txt.


    Ich hatte zwar per ftp die geänderte robots.txt ohne Disallow: /component/ in die Hauptrout hochgeladen

    Google hat das offensichtlich in den zurückliegenden 2 Tagen nicht registriert.


    Unter Anwendung des von Anka gesendeten Links: https://support.google.com/webmasters/answer/6078399?hl=de

    konnte ich Google die geänderte robots.txt so verkaufen, dass diese direkt gecrawlt wurde.


    Nachdem dieses geschehen war, konnte ich den Link zur Sitemap von OsMap free component/osmap/?view=xml&id=1

    unproblematisch hochladen.


    Hätte ich direkt am Samstag morgen das Problem hier eingestellt, dann hätte ich mir gut 2 Tagen recherchieren ersparen können.

    Nochmals Danke
    Grüsse Jurawakos