Backend Menü im ISIS Template funktioniert nicht

  • Hi !
    HAb ne Sicherung einer J3.9.2 Seite mit Template Protostar auf einem anderen (zweiten Webserver) eingespielt. Funktioniert fast alles.
    Im Backend (ISIS) kann ich im oberen Menüband (System/Benutzer/Menüs/Inhalt/Komponenten/Erweiterungen/Hilfe) die Untermenüpunkte nicht anklicken. Bzw klappen sie gar nicht raus.
    In der Browserzeile wird lediglich an die adresse ein: "#" angefügt. Der direkte aufruf per Link ist allerdings möglich.
    Im Hathor admintemplate scheint es zu funktionieren. Dort geht aber auch nicht alles gut, z.b. der Speicherbutton ist nicht in funktion....


    Was habe ich bisher gemacht:

    - adminverzeichnis aus einer frischen 3.9.2 drübergespielt

    - DB reperatur button geklickt

    - Es gibt keine Warnungen

    - DB neu eingespielt

    - FTP daten neu eingespielt

    - Google und Forumssuche bemüht
    - php versionen geändert
    - Fehlerberichten: MAXIMUM (keine Fehler)

    In der Entwicklertools werden in der Konsole folgende fehler gewurfen:

    ReferenceError: jQuery is not defined


    Link zur (FE)Seite testweise ist hier: https://www.ssvsayda.de/robby/joomla/index.php


    P.s.: die Originalseite auf dem anderen Webserver funktioniert tadellos...

    (Hoster ist jeweils alfahosting)

  • Das reicht oft nicht aus, wenn man ein JavaScript-Problem hat. Die Dazeien liegen ja alle im /media/-Ordner. Auch der libraries-Ordner ist oft relevant. Bügel ein FULL-Paket ohne Ordner installation und templates (Frontendtemplates) drüber

    Natürlich nicht.
    Vielen Dank Re:Later für den Anstoß. Nach dem drüberjagen funktioniert alles.
    Heißt dass, das die FTP sicherung eigentlich schrott ist oder?

  • Kann man so nicht sagen.


    Wenn du FileZilla meinst, gehört immer dazu, auf den Reiter unten "Fehlgeschlagene Übertragungen" zu achten. Egal in welche Richtung. Man kann die dann per Rechtsklick "zurücksetzen und wieder zur Warteschlange".


    Bei einigen Providern muss man die Anzahl gleichzeitige Übertragungen runtersetzen (Bearbeiten > Einstellungen), wenn sich die Fehler häufen. Meist liegt das dann daran.


    Den Webspace-Übertragungstools, die es bei einigen Providern gibt, trau ich nicht wirklich, weil da immer der Hinweis steht "Prüfen Sie selbst, ob alle Dateien...". Ist ja dann auch wieder Aufwand.


    Easy Joomla Backup verwende ich, wenn Provider "Beim Upload ZIP entpacken" anbietet (oder ich verwende nach Upload das Unzip-PHP-Tool von Kubik Rubik, das bei sehr großen ZIPs aber Probleme haben kann). Das aber eher wegen Dateinamen, die vielleicht Umlaute enthalten. Zumindest auf Windows werden die ja gerne verstümmelt, wenn man vorher lokal entpackt. Und dann weiter verstümmelt, wenn man sie mit FTP hochlädt.


    Hat dann aber wieder den großen Vorteil, dass man halt nur 1 ZIP übertragen muss, wo alles drin ist und eine SQL-Datei darin, die man ohne Kokolores in phpMyAdmin importieren kann. Und lokal halt ebenfalls schnell entpackt mit 7-zip oder so.


    Das Dateinamen-Problem hat man aber auch beim "normalen" Hin-und-Her-Kopieren via FTP.


    Akeeba Backup und Kickstart ist am Ende dann serverseitig doch die verlässlichste Variante, zumindest bei großen Seiten, auch, wenn ich da immer der Vorbereitungen wegen etwas genervt bin. Vorausgesetzt es funktioniert überhaupt, was derzeit bei einigen "1&1 Ionos"-Accounts nicht der Fall ist.


    Aber, wenn man den extract-wizard von Akeeba verwendet, um Dateien lokal zu entpacken, fehlen bei großen Archiven/Seiten hinterher auch oft Dateien.


    Beide Tools speichern einige Ordner (Cache/Logs und so Kram) und Akeeba auch Datenbankinhalte (Smart Search) nicht mit. Ist manchmal gut so, manchmal auch nicht ;-)


    Ich bügel eigentlich fast immer noch mal ein FullPaket drüber, zumindest bei Kundenseiten. Geht ja auch über Upload&Installieren in der Joomla-Aktualisierung. Fiel bei dir aber aus, wegen fehlendem JavaScript.


    "Eine beschissene Situation" ;-)