Probleme mit Joomla Kontaktformular und ECC+

  • Hallo zusammen,


    Bisher habe ich auf den von mir betreuten Homepages eine externe Kontaktformular-Erweiterung verwendet. Nun möchte ich überall zurück zum Joomla-eigenen Kontaktformular mit ECC+. Dabei habe ich bei einer Homepage Probleme.


    Die Ausgangslage ist Joomla 3.9.2 und PHP 7.0.



    Das Plugin ECC+ - EasyCalcCheck Plus ist installiert und auch aktiviert. Unter "Zusätzliche Erweiterungen" > "Core Erweiterungen" sind alle 4 Möglichkeiten mit "Ja" ausgewählt.


    Unter "System" > "Konfiguration" > "Standard-Captcha" kann ich es aber nicht auswählen, das Feld ist komplett ausgegraut.


    Unter "System" > "Konfiguration" > "Kontakte" >"Formular" > "Kontaktformular-Captcha" ist der Eintrag "Globale Einstellung (easycalccheckcaptcha)" vorhanden und auch ausgewählt.



    Das (korrekte und vollständige) Ausfüllen des Formulares führt zu der Fehlermeldung "Fehler Kein Captcha-Plugin ausgewählt oder es wurde keins gefunden. Bitte einen Administrator kontaktieren. Ungültiges Feld: Captcha"


    ECC+ wird dort aber augenscheinlich angezeigt. Was mich stutzig macht ist, dass der ECC+-Hinweistext "Das Ergbnis nur in Ziffern eingeben" (oder so ähnlich..) fehlt. Ein Override von com_contact gibt es (noch) nicht. Mit Protostar ist der Fehler auch unverändert.



    Kann mir jemand sagen was da nicht stimmt?


    Vielen Dank und viele Grüße

  • Hallo winterman

    Unter "System" > "Konfiguration" > "Standard-Captcha" kann ich es aber nicht auswählen, das Feld ist komplett ausgegraut.


    Unter "System" > "Konfiguration" > "Kontakte" >"Formular" > "Kontaktformular-Captcha" ist der Eintrag "Globale Einstellung (easycalccheckcaptcha)" vorhanden und auch ausgewählt.

    Es gibt 2 Versionen.


    a) Obiges ist/wäre: System - ECCC Easy CalcCheckCaptcha > vereinfachte Version.


    b) Das andere ist: System - ECC EasyCalcCheckPlus


    musst Dich halt entscheiden, welche Version Du nimmst :-)

    also bei der Globalen Einstellung "Nichts" & a) deaktivieren.


    Siehe auch hier - grüne Notiz: https://joomla-extensions.kubi…de/ecc-easycalccheck-plus


    Liebe Grüße

    Christine

  • Vielen Dank für eure Antworten!


    Ich war davon ausgegangen, dass ECC+ reCaptacha so komplett ersetzt, dass das reCapcha-Plugin komplett deaktiviert werden kann.



    Viele Grüße

    Das ist auch richtig. Deswegen glaube ich, dass bei dir irgendwo ein Durcheinander entstanden ist. Deinstalliere alle Plugins, die irgendetwas mit "ECC" zu tun haben ("System - ECC+" und ggf. "Captcha - ECCC") und installiere danach ECC+ nochmal.


    Kontrolliere anschliessend, was unter "System" > "Konfiguration" > "Kontakte" >"Formular" > "Kontaktformular-Captcha" ausgewählt ist. Korrekterweise müsste dort "Nichts ausgewählt" sein.




    faro


    Sorry, aber das stimmt so nicht ;). ECC+ kommt auch ohne das reCaptcha Plugin aus. Man kann es aber integrieren, wenn man will.

  • Hallo zusammen,


    nachdem ich das Formular nun größenteils angepasst habe, muss ich diesen Tread trotzdem nochmal aufwärmen.


    Kann mir jemand sagen, wie ich die Checkbox bei der Datenschutzerklärung linksbündig ausrichten kann? Ich bekomme es trotz mehrfacher Versuche nicht hin - sie ist immer noch mittig...



    Vielen Dank und viele Grüße