Wie Backup vom alten Hoster mit Xampp oder auf neuem Hoster öffnen?

  • Hallo und einen schönen Guten Tag an das Forum!

    Bei der Google-Suche bin ich auf dieses Forum gestoßen und hoffe, hier Hilfe zu finden.

    Mein Problem: Ich habe vor Kurzem den Hoster gewechselt. Von der WS auf dem alten Hoster (ist inzwischen abgeschaltet) hatte ich noch ein Backup (gesamtes Verzeichnis der alten Seite), das ich nun auf dem neuen Hoster wieder zum Laufen bringen möchte, ersatzweise auch auf Xampp. Es funktioniert nicht! Ich bekomme auf Xampp folgende Fehlermeldung:

    "Warning: session_start(): Failed to read session data: user (path: C:\xampp\tmp) in C:\xampp\htdocs\MeineWebsite\libraries\joomla\session\handler\native.php on line 258
    Error displaying the error page: Application Instantiation Error: Failed to start the session."

    Ich kenne mich mit speziellen Fragen zu solchen Sachen überhaupt nicht aus., deshalb bitte ich, um Hilfe bei folgenden Fragen:

    Wie kann ich dieses Backup auf dem Hoster oder in Xampp öffnen?

    Alternativ: Wo finde ich die Inhalte (Beiträge) der WS zum Kopieren in dem Backup, so dass ich schlimmstenfalls die Site neu erstellen kann, ohne die Beiträge (sind ziemlich viele) neu schreiben zu müssen?

    Vielen Dank schon im Voraus und Entschuldigung, weil ich mich so blöd anstelle.

    Freundliche Grüße von Thomas

  • Wo finde ich die Inhalte (Beiträge) der WS zum Kopieren in dem Backup, so dass ich schlimmstenfalls die Site neu erstellen kann, ohne die Beiträge (sind ziemlich viele) neu schreiben zu müssen?

    In der Datenbank. Ich hoffe die hattest Du mitgesichert. Deine Inhalte (außer Bilder) befinden sich nicht im Dateisystem.

    Schau mal bitte in usere Anleitunge, dort werden meherer Möglichkeiten aufgezeigt, wie Umzüge gemacht werden können.

    Bitte schau in die Forenregeln, da wir mehr Infos brauchen zu Deinem System.
    Genaue Joomlaversion? Eingesetzte PHP-Version?

  • Dieses Problem taucht DAUERND bei den 3.xxx-Joomla-Versionen auf, egal, was man da installiert hat und im Web findet man keine WIRKLICHE Hilfe, weil die Links dazu allesamt von völlig anderen Situationen als dem Otto-normal-Fall, der da lautet "Joomla 3.5-aufwärts unter php 7.xxx-aufwärts mit MySQL(i)-Erweiterung" ausgehen.


    Ich hatte das Problem auch schon mehrfach, hier nur nix dazu abgesondert, weil ich mir in d. R. selbst helfe und das in diesem Fall auf diesem Wege: Das Joomla-Datenbank-Dump (also das, was du da an Inhalten runtergeladen hast, hat nix mit der Installation der Files zu tun) will an eine php-Session anzuknüpfen, die es logischerweise auf einem an dieser Stelle leeren Xampp nicht mehr gibt. Ich habe deshalb die betreffenden Zeilen in einer Kopie dieses native.php auskommentiert und siehe da: es flutschte. Nachdem du dich ins Joomla-Backup eingelogt und da ein wenig gewerkelt hast, werden neue Session-Data hinterlegt und du kannst die originale native.php zurückstellen.


    Das kannst du ruhig im laufenden Betrieb machen, wenn du noch eingelogt bist. Ob das WIRKLICH ALLES läuft, siehst du, wenn du den internen Joomla-Cache komplett löschst und die Seite neu lädst. Am besten dann auslöschen, MySQL und Apache ganz runterfahren, so dass ein neuer PID hinterlegt wird, dann beides neu starten, Joomla-Startseite aufrufen - ist sie gleich auf dem Schirm, ist alles ok.

    In der Datenbank würde ich zu den Sessiondata nicht rumfummeln, meine, die gelöscht zu haben, gebracht hat es nix. Das sind ja temporäre Daten, die von Session zu Session neu gebildet werden.

  • JoomlaWunder


    Zitat


    Echt? Ich hatte diese Meldung bisher auf keiner einzigen Seite

    Dann freu dich doch. Das es das Problem gibt, steht im Startpost. Ich habe dazu ergänzt, dass ich selbiges Meldung beim Einspielen eines Dumps mehrfach hatte. Also was gibt es da anzuzweifeln?

    anka

    Zitat

    Dieser Fehler lässt keine Rückschlüsse darauf zu, ob die Datenbank da ist oder nicht. Der taucht z.B. auch dann auf, wenn entweder keine DB vorhanden ist oder wenn die DB-Daten in der configuratiion.php falsch sind.

    Reiner Spekulatius, solange uns der Threadstarter nicht sagt, ob er da nun ein Dump ex- und importiert hat oder was er mit "Backup" meint.

    BTW was gibt es für "falsche" Daten in der configuration.php? Unter xampp sind regelmäßig nach Export vier Werte in der Kopie der configuration.php anzupassen:


    Code
    1. public $host = 'localhost';
    2. public $user = 'root';


    Hat er das nicht gemacht, müsste die Fehlermeldung etwa so lauten: "Could not connect to MySQL".


    Und die beiden Pfade zu den tmp-Verzeichnissen. Letzteres hatte auch mal übersehen, da suchte sich Joomla den Pfad selbst und bildete neue Ordner auf der Festplatte. Ansonsten ist das ein statisches File, es sei denn, ich gebe einem Plugin die Freigabe, da was reinzuschreiben.




  • Zeig euch mal was. Das ist die PHP-Sessionverwaltung eines Apache-Servers, wie xampp ihn nachbildet:



    Bis auf den reader "why", dessen Inhalt im rechten Fenster steht, sind das alles Joomla-Session-Dateien. Der Normalfall ist, wenn du (online) keinen dedicated Server sebst administrierst, dann hast du nur einen Space bei einem Hoster gemietet und kommst da folglich nicht ran. Unter xampp und das war hier die Frage, kommt man da sehr wohl ran. Denn Joomla versucht anscheinend (nun beginnt Spekulatius, bin kein Entwickler), an die Einstellungen der letzten Session, wie sie hier gespeichert sind, anzuknüpfen, um schneller laden zu können. Wenn die (ansonsten gut mit einem Dump gefüllte) Datenbank(tabelle) die nicht findet, dann würde


    Code
    1. Failed to read session data


    wie in der obigen Fehlermeldung steht, einen Sinn machen. Dann würde ich erst mal hier und dort, also das tmp-Verzeichnis und die entsprechende Session-Tabelle im Dump löschen. Das macht man ja einer Kopie.

  • JoomlaWunder


    Dann freu dich doch. Das es das Problem gibt, steht im Startpost. Ich habe dazu ergänzt, dass ich selbiges Meldung beim Einspielen eines Dumps mehrfach hatte. Also was gibt es da anzuzweifeln?

    Ich habe nichts angezweifelt.

    Allerdings schreibst du, dass das Problem dauernd bei allen 3.x -Versionen auftaucht, egal was man installiert. Ferner schreibst du, dass du das Problem auch schon oft hattest.

    Den ersten Teil (also die Verallgemeinerung) kann ich nicht nachvollziehen. Einige User mögen das Problem jedoch regelmäßig haben. Die machen dann halt etwas anders. Und dass man die native.php ändern muss, ... mmh...


    Backup-Erweiterungen wie .B. AkeebaBackup sichern den Inhalt der Session-Tabelle bzw. des /tmp-Verzeichnisses in der Standard-Einstellung schon gar nicht mit. Macht man die Sicherung manuell und sichert das mit, dann kann man es natürlich beim Umzug löschen bzw. leeren!


    EDIT: Aber in dem hier vorliegenden Fall besteht die Befürchtung, dass überhaupt keine Datenbankinhalte bestehen.

  • Ich sichere - trotz installiertem Akeeba, das lasse ich nur eine Sicherung auf dem Webspace legen - meine Datenbank noch manuell, lasse dabei z.B. den search index (also finder_links, -terms, -tokens) aus. Andererseits kann natürlich sein, dass ich die Daten der session-Tabelle mitgesichert habe, da müsste ich die Dumps mal durchsehen bzw. neue machen.


    Ist das System unter xampp aktiv, kann man die Session-Tabelle des Dumps immer noch leeren.


    Erinnere mach aber dunkel so, dass weder das "gegenseitige" Leeren des tmp-Verzeichnisses des xampp-Apache noch die der (korrespondierenden bzw. eben nicht korrespondierenden) Session-Tabelle (des Joomla-dumps) was gebracht hat. Sonst hätte ich nicht in die native,php eingegriffen. Und da wollte Joomla dann endlich auf den rechten Weg kommen. Hinterher die originale native.php an ihren Platz gesetzt (einfach Namen tauschen) - alles gut.

    Ist ja nur eine mögliche Fehlerquelle, die ich hier beschreibe.

  • Zitat

    Ist ja nur eine mögliche Fehlerquelle, die ich hier beschreibe.

    Danke, dass du das mit der native.php mit uns teilst, vielleicht braucht das mal jemand, vermutlich liegt das an einer inkompatiblen Peripherie des Servers. In den letzten fünfzehn Jahren habe ich echt viele, sehr viele Seiten umgezogen, bidirektional, der von dir genannte Fehler tauchte dabei nicht auf. Aber was nicht war, kann ja noch werden chinese.

  • Hallo!

    Zuerst mal vielen dank für die zahlreichen Antworten. Das hier ist offenbar ein wirklich gutes Forum mit sehr kompetenten Mitgliedern.

    Entschuldigung, dass ich nicht mehr Angaben bereit gestellt hatte.

    Also, ich habe (neben Win10 1803) die neueste Joomla!-Version 3.9.3, hatte auf dem alten Server php 7.2 und habe auf dem jetzigen php7.0, was ich aber noch angleichen lassen will.

    Ja, leider bekomme ich die Fehlermeldung bezüglich der fehlenden Datenbank. Hatte ich nicht explizit mitkopiert/gespeichert, sondern nur die normalen Joomla!-Dateien. Bin eben nicht vom Fach, weshalb ich auch einige der Beiträge nicht völlig verstehe. Scheinbar ist es aber nun so wie J!-n schreibt, dass die Seite weg ist und eine Anzeige der WS zwecks Erstellung von Textkopien weder mit Xampp noch auf einem Browser möglich ist. Also alles neu schreiben.;(;(;(

    Beim nächsten Mal weiß ich , Dank dem Link von Sieger 66.

    Trotzdem noch einmal eine Nachfrage: Nach meinem Verständnis müsste zumindest der reine Text doch irgendwo auf dem PC gespeichert sein. Aber wo?

    Freundliche Grüße von Thomas!

  • Zitat

    Nach meinem Verständnis müsste zumindest der reine Text doch irgendwo auf dem PC gespeichert sein. Aber wo?

    Es tut mir echt leid für dich, aber es gibt keinen *reinen Text". Sämtliche Inhalte (Beiträge, Module usw.) werden ausnahmslos und ausschliesslich in der Datenbank gespeichert. :(.

  • *schluck*=O


    Zitat


    habe auf dem jetzigen php7.0, was ich aber noch angleichen lassen will.

    Normalerweise müsstest du die PHP-Version doch selbst einstellen können? Wir sind seit 11 Jahren bei all-inkl Neue Medien Münnich, da geht einfach alles. Sehr selten muss ich den Support um eine Auskunft bitten. Waren vorher bei InternetX.de, das ist, meine ich, jetzt eine Division von 1und1, das war die helle Katastrophe.

    Nun frag doch deinen alten Hoster mal nach einem Server-Backup, das er eigentlich für den Fall, dass der Server crasht, täglich anlegen muss. Er sollte die letzten 10 Versionen gesichert haben. Wenn du jetzt noch lange wartest: Die alten Versionen werden automatisch gelöscht. Ich kenne die Aufbewahrungsfristen nicht, 4 Wochen erschiene mir logisch. Möglicherweise musst du für die Wiederherstellung deiner db einen Aufpreis zahlen, das ist aber doch nichts im Vergleich zu dem Riesenaufwand, die Texte neu zu schreiben.

    Andere Möglichkeit: Gib mal , falls deine ganze Site öffentlich war, im Google-Suchfeld den String ein: "site:mypersonalsite.com", ohne Anführungsstriche und den Namen der Beispiel-Domain durch deine eigene ersetzen. KEIN Abstand zwischen dem Doppelpunkt und dem Namen der Domain, NUR die Domain "pur", ohne Protokoll, also ohne "https://"! Dann sollte Google dir alle Links, die es noch gespeichert hat, ausgeben. Rechts neben dem jeweiligen Link ist ein kleiner Winkel zum Aufklappen, da raufklicken. Die Seite wird mit Bildern, aber ohne CSS / JavaScript dargestellt. Dann runterladen, so hast das Wichtigste, nämlich die Texte und viele Bilder.

    Versuche das ähnlich auch bei xandex.ru, da sind noch andere bzw. ältere Cache-Dateien, sowie auf web.archive.org.

    Good luck:thumbup:

  • @j!-n: Das andere Problem, welches (auch) von native.php jedenfalls angezeigt wird: Danke für deine Zustimmung. Ich gehe jetzt mal von der Arbeitshypothese aus, dass die Fehlermeldung bei mir daran liegt, dass ich die Session-Tabelle mit runtergeladen und wieder unter xampp importiert habe. Ich werden mal eine Versuchsanordnung machen, um die Fehlermeldung zu reproduzieren.

    Es kam z.B. vor, wenn ich, um eine "frische" installation zu bekommen, das neueste Joomla-Paket runtergeladen habe und dann die online-DB (samt Session data) in die Datenbank importiert habe (oder umgekehrt, erst db analog der online-db gebildet, und importiert). Aber das ist alles länger her, muss das testen.


    Mit den Daten in der configuration.php hat das nichts zu tun. Das ist einfach eine Kopie der online-Datei, die genannten 4 Werte an die xampp-under-windows-Vorgaben angepasst (bei den Linuxern wird z.B. der tmp-Pfad anders sein). Ansonsten ist das File statisch.

  • Trotzdem noch einmal eine Nachfrage: Nach meinem Verständnis müsste zumindest der reine Text doch irgendwo auf dem PC gespeichert sein. Aber wo?

    Wenn du den Text direkt in den Joomla-Beitrag geschrieben hast, was der Normalfall ist, dann ist er weg, wenn du keine Sicherung der DB-Tabellen hast. Eventuell kann der Hoster hier noch helfen.

    Wurden die Texte hingegen in einem Editor auf dem Rechner "vorgeschrieben" und dann in die Beiträge kopiert, könntest du Glück haben, dass sie noch irgendwo auf dem Rechner liegen. Das kannst aber nur du wissen.

  • thommyt

    Eine schnelle Nachfrage beom alten Hoster, ob noch ein Backup der Seite oder der Datenbank vorhanden ist ist eine gute Idee.

    Wenn die Seite schon online war und du Glück hast, kannst du auch eventuell noch in http://cachedview.com/ Inhalte finden und dann per copy/paste retten.

    Wenn du bei einem neuen Hoster bist kannst du gewöhnlich dort einen Umzugsservice in Anspruch nehmen, veilleicht kostet es ein paar Euro und es ist noch waszu retten.


    Nach 10 Jahren mit Joomla und hunderten Installationen und Umzügen habe ich nicht einmal in eine native.php eingegriffen. Joomla ist ein ausgereiftes Produkt und braucht das nicht.

    Und nach ebenfalls hunderten Installationen und Umzügen der 3.9 habe ich die genannte Fehlermeldungen zwar gelegentlich, aber NUR, wenn ich mich bei den Datenbankdaten vertippt habe.