URL wird automatisch auf httpS umgesetzt

  • Hallo,


    ich habe z.Zt. das Problem, daß "irgendwas" meine URL-Verlinkung automatisch auf httpS umsetzt.

    Im Joomla-Editor steht eindeutig im Quelltext HTTP (ohne S)

    Code
    1. <td style="width: 300px;">&nbsp;<a href="HTTP://prodogromania.de/" target="_blank"><img alt="www.prodogromania.de" class="pull-center" src="images/Kooperation/www.prodogromania.de.png" style="width: 200px; height: 200px;" title="ProDog Romania e.V." /></a></td> <td style="width: 300px;"><a href="http://www.tierheim-karlsruhe.de" rel="noopener noreferrer" target="_blank" title="Tierheim Karlsruhe"><img alt="Tierheim Karlsruhe" class="pull-center" height="200" src="images/Kooperation/www.tierheim-karlsruhe.de.png" title="Tierheim Karlsruhe" width="200" /></a></td> <td style="width: 300px;"><a href="http://www.witas-ka.de/" target="_blank"><img alt="Wildtierauffangstation Karlsruhe e.V. (WITAS)" src="images/Kooperation/Witas-Logo.jpg" title="Wildtierauffangstation Karlsruhe e.V. (WITAS)" /></a></td> </tr>

    aber wenn man die Seite aufruft, ein Beispiel

    dann ist im Quellcode der Seite plötzlich überall httpS gesetzt.

    Einerseits natürlich aus Sicherheitsgründe eine feine Sache, aber (leider) sind noch immer nicht alle Internet-Seiten über https erreichbar hmm
    Von daher ist eine generelle automatische Überschreibung auf allen Seiten nicht wünschenswert.


    Ich würde mal behaupten, daß dies bei der Einrichtung der Seite (ca. 6 Monaten) nicht der Fall war, da habe ich ja alle Links überprüft.

    Hat jemand eine Idee, wer da aktiv eingreifen könnte? wie kann ich dem Verursacher auf die Schliche kommen?


    Für jeden Tipp dankbar

  • Wahrscheinlich hast du in Joomla selbst das HTTPS/SSL aktiviert. Wenn du das über die htaccess-Datei machst, hast du den Effekt nicht.


    EDIT. Das ist da normale und auch gewollte Verhalten von Joomla. Noch nachgereicht.

    Ich bin etwas irritiert... hmm


    Auch wenn ich unter System > Configuration > Server die Option "HTTPS erzwingen" aktiviere, werden Verlinkungen zu fremden Webseiten, die ich im Editor einfüge, in keiner Weise verändert. D.h. ein http-Protokoll wird nicht automatisch in ein httpS umgewandelt. Das wäre kein normales Verhalten von Joomla, und gewollt kann es erst recht nicht sein. Oder habe ich da etwas verpasst?



  • Hallo,


    meiner Meinung nach ist alles ok, denn im Fall vom 2. und 3. Link ist es so, dass wenn man die jeweilige Homepage mit dem normalen http:// aufruft, diese Seiten anscheinend jetzt ein SSL Zertifikat eingebunden haben und dies eine automatische Weiterleitung der http: zu https im Server eingestellt haben. Deshalb funktionieren Deinen links weiterhin. Nur im Fall von prodogsromania kommt ein Fehler.. eventuell ist im Helix Framework etwas aktiviert, das diese links umwandelt?

  • > Nur im Fall von prodogsromania kommt ein Fehler..

    ja, dort hat man wohl immer noch nicht auf TLS umgestellt, aber darauf habe ich leider kein Einfluß

    Und das ist das Problem, denn durch die "Automatik" ist die Verlinkung leider unbrauchbar


    > eventuell ist im Helix Framework etwas aktiviert, das diese links umwandelt?

    ich wüßte nicht wo sich da etwas dementsprechendes einstellen läßt.
    Das Framework ist auch nicht aktualisiert worden. Die Neuerung der automatischen SSL-Umstellung kam aber vor nicht allzu langer Zeit.

  • Das Problem ist, dass ProDog Fehler auf ihren Seiten haben. Das liegt nicht an dir ProDog hat einen Fehler bei seiner https://. Man kann die Site aufrufen, wenn man das Sicherheitszertifikat "händisch" zum Browser hinzufügt. In der Adresseingabe vom Browser wird dann aber bei ProDog angezeigt, dass dort Fehler sind und die Site angeblich nicht sicher ist. Ich denke, dass das daher kommt, dass ProDog seinerseits Aufrufe mit "http" haben, was diesen Effekt gern auslöst.

    Wenn du das auf deinen Seiten zu "http://" zurücksetzt, bekommst du wiederum Probleme mit deiner Site, die dann als unsicher eingestuft wird. Was sie nicht ist, aber das ist halt das Problem dabei.


    Was du machen kannst: ProDog davon in Kenntnis setzen und ihnen mitteilen, dass du, bis zur Behebung, die Site leider nicht verlinken kannst. Ist bitter, aber mittlerweile ist diese Problematik ja nicht mehr so unbekannt.


    Und so ganz am Rande: Man macht dieses Tabellenlayout, was du da gemacht hast, seit vielen Jahren schon nicht mehr. Hat was mit Barrierefreiheit zu tun, was einem Tierschutzhof sicherlich auch gut machen würde, wenn er sich darüber Gedanken macht. Gibt ja nicht umsonst diverse Tiere, die behinderten Menschen helfen ;)

    Und wir Karlsruher leben schließlich in einer IT-Hochburg! Also noch mehr Anreiz, das richtig zu machen ;)


    Besser: du setzt einfach ein paar Module mit den Logos und der Verlinkung nebeneinander.




    Axel

  • Hallo Axel


    Es geht nicht darum, dass ProDog kein oder ein falsch konfiguriertes TSL hat, sodern dass beim TE alle manuell eingefügten http-Links automatisch in httpS umgewandelt werden. Woran das liegt, weiss ich allerdings auch nicht, denn Joomla macht das normalerweise nicht.

  • Lui_brempt , Du bist mein Retter beer


    Asche auf mein Haupt 8|, vor längerer Zeit habe ich mal mit den Admin Tools von Akeeba rumgespielt und scheinbar diese Option als ganz sinnvoll angesehen und aktiviert, aber den vollen Wirkungsgrad nicht erfaßt hmm und vorallem diese Option komplett wieder vergessen.


    Option wieder deaktiviert und schon ist der Spuk weg pardon


    Auch an alle Anderen, vielen Dank für die Unterstützung :thumbup: