Älteres Joomla lokal zum Laufen bringen?

  • Hallo ihr, folgender Fall :-) Ein älteres Joomla (wo erkenne ich die Version?) lag auf einem Server und wurde lange nicht mehr aktualisiert. Auch die Warnungen des Providers wegen Umstellung auf PHP7 wurden ignoriert. Nun kommt man nicht mehr in den Adminbereich. Ich habe die komplette FTP-Struktur und die Datenbank. Ich habe das auf Mac mit MAMP und auf Windows mit XAMP versucht, aber ich stoße da an meine technischen Grenzen. Ich vermute das der lokale Server mit einer älteren PHP Version laufen müsste. Auch was ich da genau in der configuration.php genau ändern bzw. anpassen muss weiss ich nicht genau. DB Name User und PW habe ich gemacht. Fragen über Fragen. Gibt es da eine Anleitung? Ich brauche das auch nur um an den Inhalts-Text zu gelangen. Danke für eure Hilfe

  • Im aktuellen Joomla findest du die Version hier:

    administrator/manifests/files/joomla.xml


    In älteren Joomla weiß ich das nicht mehr. Habe aber gerade folgendes gegoogelt:


    Joomla! 1.0.x - ./includes/version.php

    Joomla! 1.5.x - ./libraries/joomla/version.php

    Joomla! 2.5.x & 3.x - ./libraries/cms/version/version.php


    Suche in den Dateien nach "$RELEASE" ! (Ohne Garantie)


    Seit wie vielen Jahren besteht denn dein Joomla schon?


    BTW: In Xampp ist für die Datenbanken standardmäßig kein Passwort eingestellt. Lass das also in der configuration.php leer!

    Könntest aber auch in Xampp eines setzen und dieses dann verwenden.

    Die anderen Einträge lauten "localhost" und "root", sowie natürlich das Präfix.

  • Danke für die super schellen und guten Antworten. Also die version.php finde ich unter diesem Pfad (Joomla! 1.5.x - ./libraries/joomla/version.php) wie von JoomlaWunder beschrieben. Bedeutet das (var $RELEASE = '1.5';) 1.5? Wenn ich mir die Anleitung Server zu Lokal anschaue bekomme ich Angst. Das würde ich evtl. hinbekommen aber das dauert ja einen Tag :-( Und es gibt keinen einfacheren Weg nur an die texte vom Inhalt zu gelangen? Ich bin nicht faul habe aber nie Zeit :-) Grüße und danke für die guten Tips

  • Warum 1 Tag?


    Installiere dir z.B. das Xampp, welches die PHP-Version 5.4 hat. (Für Joomla 1.5 eignet sich PHP 5.3 oder 5.4)

    https://downloads.joomla.org/technical-requirements


    Damals konnte man aus dem Namen der Xampp-Version noch nicht die PHP-Version ablesen. Ich meine, dass Xampp 1.8.2 damals das richtige für Joomla 1.5 war (wahrscheinlich PHP 5.4).

    Brauchst es ja nicht mal installieren, sondern nur direkt unter c:/ schieben oder wie auch immer deine Festplatte sich schimpft. Nötig sind nur Apache und phpmyadmin.


    https://sourceforge.net/projec…pp/files/XAMPP%20Windows/


    Dateien in /htdocs schieben (falls du her bereits mehrere Unterordner hast, dann in einen weiteren Unterordner)!Datenbank-Tabellen importieren!

    configuration.php anpassen und fertig!

  • Ok klingt gar nicht so schwer. Ich war also schon nah dran. Hier bekommt man wirklich Hilfe! Ich glaube das könnte ich hinbekommen. Allerdings habe ich jetzt kurzfristig eine viel einfachere Lösung. Wie gesagt ich benötige ja nur den Inhaltstext. Ich habe diese alte Joomla-seite doch tatsächlich auf so einem Server gefunden, der alte Seiten abspeichert: WayBackMachine. Unglaublich: alles funktioniert da noch samt Bilder, Text, Links etc. :-) Aber danke trotzdem für eure gute Hilfe. Danke und Grüße Micha

  • Wie gesagt ich benötige ja nur den Inhaltstext.

    Der Inhalt der Beiträge steht in der Datenbank. Mit PHPMyAdmin oder einem ähnlichen Tool kommst Du da ran (copy & paste). Die ganz alten Säcke unter uns wissen vielleicht noch, wie die entsprechende Tabelle in Joomla 1.5 heißt.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )