Localhost einrichten

  • Hallo zusammen,


    ein ähnliches Problem habe ich auch :-(.


    Nachdem ich nun 2 mal Xampp und 4x Joomla 3,9 übergebügelt habe, komme ich nur bis zur Datenbank Konfiguration. Nun kommt die Fehlermeldung:


    Fehler

    Es konnte keine Verbindung zur Datenbank hergestellt werden! Der Konnektor gab folgenden Fehler zurück: Could not connect to MySQL server.



    Was habe ich denn falsch gemacht?


    VG Peter

  • Es konnte keine Verbindung zur Datenbank hergestellt werden! Der Konnektor gab folgenden Fehler zurück: Could not connect to MySQL server.

    In 90% alle Fälle stimmen die Zugangdaten zur Datenbank nicht.

    I.d.R.
    Host = localhost
    User= root
    PW = leer lassen


    Du kannst über phpMyAdmin im Vorfeld schon eine neue Datenbank anlegen, meistens klappt es dann reibungsloser.

  • Hallo - habe eine "Pause" eingelegt. Bitte um Verständnis. Nach x-mal Versuchen gebe ich auf und arbeite weiter mit dem "Hoster-Joomla". Trotzdem hoffe ich noch auf eine

    funktionierende Lösung aus dem ForumKreis. Bis dahin meinen verbindlichsten Dank.


    Gruß Heinrich

  • Moin Moin,


    bin ganz neu hier. Habe zum üben auch erstmal auf meinen Rechner Joomla installiert unter Xampp. Habe nur User: root und Datenbankname eingeben. Und auf alte Datenbank löschen geklickt. Habe sonst die gleiche Fehlermeldung bekommen


    Gruss

    Lampro

  • Hallo Heinrich,

    Trotzdem hoffe ich noch auf eine

    funktionierende Lösung aus dem ForumKreis.

    eine Pause einlegen kann machmal ganz gut sein. Das Einrichten von Joomla in einer XAMPP-Umgebung ist eigentlich keine komplizierte Sache zumal Du das Buch von Tim Schürmann zur Hand und hier im Forum viele Hinweise erhalten hast.

    Was mir allerdings von Dir noch fehlt, ist die Angabe für welche der Varianten Du dich entschieden hast sowie eine möglichst präzise Auflistung der einzelnen Schritte. Einige der Supporter haben Annahmen getroffen bzw. nach Scrennshots etc, gefragt aber leider nichts erhalten.

    Ich vermute, dass es "nur" eine Kleinigkeit sein kann, die Dein Vorhaben bis jetzt scheitern ließ (vllt. irgendetwas, Du immer wieder "übersehen" hast. Daher wäre es sehr hilfreich, wenn Du die benötigten Infos bereitstellen würdest.



  • Ich bin nahe der Verzweiflung und sende euch mal einige Screenprints. Eigentlich sieht es nach der Konfiguration gut aus, aber beim installieren kommt joomla nicht zum Ende. Der Prozeßbalken bleibt immer am gleichen Ort stehen.


    Kann ich mir eine Datei ansehen, um zu wissen, dass Joomla noch in der Installation ist?


    Ist es vielleicht einfacher joomla von einer externen Platte zu starten? Ich habe Joomla und Xampp ja nun auch schon 5 mal de- und dann wieder installiert...:-(

  • Kann ich mir eine Datei ansehen, um zu wissen, dass Joomla noch in der Installation ist?

    Habe früher auch XAMPP verwendet und erinnere mich ganz trübe an das Problem. Musst hier mal im Forum suchen, da gab es einige Threads dazu.

    Inzwischen verwende ich Uwamp, Anleitung >> hier.

    Wenn Du es probieren willst, Uwamp muss nicht installiert werden, Backups sind einfach per C&P möglich und man kann zwischen verschiedenen PHP-Versionen wählen.

    Zu XAMPP:

    Damals waren einige Standardwerte in der Datei php.ini nachzujustieren. Schaue gleich mal nach. Keine Ahnung, ob es mit den modernen Versionen noch nötig ist. Such Du schon mal die Datei php.ini in Deiner XAMPP-Installation.

    Ganz blöde Frage zwischendurch:

    Werden im Control-Panel von XAMPP der Apache und MySQL als "laufend" (grün) angezeigt?

    EDIT: Das meint auch KarEm mit seiner Frage.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • php.ini:

    Ich hab mal aus der Erinnerung "die verdächtigen Kandidaten" rausgesucht.

    Welche Werten stehen in Deiner php.ini hinter den Parametern?

    Als groben Richtwert habe ich die Zeilennumern meiner alten php.ini dazugeschrieben (können bei Dir andere sein).

    458: max_execution_time

    479: memory_limit

    535: error_reporting

    770: post_max_size

    992: upload_max_filesize

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Screenprints.

    Auf dem Sreenshot #4 ist eine Bitnami-Datei zu sehen. Hast Du XAMPP von https://www.apachefriends.org und Joomla als Add-on von https://bitnami.com heruntergeladen? Diese Kombi hatte ich anfangs auch einmal genutzt und, wenn ich mich richtig erinnere, erwartet diese Kombi Joomla in einem anderen Folder. Vielleicht macht dies hier auch Ärger.

    Ich nutze nur noch die *zip-Pakete von XAMPP und Joomla (dadurch werden auch keine Einträge in die Win-Registry gemacht).


    Im XAMPP-Folder (*zip-Variante) gibt es eine Datei setup_xampp.bat die sollte nach dem Entpacken von XAMPP ausgeführt werden (damit werden einige Pfade und Einstellungen angepasst). Da ich aber Deine Installationsvariante nicht kenne, kann dieser Hinweis hinfällig sein.

  • diese Kombi Joomla in einem anderen Folder.

    hab's wieder gefunden:

    xampp -> apps -> joomla -> htdocs

    statt

    xampp -> htdocs -> joomla


    Wenn da etwas verwürfelt wurde, könnte dies auch Probleme machen.


    EDIT: Habe den Bitnamiansatz so verstanden, dass man neben Joomla z.b. auch noch Drupal im apps-Folder haben will.