Nachinstallationshinweise

  • Posting #2, # RewriteBase / aktivieren, also # davor wechnehmen. Bitte auch tun, was wir Supporter dir schreiben, sonst wird das zum Deppenpingpong. Oft ein Trial & Error.


    Wenn die Seite mal gehackt werden sollte, hat man mehr mit dieser Schlangenöl-htaccess zu tun, als alles andere...nono. Besser die originale einsetzen, und darauf aufbauen.

  • Anruf beim Hoster; Ursache ist Joomla selber, aber warum das können sie nicht sagen.

    Bleibt ja nur noch, das ich auf meine funktionierenden Datei bleibe.


    ? Frage bleibt, warum funktioniert die Datei von joomla-profis nicht auf meine Jommla Seite.....?

  • ? Frage bleibt, warum funktioniert die Datei von joomla-profis nicht auf meine Jommla Seite.....?

    Ich weiß nicht, was du mit "joomla-profis" meinst, aber vermutlich ist die von joomla-security de. Die ist keineswegs empfohlen und funktioniert bei vielen Joomlas nicht. Den Fehler jeweils zu finden bedeutet, sich mit htaccess auszukennen und davor zu sitzen. Man muss schrittweise deaktivieren und schauen, wann's wieder funktioniert.

    ABER, und das ist die Crux, man muss RICHTIG die zusammengehörigen Blöcke deaktivieren und nicht nur einfach Zeilen. Und Blöcke sind nicht intuitiv zu erkennen (ohne Erfahrung).


    Deaktiviert man falsch und funktioniert auf den ersten Blick, ist oftmals an anderer Stelle der Webseite dann doch was falsch oder sogar gefährlich falsch.


    Fehler wie deiner in einer htaccess kann man durch Kleinigkeiten verursachen. Z.B., falls der Editor mit "UTF-8 und Bom" speichert und nicht pures UTF-8.


    Vielleicht auch verbotene, aber unsichtbare Zeichen durch Copy und Paste am Zeilenanfang oder -ende.

  • Moin All und den Schreibern zu meiner Frage, warum diese nicht funktioniert um sich zu schützen.

    j!-n , habe die Originale von der Vers. 3.9.4 mir im Notepad++ angesehen und sehe das dort der Eintrag-># RewriteBase / angelgt ist ?!

    ja was den nun? Du schriebst ja immer die originale einsetzen um so keine Besucher zu bekommen.


    JoomlaWunder , Danke für deinen Hinweis -> das lese ich mir mal in Ruhe durch, den in der 3.9.3 hatte ivh noch nicht den Eintrag versucht anzulegen.


    Re:Later , Danke für deinen Hinweis zu dem UTF-8, das war gestern der Fall-> deswegen kommt auch keine 404 Fehler zu Ansicht!


    Datei Anhang der Originalen Version mit dem Ergänzungsatz, was angelegt werden soll -> Webseite nicht erreichbar?

    Sollte jemand Zeit haben, würde ich mich freuen diese doch zum laufen zu bekommen. Danke

  • Führe mal alles gleichzeitig durch und teste dann (also nicht nur immer 1 Eintrag ändern und wieder rückgängig machen, bevor man den nächsten Eintrag ändert):


    1. In der zuletzt geposteten htaccess steht der 3-Zeiler nun doppelt drin. Entferne diese Zeilen!

    2. Setze: # Options +FollowSymlinks

    3. Setze: RewriteBase /

    4. Setze auch die obersten Zeilen mal als Kommentar, also:


    #AddHandler php72-cgi .php

    #php_value memory_limit 256M

    #php_value max_input_vars 10000

    #php_value max_execution_time 300

    #php_value max_input_time 300


    Auch wenn es ohne den 3-Zeiler funktioniert, würde ich das mal testen! Kommt dann immer noch ein 500er.



    5. Schalte mal testweise um auf Protostar und teste mit dem 3-Zeiler. Cache leeren!


    Welchen Hoster hast du denn überhaupt?


    BTW: Der Unterschied zwischen der Standard-htaccess und der erweiterten htaccess von joomla-security liegt vor allem in dem zusätzlichen Hackschutz. In beiden Dateien müssen in jedem Fall gewisse Einträge überprüft und ev. je nach Hoster angepasst werden.

    Wenn von der Verwendung der Originalen die Rede ist, heißt das nicht, dass z.B. RewriteBase / als Kommentar so bleiben soll. Bei 1&1 muss es beispielsweise zwingend aktiviert sein.


    Wenn es an dem Editor liegen sollte, dürfte die .htaccess ohne den 3-Zeiler auch nicht funktionieren, wenn sie falsch abgespeichert wird. Oder verwendest du zwei htaccess, die du durch umbenennen aktivierst?