Startseite setzt sich nach gewisser Zeit zurück

  • Hallo zusammen,


    ich bin beim Thema Webseite nicht so bewandert, auch wenn ich mich schon sehr daran versucht habe. Aktuell komme ich einfach nicht weiter und verschlimmbessere das Ganze nur.

    Meine Konfiguration:

    - hosting bei netcup

    - Webseite mit joomla 1.5.6.4

    - Webseite erstellt mit Web Presence Builder 17.0.16


    Ich habe das Problem, dass sich nach bestimmter Zeit (alle paar Wochen) meine Seite wieder auf eine joomla Standardseite (getting started) zurücksetzt. Link zu meiner Seite : https://darkstar-fireworks.de/

    Nach bestimmter Zeit kommt die Seite mit dem screenshot im Anhang.


    Ich habe festgestellt, wenn diese Seite da ist, habe ich im httpdocs eine index.php. Wenn ich dann mit dem Web Presence Builder die Seite neu veröffentliche, ist die index.php verschwunden, dafür wird eine index.html erstellt und meine Seite ist wieder da. In den Joomla Menüeinstellungen ist auch nur der Standard enthalten, welchen ich nicht deaktivieren oder ändern kann. Dazu noch Screenshots im Anhang.


    Es ist mittlerweile extrem nervig jeden Tag zu prüfen, ob meine Webseite noch funktioniert, aber leider komme ich einer Lösung nicht näher.


    Hat von euch jemand eine Lösung?


    Vielen Dank

    Torsten

  • Hallo ! Es gibt ein großes Problem. Deine Joomla Version ist Megaaaaaaaaaaaaaaaaaaa Alt...


    Du hast laut eigener Aussage eine Joomla 1.5. Version. Stand heute ist Aktuell die Version 3.9.6! (Ein update könnte schief gehen und ist nicht so leicht wie ne Wurschtbemme fressen)
    Ich glaube das du auch gehackt sein kannst oder irgendwelche groben fehler drin sind.


    Wen ich sehe was deine Seite für Inhalt hat, dann machst Du, und achtung das meine ich ernst, am Besten eine Neue Jomla Seite auf also eine komplette neue Installation mit der aktuellen Joomla 3.9.6 Version

    Da bist du erstmal wieder auf einem neuen Stand und kopierst Dir dann deine neuen Texte wieder rein... Eine Installation mit Beispieldatein sollte schon viel wert sein für Dich.
    Anleitungen für Anfanger findest du bei uns im Forum oder im Netz...
    Deine Kentnisse kann ich schwer einschätzen...

  • Hallo Torsten,

    deine Seite mit dem Link ist ja keine Joomla-Seite. Bei mir wird auch nichts zurückgesetzt.


    Wo finde ich denn die Joomla-Seite?

    Und Joomla 1.5 ist auch völlig veraltet und ein Sicherheitsrisiko.

    Wobei deine Bilder mindestens eine 3er-Version anzeigen


    Die letzte der 1.5er war 1.5.26

    Gibt es dafür einen extra Link?


    Alles ein wenig undurchsichtig für mich zur Hilfe.

  • Das, was man jetzt gerade sieht (die Seite mit dem Feuerwerk als Hintergrund) ist keine Joomla-Seite. Die wurde offenbar mit diesem Web Presence Builder erstellt. Daneben scheinen sich aber auch eine Joomla-Installation auf deinem Webspace zu befinden (oder zumindest einige Joomla-Dateien), wobei das dann die Version 3.9.6 wäre (s.hier). D.h. du hast wahrscheinlich im gleichen Verzeichnis zwei verschiedene Systeme gemischt. Warum jetzt mal die Joomla-Startseite und mal die html-Seite angezeigt werden, weiss ich ehrlich gesagt auch nicht. Da müsste man mal deinen Webspace untersuchen.

  • Hallo zusammen,


    vielen Dank für die zahlreichen Antworten. Ich habe zumindest verstanden, das der Web Presence Builder und Joomla 2 verschiedene Programme sind. (joomla ist auf Stand 3.9, habe es mit einem anderen Programm verwechselt). Ich war in der Annahme, mit der Web Presence Builder ein Template für Joomla zu erstellen...

    Die Builder Seite gefällt mir nicht wirklich, daher würde ich mich jetzt mal in Joomla einarbeiten und die Tutorials studieren.


    Hat noch jemand eine Idee, warum die Joomla Seite denn immer wieder aktiv wird? Für die Übergangszeit würde ich erst einmal die Seite per Web Presence Builder online lassen.


    VG Torsten

  • Hallo Chris,


    ich habe hier schon eine .htaccess im Verzeichnis httpdocs. Kann ich in dem Code selbst etwas anpassen, oder einfach nur (wo?) hinzufügen:



    Wenn ich die Seite neu veröffentlich mit dem Web Presence Editor, verschwindet die index.php und wird durch die index.html ersetzt. Ich habe die index.php nur noch im Verzeichnis httpdocs/administrator.


    VG Torsten

  • Wenn ich du wäre, würde ich im Joomla SEF komplett deaktivieren, die jetzige .htaccess umbenennen (zB in htaccess.txt, ohne . davor, so wie Joomla ausgeliefert wird), und eine neue .htaccess mit obigem Inhalt anlegen.


    Das Joomla Frontend sollte dann noch mit https://darkstar-fireworks.de/index.php erreichbar sein. Trotzdem würde ich das auseinanderdividieren.

  • Trotzdem würde ich das auseinanderdividieren.

    Damit würde ich wahrscheinlich sogar anfangen. Habe mich über den Web Presence Builder eben nur kurz eingelesen, keine Ahnung, ob ein Backup davon gezogen werden kann, das nur dessen Dateien enthält. Ansonsten müsste man die Joomla-Dateien aus dem Webspace "raussezieren". Dann kannst Du Dich (lokal oder in einem per Verzeichnisschutz geschütztem Unterordner) in Ruhe beschäftigen und dann später umsteigen.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Das würde ich ehrlich gesagt gar nicht machen.

    Ich würde in dem Verzeichnis alles gleich lassen und es nicht mehr anrühren.


    Ich würde erstmal Joomla in ein ganz neues Verzeichnis neu installieren und dort wie du schriebst neu anfangen. Zum Arbeiten richtest du dir am besten ne neue Subdomain ein, die auf den neuen Ordner zeigt.


    Das mit dem auseinanderdividieren würde ich nicht machen ohne richtige Kenntnisse was wozu gehört, weil da vergisst man eine Datei/Ordner was auch immer und schon klappt es nicht :)

  • Und wohin mit dem Müll? Der sollte entfernt werden, uU verwaist er, und ist dann noch über eine System-Domain des Hosters erreichbar. Nicht selten werden aus nostalgischen Gründen "konservierte" Installationen Opfer eines Hacks. Aus Erfahrung kann ich sagen, dass es bei einem Hack auch zu Übergriffen auf andere Verzeichnisse / Installationen kommen kann. Nein, dann lieber ordentlich.

  • Beides schließt sich nicht aus.

    Joomla auf Subdomain im Unterordnet installieren und schnell zur gewünschten Seite erarbeiten.

    Dann hauptdomain auf en Unterordnet mit Joomla umstellen.

    Danach, wenn man es unbedingt konservieren will, die Dateien im Mischordner per FTP lokal kopieren und den Rest löschen.

    Ich gehe davon aus, dass es der Root Ordner des Webspace ist und einige Ordner nicht löschbar sein werden z.B. der für Logs. Hier sollte dann genau geschaut werden, damit nichts verbleibt, was die Seite später gefährdet.

  • Beides schließt sich nicht aus.

    Joomla auf Subdomain im Unterordnet installieren und schnell zur gewünschten Seite erarbeiten.

    Dann hauptdomain auf en Unterordnet mit Joomla umstellen.

    Danach, wenn man es unbedingt konservieren will, die Dateien im Mischordner per FTP lokal kopieren und den Rest löschen.

    Ich gehe davon aus, dass es der Root Ordner des Webspace ist und einige Ordner nicht löschbar sein werden z.B. der für Logs. Hier sollte dann genau geschaut werden, damit nichts verbleibt, was die Seite später gefährdet.

    Genau darum ging es mir. Ich meinte nicht nie löschen sondern nur sauber jetzt neu anfangen in einem Unterordner mit Subdomain und danach den anderen Quatsch alles löschen. Auch diesen builder usw...

  • Es geht mir darum, die Seite des Web Presence Builders lauffähig zu bekommen und zu halten. Die beiden System beharken sich und Joomla ist nicht nutzbar. Notwendige Updates sind nicht einspielbar und / oder stören die andere Webpräsenz. Hackgefahr, s.o.. Ein paralleles Joomla im Unterordner ist richtig. Die Mischinstallation muss aufgedöselt werden, ggf. eben mit professioneller Hilfe. Das sollte kein Vermögen kosten, schont die Nerven und ist IMHO ein echter Sicherheitsgewinn.

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • Deine Joomla-Version ist ja wohl derzeit die 3.9.6:

    https://darkstar-fireworks.de/…anifests/files/joomla.xml


    Bei welchem Webhoster und welches Paket hast du bei ihm für die Website ?


    Hast du im Backend dein Joomla! auf die Version 3.9.6 selbst aktuallisiert oder ist dies ohne dein zutun irgendwie "automatisch" passiert ?

  • Vielleicht warten wir einfach bis sich @calabi78 mal wieder zu Wort meldet. Ansonsten sind wir uns glaube ich recht einig hier nachdem wir alle das selbe meinten uns nur erstmal nicht alle verstanden haben. Ansonsten machen wir nur noch mehr Chaos.

    Die Frage nach dem Webhoster und dem Paket von Sieger66 wäre noch wichtig, dann können wir calabi78 vielleicht noch helfen, wie sie die Subdomain einrichtet.