PHP Fehler - Joomla gehostet bei 1und1

  • Hallo liebes Forum,

    ich bin ganz neu (falls Information oder bestimmte Foren Regeln fehlen, dann bitte Rückmeldung). Folgende Situation:

    Ich habe von einem Web-Entwickler ein fertiges Joomla Paket bekommen. Dieses Paket habe ich im Anschluss bei 1und1 (dort ist die Domain gemietet) in den Webspace geladen

    und die configuration.php and die datenbank von 1und1 angepasst.

    Allerdings bekomme ich eine Fehlermeldung. Die Webseite mit der Fehlermeldung: https://www.counsel-group-greenville.com/

    Der 1und1 Support kann mich nicht helfen, da es selbstentwickelt ist und der Web-Entwickler stellt sich quer, da er ist bei sich gehostet haben möchte.


    Kennt jemand den Fehler? 1und1 meinte es könnte eventuell an der .htaccess liegen.



    Die .htaccess:







    Vielen Dank und Gruß

    Kevin

  • Dein Webserver parst das php nicht sondern liefert es an den Browser zurück. Ich kann mich dran errinern, dass wir das schon mal hier im Forum hatten... Ich weiß aber ehrlich gesagt nicht mehr wo und finde es auch nicht mehr.


    Also erstmal macht mich dieser Abschnitt in deiner .htaccess sehr stutzig:


    Code
    1. # php -- BEGIN cPanel-generated handler, do not edit
    2. # Set the “ea-php70” package as the default “PHP” programming language.
    3. <IfModule mime_module>
    4. AddHandler application/x-httpd-ea-php70 .php .php7 .phtml
    5. </IfModule>
    6. # php -- END cPanel-generated handler, do not edit

    Warum wird die PHP Version über die htaccess manipuliert, dass lässt sich bei 1und1/Ionos eigentlich anders einstellen. Das würde ich als erstes mal entfernen.


    Bzw. du kannst auch einfach erstmal die ganze htaccess deaktivieren indem du sie einfach mal umbenennst z.b. in htaccess.bak oder so. Vielleicht hilft das ja schon, dann weißt du ob es überhaupt an der htaccess liegt

  • Hallo eumel1602,


    vielen Dank für die schnelle Rückmeldung.

    Ich denke in meinem Post fehlen folgende Angabe:

    Gehostet bei: 1und1 Ionos.

    MySQL Version: 5.5

    PHP-Einstellung bei 1und1: 7.2

    Auf welcher Version Joomla läuft, kann ich nicht sagen, da ich nur das fertige Paket bekommen habe.


    Fehlt noch etwas?

  • Hallo Johannes,

    Bzw. du kannst auch einfach erstmal die ganze htaccess deaktivieren indem du sie einfach mal umbenennst z.b. in htaccess.bak oder so. Vielleicht hilft das ja schon, dann weißt du ob es überhaupt an der htaccess liegt

    Ich habe die htaccess deaktivert. Jetzt wird die Webseite zwar angezeigt, allerdings kommt bei den Unterseiten ein Error...

  • Weil du das Rewrite im Backend noch aktiv hast.


    Lad dir einfach mal die originale .htaccess von Joomla! hoch.


  • Ich habe die Orginale .htaccess hochgeladen, wenn ich dort keinen Fehler gemacht habe.


    Jetzt bekomme ich eine neue Fehlermeldung...


  • 1und1/Ionos ist etwas speziell mit dem mod_rewrite.


    Mein Vorschlag. Nimm die orginale .htaccess,die dir Haug IT-Solutions empfohlen hat mit der die Seite ging. Die Unterseiten werden nicht gehen, weil das mod_rewrite dazwischen funkt und das index.php falsch umleitet.


    Bei 1und1 musst du folgendes so haben:


    Code
    1. ## Mod_rewrite in use.
    2. RewriteEngine On


    Dort musst du also vorher die # rausnehmen und bei:


    Code
    1. RewriteBase /

    Muss auch vorher die # raus.


    Dann sollten auch die Unterseiten gehen. Mehr Hilfe gibt es hier.

  • Jop,

    aber ich denke, dann hat er in dem Moment entweder die .htaccess nicht gespeichert gehabt oder was anderes noch nicht auskommentiert gehabt oder wie auch immer. Habe leider auch eine Seite bei 1und1/Ionos und habe es gerade mit der Standard htaccess und den beiden Änderungen getestet - das läuft. Daher wenn es damit nicht klappt ist etwas anderes quer aber das kann ich mir bei dem Verhalten fast nicht vorstellen... Vor allem, weil die Unterseiten auch laufen, wenn ich ein index.php manuell einfüge...

  • Die genannten Tipps sind natürlich alle gleichzeitig auszuführen, also

    - original .htaccess verwenden

    - die # vor RewriteBase / entfernen

    - eine # vor Options +FollowSymlinks setzen

    - zu verwendende PHP-Version (typischerweise PHP 7.2) über 1&1 einstellen, weitere PHP-Versionseinstellungen in der .htaccess dann unterlassen

    - in der Backend-Konfiguration bei SEO die ersten beiden Haken setzen, eventuell auch Dateiendung (falls gewollt)


    Wenn man nur 1 Einstellung wieder rückgängig macht, die nicht fruchtet, dann nützen die anderen Änderungen danach auch nichts mehr.


    Alternativ: Ohne .htaccess arbeiten und dann aber den zweiten Haken in der SEO-Konfiguration entfernen! Sonst werden die Unterseiten nicht angezeigt (Es wird von einem Apache-Server ausgegangen).


    Schlussendlich könntest du, wenn alles läuft, die ein oder andere Einstellung aus der .htaccess deines Webdesigners übernehmen.

    Allerdings: Diese 302-Weiterleitung auf http macht aber irgendwie keinen Sinn, da du ja https verwendest.

  • Die Seite läuft, allerdings ist die Navigation noch fehlerhaft ... die SEO Einstellungen passen noch nicht:

    Im Menü ist der erste Punkt
    https://www.counsel-group-gree…lifecycle-management.html

    läuft aber auf einen 404-Error (Seite nicht gefunden), ändert man den Link zu:

    https://www.counsel-group-gree…prise-security-management

    kann man die Unterseite aufrufen. Leider habe ich gerade nicht auf dem Schirm welchen Änderungen man vornehmen muss. pardon Vielleicht nimmst du erst die Einstellungen von JoomlaWunder vor und testest dann nochmal.