Probleme mit localhost bei Neustart des PCs

  • Hallo,

    ich bin dabei, die Homepage einer Schule in Joomla neu zu gestalten. Das möchte ich zunächst erstmal auf meinem PC ausprobieren und habe deshalb xampp installiert, dann Joomla usw. Das Ganze funktioniert gut, ich komme über localhost auf die Joomla Seite.

    Wenn ich allerdings den PC ausschalte und wieder starte, bekomme ich folgende Fehlermeldung, wenn ich localhost eingebe:

    Warning: session_start(): Failed to read session data: user (path: E:\xampp\tmp) in E:\xampp\htdocs\libraries\joomla\session\handler\native.php on line 260


    Error: Failed to start application: Failed to start the session


    Ich habe das Ganze nochmal deinstalliert, wieder alles neu gemacht, dann klappt es wieder, aber nach einem Neustart wieder nicht. Leider stehe ich auf dem Schlauch und hoffe auf eure erfahrene Hilfe. Vielen Dank.

    Tinabel


  • Tinabel Welches
    Betriebssyste hast du auf deinem PC, welche Version?
    Welche Ausstattung hast du?
    Welche xampp Version und in welchem Verzeichnis / auf welchem Laufwerk hast du xampp?

    Was läuft sonst dauerhaft?


    Eine Lösung weiss ich jetzt nicht, aber ich habe manchmal auch den Effekt, dass sich nach einem Neustart des PC mysql aus ungeklärter Ursache mal verabschiedet so dass ich mysql neu starten muss. Ich nehme an, dass sich dann zwei Prozesse um einen Port streiten .. ich habe skype im Verdacht. Aber auf diesem Gebiet habe ich keine Ahnung, das ist nur geraten.

    JoomlaWunder bei mir dauert das starten nur einen Augenblick

  • XAMPP muss nicht in C:, sondern kann z.B. auch auf G: und unter einem modifizierten Namen des Install-Directories (z.B. xampp_20190723) installiert werden. Wichtig dabei ist, dass nach der Installation (ich bevorzuge ein .zip-xampp) die Datei setup_xampp.bat im XAMPP-Install-Directory ausgeführt wird. Dadurch werden die oben erwähnten Pfadanpassungen vorgenommen. That's it.

    Adminrechte werden empfohlen, ja, sind aber nach meinen Erfahrungen mit den .zip nicht erforderlich.

    Außerdem hat die .zip-Variante den Vorteil, dass keine Einträge in der Registry vorgenommen werden.


    Habe das mittlerweile mehrfach ohne jedes Problem durchgeführt (Win 7 Pro, Win 10 Pro).

  • Gemäß Fehlermeldung befindet sich Xampp ganz oben auf "E:" .


    Als ich Xampp 7.3 die ersten Male startete, ging das auch sehr schnell. Seit dem 4 oder 5 Start läuft es nur noch langsam, und das auf mehreren Rechnern. Vielleicht sollte ich auch noch mal die Port-Problematik überprüfen. Glücklicherweise nutze ich Xampp nicht so häufig, da ich Testversion lieber direkt beim Hoster anlege.

  • Xampp ganz oben auf "E:" .

    Ja, habe ich auch gesehen, daher meine Nachfrage nach der Art der Installation.


    Ich nutze seit ca. 3 Jahren xampp (verschiedene Versionen, abhängig von der includierten PHP-Version) und habe keine Veränderung der Startzeit feststellen müssen. Auch an den Ports musste ich keine Änderungen vornehmen (hängt aber mit den installierten Progs zusammen). Nur die erste Version hatte ich als .exe installiert, alle anderen danach nur noch als .zip auf einer separaten Platte (nicht C:).

  • Vielen Dank für die schnellen Antworten. Ich würde das auch lieber direkt bei dem Hoster machen, da liegt aber momentan die alte Homepage, die weiterhin verfügbar sein muss. Und deshalb wollte ich es lokal ausprobieren.


    Zuerst einmal nutze ich Windows 10 Home Version 1803

    Ich habe jetzt nochmal alles neu gemacht: Xampp in C:\ installiert. Das Xampp Control-Panel kann ich nur über den Explorer aufrufen, da ich keinen Eintrag bei den Apps habe. Soweit so gut.

    Ich starte Apache und My SQL und alles läuft.

    Ich lege über phpMyAdmin eine neue Datenbank an.

    Dann entpacke ich die neueste Joomla Version in c:\xampp\htdocs\ und installiere es.

    Über localhost kann ich auf die Startseite zugreifen und alles scheint zu funktionieren.


    Ich starte den PC neu, rufe als Administrator das Xampp Control-Panel auf. Apache startet und bei My Sql bekomme ich wieder eine Fehlermeldung:

    Versuche MySQL zu starten...

    12:38:16 [mysql] Statusänderung erkannt: gestartet

    12:38:16 [mysql] Statusänderung erkannt: gestoppt

    12:38:16 [mysql] Fehler: MySQL wurde unerwartet beendet

    12:38:16 [mysql] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,

    12:38:16 [mysql] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.

    12:38:16 [mysql] Drücke den Logs Button um error logs zu sehen und prüfe

    12:38:16 [mysql] im Windows Event Viewer für weitere Hinweise

    12:38:16 [mysql] Wenn du weitere Hilfe benötigst, kopiere den kompletten Inhalt des Log Fensters

    12:38:16 [mysql] und füge ihn als Ergänzung in einem neuen Forum Eintrag hinzu.


    Dazu noch der Inhalt der Log Datei:

    2019-07-24 12:04:31 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions

    2019-07-24 12:04:31 0 [Note] InnoDB: Uses event mutexes

    2019-07-24 12:04:31 0 [Note] InnoDB: Compressed tables use zlib 1.2.11

    2019-07-24 12:04:31 0 [Note] InnoDB: Number of pools: 1

    2019-07-24 12:04:31 0 [Note] InnoDB: Using SSE2 crc32 instructions

    2019-07-24 12:04:31 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M

    2019-07-24 12:04:31 0 [Note] InnoDB: Completed initialization of buffer pool

    2019-07-24 12:04:31 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=1791378

    2019-07-24 12:04:31 0 [Note] InnoDB: 128 out of 128 rollback segments are active.

    2019-07-24 12:04:31 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"

    2019-07-24 12:04:31 0 [Note] InnoDB: Creating shared tablespace for temporary tables

    2019-07-24 12:04:31 0 [Note] InnoDB: Setting file 'C:\xampp\mysql\data\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...

    2019-07-24 12:04:31 0 [Note] InnoDB: File 'C:\xampp\mysql\data\ibtmp1' size is now 12 MB.

    2019-07-24 12:04:32 0 [Note] InnoDB: Waiting for purge to start

    2019-07-24 12:04:32 0 [Note] InnoDB: 10.3.16 started; log sequence number 1791387; transaction id 163

    2019-07-24 12:04:32 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool

    2019-07-24 12:04:32 0 [Note] InnoDB: Buffer pool(s) load completed at 190724 12:04:32

    2019-07-24 12:04:32 0 [Note] Plugin 'FEEDBACK' is disabled.

    2019-07-24 12:04:32 0 [Note] Server socket created on IP: '::'.


    Vielleicht hilft das ja noch ein kleines Stück weiter. Vielen Dank.

  • Hast Du als Administrator xampp und jommla installiert und direkt nach der Installation (vor dem Neustart des Rechners) das control-Panel gestartet (also auch mit den Admin-Rechten)?

    Mit welchen Rechten rufst Du nach dem Neustart Joomla auf ("normaler Nutzer" oder Admin)?


    Versuche mal nach einem Neustart als "normaler Nutzer" das control-Panel und Joomla zu starten.

  • Gibt es auch log-Einträge von dem Zeitpunkt

    Die beigefügten Logeinträge sind zu diesem Zeitpunkt 34 Min alt.

    Ja, die gibt es:


    2019-07-24 12:38:16 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions

    2019-07-24 12:38:16 0 [Note] InnoDB: Uses event mutexes

    2019-07-24 12:38:16 0 [Note] InnoDB: Compressed tables use zlib 1.2.11

    2019-07-24 12:38:16 0 [Note] InnoDB: Number of pools: 1

    2019-07-24 12:38:16 0 [Note] InnoDB: Using SSE2 crc32 instructions

    2019-07-24 12:38:16 0 [Note] InnoDB: Initializing buffer pool, total size = 16M, instances = 1, chunk size = 16M

    2019-07-24 12:38:16 0 [Note] InnoDB: Completed initialization of buffer pool

    2019-07-24 12:38:16 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=4296578

    2019-07-24 12:38:16 0 [Note] InnoDB: 128 out of 128 rollback segments are active.

    2019-07-24 12:38:16 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"

    2019-07-24 12:38:16 0 [Note] InnoDB: Creating shared tablespace for temporary tables

    2019-07-24 12:38:16 0 [Note] InnoDB: Setting file 'C:\xampp\mysql\data\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...

    2019-07-24 12:38:16 0 [Note] InnoDB: File 'C:\xampp\mysql\data\ibtmp1' size is now 12 MB.

    2019-07-24 12:38:16 0 [Note] InnoDB: 10.3.16 started; log sequence number 4296587; transaction id 2251

    2019-07-24 12:38:16 0 [Note] InnoDB: Loading buffer pool(s) from C:\xampp\mysql\data\ib_buffer_pool

    2019-07-24 12:38:16 0 [Note] InnoDB: Buffer pool(s) load completed at 190724 12:38:16

    2019-07-24 12:38:16 0 [Note] Plugin 'FEEDBACK' is disabled.

    2019-07-24 12:38:16 0 [Note] Server socket created on IP: '::'.

  • E:\xampp\htdocs\libraries\joomla\session\handler\native.php

    Dies ist die Pfadangabe in Deinem 1. Beitrag. Wie sieht dieser Pfad nach der Neuinstallation in C: aus? Wenn bis auf das LW identisch, dann habe ich Zweifel, ob Joomla richtig installiert wurde.

    Bei mir sieht der Pfad so aus: G:\xampp\htdocs\hp_joomla1\libraries\joomla\session


    In htdocs liegen bei mir parallel mehrere Jommlainstallationen aber kein libraries Folder. Kann es sein, dass Du Joomla direkt in htdocs installiert hast?


    Zur Sicherheit, welche XAMPP-Version aus welcher Quelle nutzt Du?


    Zu den Logeinträgen würde mich interessieren, wie die nächsten beiden Einträge nach diesem

    2019-07-24 12:38:16 0 [Note] Server socket created on IP: '::'.

    aussehen.


    Bei mir folgt nach dieser Zeile:

    2019-07-23 10:06:43 6916 [Note] g:\xampp\mysql\bin\mysqld.exe: ready for connections.


    Bei der Installation von Joomla müssen auch Einträge in der Windows-Firewall vorgenommen werden. Wurden die während der installation von Joomla angefordert?


    Hast Du als Administrator xampp und jommla installiert und direkt nach der Installation (vor dem Neustart des Rechners) das control-Panel gestartet (also auch mit den Admin-Rechten)?

    Mit welchen Rechten rufst Du nach dem Neustart Joomla auf ("normaler Nutzer" oder Admin)?


    Versuche mal nach einem Neustart als "normaler Nutzer" das control-Panel und Joomla zu starten.

    Hast Du dies mal getetstet?


    Xampp Control-Panel kann ich nur über den Explorer aufrufen

    Du kannst das Control-Panel auch an die Taskleiste anheften, dann geht der Start mit einem Klick.

  • Vielleicht hilft das ja noch ein kleines Stück weiter.

    Hier war es ein anderes Programm, welches einen Port blockiert.

    Deshalb die direktre Frage: Läuft bei Dir Skype im Hintergrund. Wenn ja, schließen.

    ----

    Anderfalls liebe Kollegin (?): Probiere >> Uwamp

    ------------------------------------------------------------
    Gruß vom Jörg
    (Lehrer ist kein Beruf sondern eine Diagnose. oops )

  • hechtnetz das mit skype hatte ich auch im Verdacht aber es geht nicht an, skype zu schliessen bevor man xampp startet.

    Dann könnte ich ja meinen Laden zu machen!


    Bei mir wird xampp jetzt automatisch gestartet und zwar mit folgenden Einstellungen:

    Damit habe ich das Problem nicht mehr.



    Uwamp müsste ich auch mal ausprobieren ...