HikaShop Module auf der Startseite --> Fehlermeldung

  • Hallo zusammen,


    seit vielen Jahren administriere ich die Seite http://www.blaeserforum.com und konnte bisher alle auftretenden Probleme selbst beheben. Aktuell stehe ich aber auf dem Schlauch und komme ohne Hilfe nicht weiter.


    Zunächst die wichtigsten Infos:

    Joomla 3.9.10, PHP 7.2.20, Hikashop 4.2.1, Gantry 4.1.41

    Template: Plethora von RocketTheme


    Das Problem ist folgendes: Auf der Startseite sind diverse HikaShop Module (HikaShop Content Module) eingebunden, die auf unterschiedliche Produkte im Katalog verweisen. Klickt man auf eines dieser Produkte bekommt man folgende Fehlermeldung:


    Fatal error: require_once(): Failed opening required '/homepages/3/d205006342/htdocs/bfk2014/libraries/joomla/document/html/renderer/head.php' (include_path='.:/usr/lib/php7.2') in /homepages/3/d205006342/htdocs/bfk2014/templates/rt_plethora/error.php on line 134


    Das ist gar nicht schön, zumal ein gleiches Modul an einer anderen Stelle problemlos funktioniert. Als Beispiel nehme ich das Modul auf der Startseite "Unsere Gebrauchten - Immer einen Blick wert!" (Ganz unten auf der Seite) Klicke ich hier auf eines der Produkte, erhalte ich den o. a. Fehler. Das gleiche Modul habe ich u. a. auch hier eingebunden: https://blaeserforum.com/index…ote/category/69-trompeten (auch hier ganz nach unten scrollen). Klicke ich hier auf eines der Produkte funktioniert alles einwandfrei.


    Ich wäre unglaublich dankbar, wenn ihr einen Tipp für mich hättet, wie ich dieses Problem beheben kann.


    Mit bestem Dank,


    Andreas


  • Es handelt sich um einen Fehler in der Datei templates/rt_plethora/error.php deines Templates, das offensichtlich nicht mehr das frischeste ist. Bennene diese error.php um, damit sie deaktiviert ist und die von Joomla genommen wird. Dann solltest du die eigentliche Fehlermeldung sehen.


    Mit dem Modul hat das höchstwahrscheinlich gar nichts zu tun.

  • Gesagt, getan,


    jetzt bekomme ich einen Kasten mit den folgenden Infos:


    0 - Call to a member function get() on null


    Die Seite kann nicht angezeigt werden, weil:

    1. Sie ein veraltetes Lesezeichen aufgerufen haben.
    2. Sie über eine Suchmaschine einen veralteten Index dieser Website aufgerufen haben.
    3. Sie eine falsche Adresse aufgerufen haben.
    4. Sie keinen Zugriff auf diese Seite haben.
    5. Die angefragte Quelle wurde nicht gefunden!
    6. Während der Anfrage ist ein Fehler aufgetreten!

    Bitte eine der folgenden Seiten ausprobieren:

    Irgendwie hilft mir das nicht wirklich weiter.

  • Danke für den Hinweis, das habe ich jetzt auch getan und bekomme folgendes wenn ich einen Artikel im Modul anklicke:


    Call to a member function get() on null

    /homepages/3/d205006342/htdocs/bfk2014/components/com_hikashop/views/product/view.html.php:131


    Call stack
    # Function Location
    1 () JROOT/components/com_hikashop/views/product/view.html.php:131
    2 ProductViewProduct->listing() JROOT/components/com_hikashop/views/product/view.html.php:28
    3 ProductViewProduct->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:657
    4 hikashop_getLayout() JROOT/modules/mod_hikashop/mod_hikashop.php:73
    5 include() JROOT/libraries/src/Helper/ModuleHelper.php:200
    6 Joomla\CMS\Helper\ModuleHelper::renderModule() JROOT/components/com_hikashop/views/product/tmpl/show.php:391
    7 include() JROOT/libraries/src/MVC/View/HtmlView.php:697
    8 Joomla\CMS\MVC\View\HtmlView->loadTemplate() JROOT/administrator/components/com_hikashop/helpers/helper.php:2127
    9 hikashopView->loadTemplate() JROOT/libraries/src/MVC/View/HtmlView.php:230
    10 Joomla\CMS\MVC\View\HtmlView->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:2110
    11 hikashopView->display() JROOT/components/com_hikashop/views/product/view.html.php:29
    12 ProductViewProduct->display() JROOT/libraries/src/MVC/Controller/BaseController.php:672
    13 Joomla\CMS\MVC\Controller\BaseController->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:1848
    14 hikashopController->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:1616
    15 hikashopController->show() JROOT/libraries/src/MVC/Controller/BaseController.php:710
    16 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/administrator/components/com_hikashop/helpers/helper.php:1826
    17 hikashopController->execute() JROOT/components/com_hikashop/hikashop.php:92
    18 require_once() JROOT/libraries/src/Component/ComponentHelper.php:402
    19 Joomla\CMS\Component\ComponentHelper::executeComponent() JROOT/libraries/src/Component/ComponentHelper.php:377
    20 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/SiteApplication.php:194
    21 Joomla\CMS\Application\SiteApplication->dispatch() JROOT/libraries/src/Application/SiteApplication.php:233
    22 Joomla\CMS\Application\SiteApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:196
    23 Joomla\CMS\Application\CMSApplication->execute() JROOT/index.php:49

    Vielleicht könnt ihr damit ja etwas anfangen.

  • Hikashop 4.2.1

    Wenn ich in dem Paket (das Starter von Herstellerseite) nach

    /components/com_hikashop/views/product/view.html.php

    Zeile 131 schaue, dann gibt es da nichts, was die Fehlermeldung

    Call to a member function get() on null

    werfen könnte.


    Und auch die

    ProductViewProduct->listing()
    JROOT/components/com_hikashop/views/product/view.html.php:28

    stimmt nicht überein.


    Wenn du eine PRO-Version verwendest, wirst wohl die Hersteller fragen müssen.