Beiträge von Thomas Vitt
-
-
-
-
Hallo,
beim automatischen Update von 6.0.3 auf 6.0.4 wurde meine angepaßte index.php im Child-Template von Cassiopeia durch eine (alte) index.php (die gleiche wie im Original) überschrieben.
Nach meinem Verständnis werden doch Änderungen bei Updates nur im Haupt-Template durchgeführt und die Änderungen im Child-Template bleiben davon unberührt. Auch die component.php, error.php und offline.php wurden überschrieben.
Wer kann mir den Hintergrund dazu erklären.
Durch eine Rücksicherung der angepaßten index.php ist das Problem bereits beseitigt, mich interessiert warum das überhaupt passiert ist. -
Vielen Dank für die schnellen Antworten.
Läuft in dem neuen Unterverzeichnis womöglich eine andere PHP-Version oder sind bestimmte Servereinstellungen dort anders?
das wars. Die Domain läuft unter 7.4 die Subdomain war auf 8.1 eingestellt.
Vielen Dank, jetzt kann ich weitermachen
-
Hallo,
ich möchte jetzt auch endlich meine Homepage auf Joomla 4# umstellen und habe dazu eine zweite Instanz in einer Subdomain erstellt.Template: Allrounder-3 Version 1.1
1. neues Verzeichnis joomla4 unter .../html/
2. komplettes Verzeichnis joomla3, ohne configuration.php und hctaccess.txt in joomla4 kopiert
3. configuration.php mit neuem DB-Namen, User, Passwort und neuem Pfad für log und tmp ins Verzeichnis kopiert
4. mit PHPMyAdmin DB Exportiert und in DB der Subdomain importiert
Zugriff auf Backend ist möglich, Zugriff auf Frontend nicht (weiße Seite ohne Meldung)
Debug-Modus auf Maximum eingerstellt. Fehlermeldung (neben ein paar Deprecated Meldungen):
Warning: session_name(): Session name cannot be changed after headers have already been sent in ...html/joomla4/libraries/joomla/session/handler/native.php on line 128Warning: session_cache_limiter(): Session cache limiter cannot be changed after headers have already been sent in .../html/joomla4/libraries/joomla/session/handler/native.php on line 235
Error: Failed to start application: Failed to start the session because headers have already been sent by ".../html/joomla4/libraries/vendor/joomla/input/src/Input.php" at line 41.
Damit auch kein Zugriff aufs Backend mehr möglich.
Kann ich den Debug-Modus auch ohne Backend wieder ausstellen?
Was muss ich tun, um auch auf das Frontend zugreifen zu können.