Beiträge von Rabendoktor

    Die Extension, die Tom in dem von Re:Later empfohlenen thread erwähnt (ganz unten...) (https://www.r2h.nl/joomla-extensions/imagemanager) ist auch in der Free-Version für meinen Zweck sehr hilfreich gewesen.


    Sie funktioniert aber nicht vollständig zuverlässig: einige definitiv verwendete Bilder werden nicht als "verwendet" erkannt, verschiebt man diese dann mit der Extension, funzt die Link-Anpassung nicht. Also: Ergebnis kontrollieren.... ;-)


    Aber mit etwa 95% Trefferquote auch in der kostenlosen Version sehr hilfreich...


    DANKE an Alle für's Mitdenken...


    Schönes Wochenende,


    Stefefn

    Servus,


    auf einer meiner Joomla-Seiten hat die Menge der unter /images abgelegten, verlinkten Bilder überhand genommen, ich möchte diese umstrukturieren durch das Anlegen von Unterordnern unter /images. "Leider" besteht die Seite aus einer großen Zahl an einzelnen Seiten.


    Mir ist natürlich klar, dass ich dann auch den jeweiligen link auf den jeweiligen Seiten ändern muss - da liegt das Problem...


    Gibt es eine Möglichkeit, dass ich mir ausgehend vom einzelnen Bild anzeigen lasse, auf welchen Seiten die Graphik verwendet wird, sprich: ich den jeweiligen link verändern muss?


    Danke für Eure Hilfe,

    herzlich,


    Steffen

    Außer das modifizierte Template ist schon sehr viel älter, wo das noch nicht drin war. Heute sieht die Zeile so aus:

    DAS war es - ich habe jetzt einfach aus einer J3.8.8 Original-Installation die index.php in mein template kopiert - plötzlich funzt es zumindest ansatzweise...


    DANKE wieder einmal allen, die mitgedacht haben!


    Sonnige Grüße vom Ammersee,


    Steffen

    Hallo, Ihr Drei - vielen Dank für Eure raschen Antworten!


    time4mambo : ich hatte es auch so verstanden, dass Protostar die user.css automatisch NACH der template.css lädt - meine Änderungen sind zu viele, um sie einzeln mit !important zu kennzeichnen

    @ghsvs: Wo genau fände ich diese Zeile? in der index.php des templates finde ich sie grad nicht... - am cache kann es nicht liegen, das Problem ist in allen browsern reproduzierbar, auch nach löschen des cache

    KarEm : meine template.css hat 604, aber auch, wenn ich die user.css auf 644 setze, ändert sich nix...


    DANKE schon bis jetzt,

    herzliche Grüße,


    Steffen

    Ich traue mich ja fast schon nicht mehr, aber:


    Ich habe mit meinem Texteditor mein bislang verwendetes, modifiziertes Protostar template.css verglichen mit einem frisch heruntergeladenen Protostar-template.css und alle von mir modifizierten Anteile in eine user.css-Datei kopiert, die ich im selben Ordner abgelegt habe, wie die template.css (CHMOD 604).


    Solange ich jetzt die alte template.css nutze, sieht alles prima aus - wenn ich jetzt aber (und so war der Plan) diese umbenenne oder aus dem css-Ordner rausnehme und die Original-Protostar-template.css in den css-Ordner zu der user.css kopiere... wird die user.css völlig ignoriert. Das sehe ich daran, dass sich das Aussehen der Seite in keiner Art und Weise ändert, wenn ich dann die user.css umbenenne oder aus dem Ordner rausnehme.


    Woran kann das liegen?


    DANKE,

    herzlich,


    Steffen


    PS: http://www.impf-info.de

    Entschuldigt, dass ich mich einschalte, aber:


    warum sollen Google-Fonts nicht DSGVO-konform sein? IMHO musst Du lediglich in Deiner DSE darauf hinweisen, DASS Du Google-Fonts verwendest... . Fertich...


    Dass Deine website so aussieht, wie Du es Dir vorstellst ist ja primär erst einmal ein "berechtigtes Interesse" im Sinne der DSGVO.


    Herzlich,


    Steffen

    Danke Dir, Tom -


    ich habe aus der Episode gelernt, dass ich meine beiden Seiten auf die Original template.css-Datei umstellen werde und die von mir vorgenommenen Änderungen in eine user.css ausgliedere.


    Die erstelle ich mir aus den mit Deinen Software-Tips identifizierten Änderungen in meiner jetzigen template.css.


    Wieder einmal: Joomla ist nicht nur ein, nein, DAS Super-CMS, sondern speziell diese Community ist das Beste, was einem Möchte-gern-webdesigner wie mir passieren kann... DANKE, DANKE, DANKE!


    Schönen Tag allen Mitlesern,

    herzlich,


    Steffen

    Viel schlimmer - es fehlte nicht, es fehlte nur das Komma hinter dem 2. .nav-child.... Wie gut, dass es hier kein facepalm-emoji gibt.


    Anka, ich danke Dir, jetzt ist alles so, wie ich mir das vorstelle!


    Gibt es eine Möglichkeit, 2 CSS-Dateien schnell und übersichtlich zu vergleichen (idealerweise für Mac)?


    In jedem Fall einen schönen Abend für Dich,

    herzliche Grüße, (auch nochmal an die anderen 3 Mit-Helfer),


    Steffen

    DANKE, anka!


    - ich bin erschüttert und weiß nicht, wie das passieren konnte - die waren tatsächlich weg... ich habe jetzt alle .nav li li -CSS-Zeilen rüberkopiert (hat auch funktioniert, ich musst die Farbe wieder von blau auf grün umstellen), aber das Problem mit der fehlenden dritten Ebene ist leider geblieben...


    Ich muss mich korrigieren - die 3. Ebene erscheint jetzt!, aber erst, nachdem ich auf die 2. geklickt habe... wie kann ich es einstellen, dass die schon beim hovern auftaucht?

    Hallo, Christiane,


    DANKE für die vorsichtige Nachfrage - ja, alles ist public...


    GANZ glücklich bin ich damit auch nicht, aber die Alternative wären halt mehr Menü-Überschriften, die dann nicht mehr horizontal darstellbar sind... ich brüte da noch drüber, aber das mit der 3. Ebene verstehe ich trotzdem nicht.


    Indigo66 : ist ja wenn dann mein Fehler: mit der Überschrift ist es dann ja die 3. Ebene...


    Herzliche Grüße Euch Mitdenkern und Helfern,


    Steffen

    Das verstehe ich nicht - unter macOS 10.13 (der Mauszeiger fehlt natürlich, den brauche ich für's Bildschirmfoto):


    Firefox:



    Safari:



    Ich würde doch jetzt erwarten, das rechts neben "Die Impfaufklärung" auftaucht "Juristisches" und "STIKO", oder?


    Woran kann das liegen?

    Hallo,


    derzeit "relaunche" ich meine impf-info.de - Seite und scheitere gerade an der Menüstruktur. Ich habe per nav-pills das Hauptmenü auf horziontal gestellt und dessen Aussehen angepasst, allerdings haben einige Menüpunkte noch Untermenüpunkte, die mir das template bis jetzt vorenthält.


    So müssten bei "Die Impfentscheidung"/"Impfaufklärung" eigentlich noch die Unterpunkte "Juristisches" und "STIKO" auftauchen (idealerweise im gleichen design nach rechts verschoben) - das tun sie aber nicht... warum nicht?




    DANKE für Eure Hilfe,

    herzliche Grüße,


    Steffen

    Guten Morgen, Christiane,


    nein, das war wirklich Kurzfassung im Panikmodus - die Datei heisst natürlich configuration.php... ABER: ich habe nach dieser unglücklich Aktion (Nochmal Fehler 500 - NICHT bei Strato... )tatsächlich das Problem, dass ich auf der wiederhergestellten Seite jedesmal beim Speichern der veränderten configuration.php (Cyberduck, Bearbeitung mit Smultron 4) eine Fehlermeldung bekomme "Permission denied". Berechtigungen sind 444, das ist aber bei meinen anderen joomla-sites auch so...


    Ich kann das dann zwar durch vorübergehendes Ändern der Berechtigungen lösen, es nervt aber und ich verstehe es nicht - wo liegt der Haken?


    DANKE für Eure Hilfe,

    herzlich,


    Steffen