Beiträge von tru_visual

    Hallo Re:Later,
    vielen Dank für deinen Code, leider wird kein span tag hinzugefügt.... leider...
    im Inspector von firefox zeigt er mir das Menü genauso an wie vorher...

    Code
    1. <ul class="nav navbar-nav">
    2. <li class="item-101 current active"><a href="/index.php">Start</a></li>
    3. <li class="item-105"><a href="/index.php/login">LogIn</a></li>
    4. <li class="item-104"><a href="/index.php/lebenslauf">Lebenslauf</a></li>
    5. <li class="item-102"><a href="/index.php/kontakt">Kontakt</a></li>
    6. <li class="item-103"><a href="/index.php/impressum">Impressum</a></li>
    7. </ul>


    Hast Du, oder Ihr, vielleicht noch eine andere Idee?

    Hallo Re:Later,


    vielen Dank für deinen Tipp.
    die default_component.php habe ich mir auch schon angeschaut.
    Darmals ging es mit der default_url.php.


    Die neue default_url.php dieht anders aus, und ich kann da kein span tag rein machen, jedenfalls wüsste ich nicht wie.
    Hier die neue default_url.php, vielleicht wisst ihr ja wie?! (ein span tag ist da ja schon, aber ich möchte ja gern ein separates span ansprechen, immer das, was bei einem h:over a tag ist.

    Hallo ihr da draussen,


    folgendes, ich möchte unter Joomla 3 gerne wieder ein span Tag den Menüeintragen ( a Tags) anhängen.


    Vorher ging das in dem man bei ../modules/mod_menu/tmp/default_url.php folgenden Code einfügte:

    PHP
    1. ?><a <?php echo $class; ?>href="<?php echo $item->flink; ?>" <?php echo $title; ?>><span><?php echo $linktype; ?></span></a><?php


    Leider hat sich das bei Joomla 3 wohl geändert...


    Hat jemand eine Idee?


    Lieben Gruß,
    tru

    Hallo deGobbis,


    vielen Dank für deinen Link.


    Ich möchte gern ei dem Code leien, den ich jetzt habe, da alles soweit funktioniert, bis auf das einlenden des Untermenüs.


    Und ich denke, es ist einfach nur ein Syntaxfehler, das ich das untergeordnete ul nicht richtig anspreche.
    Das auslenden klappt ja, nur das einlenden eim hover will noch nicht...


    Hier sonst noch mal ein Ausschnitt aus der HTML:

    Code
    1. <div id="header"><div class="main"><div class="moduletable"><ul id="nav-menu" class="nav menu"><li class="item-101 current active"><a href="/"></li><li class="item-113 deeper parent"><a href="/index.php/agb-blw">Test<span></span></a><ul class="nav-child unstyled small"><li class="item-124"></ul></li><li class="item-114"><li class="item-122"></ul></div></div>


    Im CSS Teil habe ich das Untermenü so ausblenden können:

    Code
    1. ul#nav-menu .nav-child.unstyled.small { background-image: url(../images/sidebar-bgd.png); position:absolute; display:none; float:left; clear:both; width:100px; height:30px; margin:35px 0px 0px 60px; z-index:1;}


    Und den hover einblend Effekt versuche ich so:

    Code
    1. ul#nav-menu .nav-child.unstyled.small li:hover { background-image: url(../images/sidebar-bgd.png); position:absolute; display:block; float:left; clear:both; width:100px; height:30px; margin:35px 0px 0px 60px; z-index:1;}


    Habe alles mögliche probiert,

    Code
    1. ul#nav-menu .nav-child.unstyled.small li:hover ul
    2. ul#nav-menu li:hover ul
    3. #nav-menu ul ul li:hover


    Und so weiter... ist eher ein raten...


    Desshalb hilft mir ein Tutorial nicht viel, da ich die Regel der hierarchie nicht verstehe, hab ein Nachschlagebuch, geht da auch nicht draus hervor...


    Für weitere Hilfe wäre ich sehr Dankbar


    Gruß,
    tru

    Hallo zusammen,


    ich habe es nun mit dem "Laser" Effekt hinbekommen. Vielen Dank nochmal.


    Habe aber ein Problem mit dem Submenü.
    Wenn ich im Modul die Angabe Untermenüeinträge anzeigen auf Nein setze, dann werden mir die anderen Menüpunkte´, in der ersten Ebene, angezeigt.


    Wenn ich auf einen Menüpunkt klick, der ein Untermenü hat, dann verschwinden die anderen nachfolgenden Menüpunkte, in der ersten Ebene.
    Und die Untermenüpunkte werden auch nicht dargestellt.


    Wenn ich im Modul die Angabe Untermenüeinträge anzeigen auf Ja setze, dann sien die nachfolgenden Menüpunkte, erste Ebene, weg.


    Mein Ansatz war erst, die Untermenüpunkte mit CSS zu formatieren.
    Aber, der Fehler ist erstmal bei dem Listeneintrag li, welches das Untermenü hat.


    Das li nimmt die Größe des untergeordneten ul s an...?
    Desshalb wollte ich das li (mit Submenü), seperat formatieren.


    Z.B. so:

    Code
    1. ul#nav-menu li.item-113.deeper.parent {
    2. width:100px;
    3. margin:0;
    4. }


    Ich weiß nicht weiter...


    Habt Ihr eine Idee?
    Hier der Link zur Seite:http://www.blw-24.dehttp://www.blw-24.de
    Gruß,
    tru

    Hallo Re:Later,


    vielen Dank für deine Aufmerksamkeit.


    Was ich meine ist, das rot markierte... das wird einfach hinzugefügt... soll aber weg:
    <li class="item-113">
    <a a="" agb<="" href="/index.php/agb-blw">
    <span></span>
    </a>
    </li>


    Und, diese Link gehören auch nicht darein:
    <a a="" video<="" href="/index.php/video00">
    </a>
    </div>
    <a a="" video<="" href="/index.php/video00">
    </a>
    </nav>
    <a a="" video<="" href="/index.php/video00"> </a>
    </div>


    Kannst Du mir sagen, bzw. erklären, wie ich das Grundgerüst aufbauen muss?
    Ich habe zwei Dateien modifiziert, einmal die default_component.php,
    und einmal die default_url.php.


    So das immer ein span tag zu den Link angehängt wird.
    So soll das im original Code funktionieren (das dieser laser Effekt passiert)


    Meine Frage ist eigentlich die, welche Basis Angaben muss ich eigentlich machen?
    1. Das Menü ansprechen: z.B. .nav-menu etc.
    2. a
    3. ul und li
    4.a:hover ( a:hover span etc)
    Habe aber auch gesehen, das es li:hover gibt.
    wo kommt das denn zum Einsatz?


    Ich bräuchte wirklich eine kurze, prignante Erklärung... im Netz finde ich das so nicht, bzw. verstehe ich nicht.


    Wäre sehr erleichtert, wenn Du mir das erklären könntest, denke das man das Grundprinzip einfach nur verstehen muss, oder?


    LG
    tru

    Hallo allerseits...


    ich bin jetzt etwas weitergekommen...


    Habe aber noch ein "kleines" Problem.
    Diesen Laser Effekt habe ich jetzt einigermaßen... nur, die Menüpunkte werden nicht angezeigt.



    Firebug sagt mir:


    Ach ja... hab ich vergessen...
    ich habe ein mod override gemacht, damit hinter dem a tag ein span eingebaut ist, so soll das mit dem Laser funktionieren...
    default_component.php:


    Und default_url.php:


    Was habe ich falsch gemacht?

    Hallo alle zusammen,


    ich habe eine Seite gefunden, deren Hover effekt ich gerne mal ausprobieren würde.


    Ich habe mir das mal mit Firebug angeschaut, es scheint ein Javascript zu sein.


    Meine Frage: würde es nicht auch mit css (Transitions) gehen?


    Und, ich wollte mir das Script in Firebug anschauen, Firebug schreibt: bitte Seite aktualisiern um Code anzuzeigen...


    gesagt, getan... aber kein Code wird angezeigt...


    Kennt Ihr den Effekt? Wo könnte ich die Basics herbekommen, um es sauber einzubauen?


    Hier der Link zu der Seite: http://www.b-signs.de/


    Vielen Dank für hilfreiche Tipps von euch.


    Gruß,


    tru

    Hallo!
    Entschuldigt bitte meine späte Antwort!


    Ich habe die Lösung von Addi gewählt, die auch sofort funktioniert hat! Super!


    Aber, ich danke euch allen, für eure Hilfe! Danke! :-)


    P.s.: Wie ändere ich eigentlich meinen Mitgliedsnamen? tru_viual in tru_visual?

    Hallo Re:Later!


    Die Nutzungsbedingungen für das Menü sind mir klar...
    wenn ich es zum Einsatz bringen werde bzw. zum laufen bekomme, dann werde ich auch den Nutzungsbedingungen gerecht werden.


    Ich habe ein anderes Menü, welches ähnlich ist, auch unter Joomla zum laufen bekommen.


    Ich finde deinen Kommentar jetzt nicht gerade konstruktiv... soll keine Beleidigung sein.
    Ist nur mein Empfinden jetzt, da ich ein Problem habe, und eure Hilfe benötige.


    Gruß,
    tru

    Hallo Jacxx, Hallo Webworker,


    vielen Dank für eure Aufmerksamkeit.
    @ Webworker: Ich habe dies nur Lokal getestet, nicht im Internet.


    @ Jacxx: Hier ist der CSS Code:



    Ich danke euch nochmals für eure Hilfe!


    Tru


    --------------------------------------------------------------------------------------


    Entschuldige bitte aber ich musste den Code leider löschen wegen dem Urheberrecht.


    Gruß
    Spike69
    Admin

    Hallo liebe Joomla Gemeinde,


    ich habe vor, ein spezielles Menü in Joomla einzubauen,


    hier der Link dazu: http://www.cssplay.co.uk/menus/css3-cssplay3.html


    Ich habe versucht, dies o zu machen, klappt aber nicht... kann mir
    jemand sagen, was ich da falch mache, und wie ich es richtig machen
    muss?
    --------------------------------------------------------------------------------------


    Entschuldige bitte aber ich musste den Quellcode leider löschen wegen dem Urheberrecht.


    Gruß
    Spike69
    Admin