Beiträge von Antonella

    Hallo,
    ich baue an einem Seminarkalender. Dafür habe ich YOOTheme mit erweitertem Grid (Grid10) und dynamischem Content im Einsatz.

    Die Seminarinfos kommen aus Custom Fields.

    Nun würde ich gerne auch den Grid-Button dynamisch einfügen, damit er nur dann erscheint, wenn er gebraucht wird.

    Dafür habe ich ein Custom field angelegt, in das man den Artikel-Alias einfügt.

    Das Custom field wird im YOOtheme-Grid in das Link-Feld geladen. Vor dem Feldwert ergänzt YOOtheme den ersten Teil der Beitrags-URL.

    Soweit so gut, nur leider erscheint zusätzlich die Beitrags-ID in der URL, also z.B. /208-test-beitrag.

    Wie bekomme ich die ID aus der URL?

    Hat jemand einen Tipp?

    Danke und LG

    Antonella

    Antonella meld dich mal bei deinem Hoster. Die Fehlermeldung aus dem Screenshot ist die 500er Seite deines Hosters, nicht die von Joomla - damit kannst du das nicht sinnvoll debuggen

    Hab ich schon. Meine Frage richtete sich genau in diese Richtung - weil es keine übliche Joomla-Fehlerseite ist. Ich bekam eine für mich eher kryptische Antwort:

    Fällt dir da was zu ein?

    Die Acymailing-Tabellen sind aus der DB entfernt, debug-Modus und Fehler berichten sind aktiviert, die error.php im Template ist umbenannt.

    Also: Noch mal das Kompatibilitäts-Plugin deaktiviert - same situation: 500er Server-Fehlerseite ohne Error-Meldungen.

    Habt ihr dazu noch eine Idee?

    Was ist mit der FOF-Bibliothek, deren Kompatibilität mit J6 neben der des German Language Packs nicht erkannt wird. Kann das Problem damit zusammenhängen? Bei vielen anderen Seiten mit FOF ist das Systemupdate bisher problemlos durchgelaufen.

    Hat dein Template eine eigene error.php Datei? Wenn ja, benenne sie kurz um, dann wird die Errorseite von Joomla geladen.

    Ich verwende YOOtheme in der aktuellsten Version und habe die error.php in templates/yootheme umbenannt, bekomme aber die selbe leere 500er-Fehlerseite und nicht die Errorseite von Joomla.

    Zum Glück bin ich bei einem Webhoster, bei dem ich im Panel die letzte Backup-Version mit zwei Klicks wieder herstellen kann, deswegen muss ich keine Umwege über die configuration.php oder die DB gehen.

    Aus dem Logfile werde ich auch nicht schlauer. Es gibt diese Zeile aus, mehrfach, identisch:
    [21-May-2026 15:22:54 Europe/Berlin] PHP Warning: Zend OPcache can't be temporary enabled (it may be only disabled till the end of request) in Unknown on line 0

    Der Tipp ist der gleiche: aktiviere den Debug Modus, deaktiviere das Kompatibilitätsplugin und dann siehst du anhand der ausführlichen Fehlermeldung was die Ursache ist.

    Hallo zusammen,
    was mache ich denn, wenn ich das Kompatibilitäts-Plugin deaktiviere und die Seite nichts weiter als einen 500er Server Error zeigt? Der Debug-Modus ist aktiviert, aber das führt ja zu nichts bei einem 500er Server Error. Any idea?

    Hallo zusammen,

    ich erledige gerade die Updates auf 5.4. Einige der von mir betreuten Websites haben diverse Versions-Sprünge hinter sich. Nun stoße ich bei einem Projekt auf die Bibliothek "SimplePie", das seit J3.x obsolet ist, aber immer noch im System herumgeistert. Im Issue Tracker habe ich die Info gefunden, dass diese Bibliothek mit dem Upgrade auf 4.x entfernt worden sein sollte:

    Ist sie aber nicht. Und es lässt sich nicht deinstallieren (Bibliotheksdeinstallation: Die Manifest-Datei ist ungültig oder konnte nicht gefunden werden.)

    Nun meine Frage: Fliegt mit die Website um die Ohren, wenn ich auf 5.4 update?
    Muss ich vorher SimplePie in der DB und den Dateien per FTP suchen und manuell entfernen oder kann ich es ignorieren?

    Wie würdet ihr damit umgehen?

    Vielen Dank
    Antonella