Doppelklick auf "unerledigt" bringt eine Fehlermeldung. Vielleicht geht's ja auf diesem Weg.
Beiträge von Antonella
-
-
Great!
Das hat wunderbar funktioniert und macht auch bei anderen Links keine Probleme.DANKEEE!
Nach all den Jahren wieder was dazugelernt ... Joomla is great, isn't it?
-
Hallo,
ich baue an einem Seminarkalender. Dafür habe ich YOOTheme mit erweitertem Grid (Grid10) und dynamischem Content im Einsatz.Die Seminarinfos kommen aus Custom Fields.
Nun würde ich gerne auch den Grid-Button dynamisch einfügen, damit er nur dann erscheint, wenn er gebraucht wird.
Dafür habe ich ein Custom field angelegt, in das man den Artikel-Alias einfügt.
Das Custom field wird im YOOtheme-Grid in das Link-Feld geladen. Vor dem Feldwert ergänzt YOOtheme den ersten Teil der Beitrags-URL.
Soweit so gut, nur leider erscheint zusätzlich die Beitrags-ID in der URL, also z.B. /208-test-beitrag.
Wie bekomme ich die ID aus der URL?
Hat jemand einen Tipp?
Danke und LG
Antonella
-
Antonella meld dich mal bei deinem Hoster. Die Fehlermeldung aus dem Screenshot ist die 500er Seite deines Hosters, nicht die von Joomla - damit kannst du das nicht sinnvoll debuggen
Hab ich schon. Meine Frage richtete sich genau in diese Richtung - weil es keine übliche Joomla-Fehlerseite ist. Ich bekam eine für mich eher kryptische Antwort:
ZitatAlles anzeigen
ich sehe einen Fatal Error im phperror-Log:[21-May-2026 15:51:37 Europe/Berlin] PHP Fatal error: Uncaught Error: Failed opening required '/var/www/virtual/ikuf.de/htdocs/includes/defines.php' (include_path='.:/usr/share/php') in /var/www/virtual/ikuf.de/htdocs/index.php:36
Stack trace:
#0 {main}
thrown in /var/www/virtual/ikuf.de/htdocs/index.php on line 36
Ob das Ihr Problem ist weiss ich nicht.
Leider beeinflussen sich die Error-Excenptionsroutinen im Joomla mit den Ausgaben die PHP im error-Log machen kann.
Welche Variante an Einstellungen im Joomla hier sinnvoll ist, kann ich noch nicht sagen.
Ich würde jeglichen Debug- und Error-Ausgabemodus im Joomla deaktivieren und nur das Error-Log des PHP aktivieren, was Sie im Control-Center einstellen können.
Falls das zu keinen Fehlerausgaben führt, kann es auch sei das es gar keine PHP-Erros sind oder das eine andere Einstellkombination gewählt werden muss.
PHP-FPM reagiert hier anderes als das fgi vorher.
Fällt dir da was zu ein?
-
Ich danke euch allen für die Unterstützung. Heute werde ich den Fehler nicht mehr finden. Und J5.4.5 läuft ja auch noch ein paar Tage ...
-
Die Acymailing-Tabellen sind aus der DB entfernt, debug-Modus und Fehler berichten sind aktiviert, die error.php im Template ist umbenannt.
Also: Noch mal das Kompatibilitäts-Plugin deaktiviert - same situation: 500er Server-Fehlerseite ohne Error-Meldungen.
Habt ihr dazu noch eine Idee?
Was ist mit der FOF-Bibliothek, deren Kompatibilität mit J6 neben der des German Language Packs nicht erkannt wird. Kann das Problem damit zusammenhängen? Bei vielen anderen Seiten mit FOF ist das Systemupdate bisher problemlos durchgelaufen.
-
In der Datenbank habe ich Acymailing-Tabellen gefunden - Acymailing ist seit Jahren deinstalliert. Offenbar nicht vollständig. Kann ich die Tabellen einfach löschen? Ich trau mich manchmal nicht so richtig ...
-
Hat dein Template eine eigene error.php Datei? Wenn ja, benenne sie kurz um, dann wird die Errorseite von Joomla geladen.
Ich verwende YOOtheme in der aktuellsten Version und habe die error.php in templates/yootheme umbenannt, bekomme aber die selbe leere 500er-Fehlerseite und nicht die Errorseite von Joomla.
Zum Glück bin ich bei einem Webhoster, bei dem ich im Panel die letzte Backup-Version mit zwei Klicks wieder herstellen kann, deswegen muss ich keine Umwege über die configuration.php oder die DB gehen.Aus dem Logfile werde ich auch nicht schlauer. Es gibt diese Zeile aus, mehrfach, identisch:
[21-May-2026 15:22:54 Europe/Berlin] PHP Warning: Zend OPcache can't be temporary enabled (it may be only disabled till the end of request) in Unknown on line 0 -
Danke Christane,
dann doch Fischen im Trüben. Ich schau mal, ob ich aus den Logfiles schlau werde.
-
System > System debuggen: Ja
Server > Fehler berichten: Maximum -
Danke für eure Hinweise. Aber leider bekomme ich auch bei "Fehlerberichten: Maximum" keine Fehler angezeigt. Die Seite zeigt nur den 500er-Fehler.
-
Der Tipp ist der gleiche: aktiviere den Debug Modus, deaktiviere das Kompatibilitätsplugin und dann siehst du anhand der ausführlichen Fehlermeldung was die Ursache ist.
Hallo zusammen,
was mache ich denn, wenn ich das Kompatibilitäts-Plugin deaktiviere und die Seite nichts weiter als einen 500er Server Error zeigt? Der Debug-Modus ist aktiviert, aber das führt ja zu nichts bei einem 500er Server Error. Any idea? -
Wie durch ein Wunder taucht Simplepie nicht mehr in der Liste der für das Update kritischen Erweiterungen auf. Ich habe die Seite problemlos auf 5.4 aktualisiert. It's magic!
-
Hallo zusammen,
ich erledige gerade die Updates auf 5.4. Einige der von mir betreuten Websites haben diverse Versions-Sprünge hinter sich. Nun stoße ich bei einem Projekt auf die Bibliothek "SimplePie", das seit J3.x obsolet ist, aber immer noch im System herumgeistert. Im Issue Tracker habe ich die Info gefunden, dass diese Bibliothek mit dem Upgrade auf 4.x entfernt worden sein sollte:
Joomla! Issue Tracker | Joomla! CMS #40245 - Remove obsolete simplepie and phpmailer libraries from Joomla 4Issue tracking platform for the Joomla! projectissues.joomla.orgIst sie aber nicht. Und es lässt sich nicht deinstallieren (Bibliotheksdeinstallation: Die Manifest-Datei ist ungültig oder konnte nicht gefunden werden.)
Nun meine Frage: Fliegt mit die Website um die Ohren, wenn ich auf 5.4 update?
Muss ich vorher SimplePie in der DB und den Dateien per FTP suchen und manuell entfernen oder kann ich es ignorieren?Wie würdet ihr damit umgehen?
Vielen Dank
Antonella -
-
Hallo zusammen,
ich bin gerade dabei, die Updates auf 5.4.0 zu erledigen. Bei einigen Projekten macht der Button "automatische Updates" keinen Sinn, weswegen ich ihn gerne entfernen würde. Wenn ich in das Administrator-Modul Notifications gehe, taucht der Eintrag nicht auf. Wo finde ich ihn und wo kann ich ihn ausblenden?
DANKEE
Antonella -
Ja, es geht um die SPAM-Falle, vor allem seit gmx, googlemail, web.de etc. immer restriktiver damit umgehen. AMAZON finden meine KundInnen nicht so toll
Deswegen meine Frage nach Cleverreach oder Brevo. -
Hallo zusammen,
hat jemand von euch Erfahrung mit Mailservices wie Brevo oder Cleverreach? Was könnt ihr empfehlen für kleine Unternehmen, die mehrmals im Jahr ein Mailing an ca. 1000 Empfänger verschicken?
Danke euch
Antonella
-
Sie heißt easycalendar von https://www.joomboost.com/
-
Nun habe ich noch eine sehr einfache Kalender-Erweiterung gefunden. Damit und mit ConvertForms lässt sich das kleine Projekt sicherlich gut umsetzen.
Danke euch!