Beiträge von Luxa

    Mmh ok, ich dachte nur, dass CookieHint auch mit Joomla 3.6 kompatibel ist da hier: https://extensions.joomla.org/extension/cookiehint/ steht Compatible with Joomla 3.x
    Ich habe mich bisher vor einem Update gedrückt, da ich eine Galerie-Erweiterung installiert habe, die möglicherweise mit einer höheren Joomlaversion nicht mehr funktioniert.


    Gibt es Cookie-Plugins die auch mit einer älteren Joomlaversion laufen oder liegt es rein an meiner etwas älteren Joomlaversion?

    Ich würde meine Webseite gerne DSGVO konform machen und entsprechend einen Cookie-Banner einbauen.


    Joomla Version 3.6.5
    PHP-Version 7.0

    Ich bin leider kein Joomla Profi, sondern eher ein Learning-by-doing Laie. Gibt es eine Möglichkeit irgendwo zu sehen, welche Cookies die Webseite lädt (oder ob)?


    Eben nachgeschaut. Laut Chrome-Browser verwendet die Seite zwei Cookies.

    Hallo zusammen,


    ich versuche im Moment einen Cookie-Banner auf meiner Homepage einzubauen.

    Ich habe schon diverse Plugins hierfür ausprobiert. Leider bricht jedes Mal meine Webseite zusammen sobald ich das Plugin aktiviere.

    Zuletzt habe ich das Plugin CookieHint (https://www.redim.de/downloads/erweiterungen/cookiehint) ausprobiert.

    Sobald ich es aktiviere kommt "Es ist ein Fehler aufgetreten! Call to undefined method JApplicationAdministrator::isClient()" und meine Webseite geht nicht mehr.

    Ich muss dann ein komplettes Backup aufspielen damit ich die Seite wieder zum Laufen bekomme.


    Kennt jemand eine Lösung? Oder hat jemand eine Idee woran das liegen könnte?
    Ich weiß einfach nicht, wie ich so einen Cookie-Hinweis auf meine Webseite machen sollen.

    Viele Grüße
    Luxa

    Vielen Dank für eure Hilfe.
    Habe jetzt erstmal einige Seiten manuell über die Google Search Console entfernt und in der robots.txt die Links mit /*? verboten. Mal sehen wie das klappt.
    Mittlerweile habe ich eine Teilursache für diese seltsamen ?1234 Links gefunden. Sie stammten u.a. von meinem Gallery-Tool. Bei dieser Galerie kann man einstellen, dass nicht jedes Bild eine eigene URL angezeigt bekommt (eben nicht die URL ...?1234 (wobei 1234 die Bild-Nummer ist), sondern nur die URL der Seite auf der sich die Galerie befindet). Diese Einstellung wirkt aber scheinbar nur für den Benutzer meiner Webseite und gilt nicht für Google ... für Google war dieser "manuell verborgene" Link scheinbar nicht unsichtbar. Die Entwickler der Galerie sind aber mittlerweile informiert und werden das Problem in künftigen Updates versuchen zu beheben.

    Noch eine Frage zum Schluss. Wisst ihr zufällig, wie man in der Google Search Console eine Neuindizierung für die gesamte Homepage beantragen kann?

    Bei der "alten" Version der Search Console konnte ich das, bei der "neuen" Search Console, auf die Google jetzt scheinbar umstellt (und einige Einstellungen werden auch nur noch mit der "neuen" Console anzeigt), finde ich die betreffende Option nicht. Ich finde nur die Option für das Beantragen der Neuindizierung von einzelnen URLs, nicht für die gesamte Homepage. - Die Seiten, auf denen sich jetzt eine neue "no index" Einstellung befindet, können dadurch (irgendwie auch logisch) nicht neu indiziert werden .... allerdings erkennt Google so aber auch vermutlich nicht, dass die Seite aus dem Suchverlauf rausgeschmissen werden sollte... Bin mal gespannt, wie lange das mit dem manuellen URL-Entfernen klappt ...

    Vielen Dank für deine Antwort.

    Ich habe das Problem nie, da ich bei der Erstellung darauf achte, dass Suchmaschinen nur meine Menüstruktur bekommen und nicht meine Kategoriestuktur.

    Wie macht man das? Wie bewirke ich, dass Google nur die Menüstruktur bekommt? Hätte man da von Anfang an die Robots-Einstellungen entsprechend auf noindex,nofollow stellen müssen oder wie verhinderst du, dass Google nur deiner Menüstruktur folgt?


    Bzw. wie kann ich jetzt, nachdem der Fehler wohl passiert ist, die Kategoriestruktur wieder aus der Googlesuche versuchen zu entfernen?


    Und wie verhindere ich diese komischen URLs, an denen an die eigentliche URL "?1234" einfach willkürlich eine vierstellige Zahl angehängt wird. Google listet mir dadurch z.B. meine Startseite mehr als 10mal auf.

    Vielen Dank für die schnelle Antwort.
    Für die Menüpunkte werde ich dann jeweils mit meiner "Seltsamen Beobachtung" die betreffenden Seiten-URLs entfernen und dann mit der Google Search Console sie auch aus der Googlesuche löschen. Sollte dann ja dauerhaft sein, da es ja den Link nicht mehr gibt wegen der Fehlerseite.

    [In der default.php konnte ich nichts mit "case heading" oder Ähnlichem finden. Ich denke aber, dass das nicht mehr relevant ist, da es jetzt ja mit den Menüpunkten dann funktionieren sollte.]



    Allerdings sind mir noch ähnliche Probleme bei zwei Dingen aufgefallen:

    1. Für "Kategorien":

    Joomla generiert für jede erstellte Kategorie eine eigene URL (z.B. .../index.php?option=com_content&task=view&id=31 und/oder .../index.php/43-NamederKategorie ; dabei ist 43 die Kategorie ID). Allerdings wird diese Seite/URL gar nicht benötigt und es ist nicht gewollt, dass diese bei der Google-Suche auftritt. Da ich keine Möglichkeit gefunden habe, dass diese URLs gar nicht existieren, habe ich jetzt bei den Kategorien jeweils in den Einstellungen auf "Robots: Globale Einstellung noindex, nofollow" umgestellt. Damit sollten die Seiten nach dem nächsten Crawling nicht mehr in der Google-Suche auftauchen, oder?
    Gibt es eine Möglichkeit Joomla ganz daran zuhindern, dass diese Kategorie-URLs generiert werden?


    2. In der Google-Suche erscheinen ganz viele https://Webseiten-Name/index.php?1213 , https://Webseiten-Name/index.php?1218 , usw. jeweils mit einer anderen vierstelligen Nummer. Es wird dabei immer zur Startseite verlinkt.

    Ich hab absolut keine Idee, woher diese URLs kommen. Scheinbar müssen sie ja von der Webseite selbst kommen, wenn Google sie findet. Aber ich habe keine Ahnung, warum Joomla so seltsame URLs generiert. - Folglich weiß ich auch nicht wie man diese extrem unnötigen URLs in der Googlesuche los wird. Hat mir da jemand eine Idee?
    Es habe das gleiche Phänomen aber auch schon bei einem anderen URL-Link gesehen. Auch hier wurde einfach eine vierstellige Nummer angehängt.

    [Den Namen der Webseite würde ich, falls notwendig, dann gerne per persönliche Nachricht schicken.]


    Schon mal vielen Dank für alle Tipps und Ratschläge!

    Hallo,


    ich habe ein kleines Problem mit den Menüpunkten auf einer Internetseite, die mit Joomla erstellt wurde.

    Ich habe mehrere Menüpunkte, die selbst zu keinem Beitrag/... verlinken sollen, sondern einfach nur als Oberüberschrift für darunter geordnete Untermenüpunkte dienen.

    Diese Menüpunkte sind in Joomla erstellt mit der Einstellung: "Menüeintragungstyp: Menü-Überschrift".

    Auf der Webseite selbst funktionierten diese "toten Menüpunkte" wunderbar, allerdings gibt es ein Problem mit Google.


    Wenn ich die Seite mit Google suche, dann zeigt mir Google neben dem eigentlichen Link zur Startseite auch Links zu einzelnen Beiträgen, ... an. - An sich kein Problem, aber Google zeigt mir auch Links mit meinen "toten" "Menüpunkt-Überschriften" an. Diesen Menüpunkten ist ja kein Beitrag zugeordnet, aber Google verlinkt mich dann mit Klick auf die wohl doch irgendwie zugängliche Seite (http/...../tote-menüpunkt-überschrift). Auf dieser wird mir dann eine Liste mit allen Kategorien der Webseite (und Unterkategorien, sowie zugeordneten Beiträgen) angezeigt. Dies ist für die Besucher total verwirrend. Ich möchte gerne, dass Google praktisch nicht zu diesen "toten Menüpunkten" verlinkt - schließlich enthalten sie ja keinen Inhalt, da kein Beitrag ihnen zugeordnet ist.

    Kann mir jemand weiterhelfen? Weiß jemand, wie ich Google klar mache, dass die "toter Menüpunkt"-Seite (http/...../tote-menüpunkt-überschrift) nicht relevant ist und den Besuchern meiner Seite nicht zugänglich ist und folglich auch nicht über Google erreicht werden sollte.


    Viele Grüße

    Luxa



    Jetzt ist noch etwas Seltsames aufgetreten: Wenn ich im Joomla-Administatorbereich den betreffenden "toten Menüpunkt" aufrufe und einfach unverändert speichere, dann erscheint auf der Homepage (unter dem Link für den toten Menüpunkt, der ja eigentlich nicht zugänglich sein sollte (http/...../tote-menüpunkt-überschrift)) statt der Kategorieliste plötzlich die Fehlerseite.

    Woher kommt das? Würde Google jetzt nicht mehr diesen falschen (falsch, da er ja nicht gewünscht ist, da kein Beitrag dahinter liegt) Link in der Googlesuche aufführen (... dauert natürlich einige Woche bis Google seine Links überarbeitet)?

    Hallo,


    ich habe meine Internetseite neu aufgesetzt (alles neu - neue Joomla-Version; neues Template; neues Menü; ...).
    Leider habe ich nun mit der Google-Suche einige Probleme und weiß nicht, wie ich diese gelöst bekommen soll.


    Zum Einen zeigt Google immer noch Suchergebnisse mit Links zu Beiträgen meiner alten Seite an (z.B...../index.php?option=com_content&task=view&id=73), obwohl dieser Artikel auf der neuen Seite nicht mehr besteht! Daher kommt dann auch immer "Kategorie nicht gefunden", wenn man den Link benutzt.
    Er zeigt auch Links zu Seiten an, die ich gar nicht "eingerichtet" habe und die ich auch nicht meinen Besuchern zeigen möchte
    z.B. .../index.php?option=com_content&ta -> Zeigt alle Menüs mit Untermenüs als Liste an
    oder .../index.php?option=com_content&task=view&id=20&Itemid=119 -> Zeigt eine Liste mit Beiträgen einer Kategorie


    Außerdem bietet Google bei der Googlesuche auch noch Links zu Beiträgen an, die ich in Joomla als "versteckt" markiert habe.


    Wie kann ich abstellen, dass Google solche Seiten bei der Google-Suche anzeigt?
    Außerdem würde ich gerne verhindern, dass meine Besucher eine solche Seit sehen können.


    Wäre sehr nett, wenn mir jemand weiterhelfen könnte. Habe schon viel im Internet gesucht, aber noch nicht so richtig was passendes gefunden ... habe mich auch bei Google Webmaster-Tool angemeldet, allerdings finde ich auch dort keine anständige Lösung.


    Vielen Dank

    Hallo zusammen,


    über eine editor.css Datei kann ich meine normalen Style im JCE-Editor sichtbar machen.
    Bisher ist es mir leider noch nicht gelungen, die Font-Awesome-Symbole im JCE-Editor sichtbar zu machen.


    Hat jemand eine Idee, wie man diese im JCE-Editor sichtbar machen kann?


    Viele Grüße
    Luxa

    Hallo,


    vielen Dank für die schnelle Antwort.
    Gerade hat sich das Problem von selbst aufgelöst. Ich habe schlauerweise eine Klammerzu in der custom.css nach @media vergessen und somit meine ganzen nachfolgenden Klassen "ausgeschaltet" ....


    Danke dennoch für die schnelle Antwort.
    Viele Grüße
    Luxa

    Hallo,


    ich erstelle gerade eine Webseite und bei mir ist folgendes Problem aufgetreten.
    Ich würde gerne eine Tabelle in einem Artikel individuell anpassen.
    Dafür habe ich folgenden html-code im article-editor eingegeben:
    <table class="rot">
    <tbody>
    <tr>
    <td>text</td>
    <td>text</td>
    </tr>
    </tbody>
    </table>>


    in meiner Custom.css-Template-Datei habe ich ergänzt:
    .rot {
    color: #b40000;
    }


    Leider wird die Klasse nicht angewählt. D.h. es erscheint zwar auf der Homepage im html-code <table class="rot"> aber diese Klasse wird nicht angewählt (nur das normale table wird angewählt; die Klasse .rot in der custom.css nicht).
    Wenn ich normalen Texten (ohne Tabelle) z.B. <p class="rot"> zuordne, dann wird diese Klasse wie gewohnt angewählt und ausgeführt.


    Warum werden keine Tabellenklassen ausgeführt? Hat da jemand eine Idee?


    Vielen Dank
    Luxa

    Hallo zusammen,


    ich würde gerne folgendes Plugin für die Gallerien auf meiner Webseite verwenden:
    http://www.joompolitan.com/lightgallery.html


    Leider zeigt das Plugin unter jedem Bild (in der Lightbox) immer den Titel der Gallery an. (z.B. Image from Joopolitan)


    Ich würde es aber bevorzugen, wenn anstatt des Titels der Gallery, der Titel des jeweiligen Bildes angezeigt werden würde.
    (z.B. Wenn image-url: /.../images/reddog.jpg und alternate text: red dog, dass dann mir angezeigt wird: "reddog" unter dem Bild anstatt des Gallerytitels)
    [So wie beim SIGE-Gallery-Plugin https://joomla-extensions.kubi…le-image-gallery-extended leider sind mir hier die Buttons für "imagenext" zu klein und unpraktischerweise unter dem Bild statt am Seitenrand angeordnet]


    Leider kenne ich mich mit dem Aufbau von Plugins nicht gut aus und weiß nicht, in welcher Datei des Plugins ich den Code wie abändern muss.
    Vielleicht hat von euch jemand eine Idee bzw. kann mir sagen, ob das überhaupt möglich ist.


    Ich habe bereits nach Alternativ-Gallerien gesucht. Aber entweder finde ich das Design echt unpraktisch (viel zu kleine "nextimage"-Pfeile/ schlechte Anordnung/...) oder sie haben alle das Problem, dass sie nur den Gallerietitel unter dem Bild anzeigen und nicht den Bildtitel.


    Wäre nett, wenn mir jemand weiterhelfen könnte.


    Viele Grüße
    Luxa