Beiträge von thofi61

    Hallo Gemeinde,


    checke ich meine Seite auf builtwith.com, um zu sehen, was da bei mir im Hintergrund noch so arbeitet, werden mir ein paar Sachen angezeigt, die eigentlich nicht vorhanden sind. U.a. Google Analytics, was ich nie verwendet habe. Dann noch Adsense, Addthis und Google Translate Widget. Ist von mir alles entfernt worden. Joomla Cache Speicher ist leer und aus. In der Datenbank finde ich nichts. Auf dem Server auch nicht. Die index.php ist sauber. Wo versteckt Joomla die Altlasten?

    Gut, vergessen wir GDRP. Wenn's keine All-in-One-Lösung für DSGVO gibt, muss ich mich wohl noch weiter in die Materie einarbeiten. Habe meine Seite schon von jeglichen Ballast befreit, über den ich stolpern könnte. Keine Kommentarfunktion mehr, keine Social Links, keine Formulare, keine Suchfunktion, ... usw. Nur noch Inhalte ... und etwas Werbung ... auch heikel.

    Datenschutzerklärung und Impressum sind DSGVO konform überarbeitet. Fehlt noch der Auftragsverarbeitungsvertrag mit dem Hoster. Wenn ich für das heiße Thema Cookies bis zum 25. keine Lösung finde, werde ich mich wohl von meinem Hobby verabschieden. Die Haie warten nämlich schon auf ihre Beute und wenn man einmal deren Opfer war, möchte man das nicht nochmal erleben. Ich hoffe, nach den ersten Rechtsprechungen pendelt sich die Verordnung etwas ein, dass man als Hobby-Webmaster wieder etwas mehr wagen kann.

    Hallo Gemeinde,


    der Mai ist gekommen und am 25. tritt die neue Datenschutzgrundverordung (DSGVO) in Kraft. Joomla entsprechend darauf vorzubereiten, scheint ja nicht so einfach zu sein - Siehe hier.

    Bisher wird die neue Verordnung noch nicht bei den Joomla-Updates berücksichtigt und da die Zeit langsam drängt, überlege ich die Erweiterung GDPR zu erwerben. Hat schon jemand Erfahrung damit und kann bestätigen, dass z.B. tatsächlich die Möglichkeit besteht die Cookies zu blockieren, wenn der User das nicht möchte? Viele Cookie-Hint Plugins arbeiten hier nämlich nicht korrekt.


    Beste Grüße

    Thomas

    Nach langen vergeblichen Suchen and Testen habe ich mich nun dafür entschieden das PHP-Script view.html.php im Ordner components/com_content/views/article anzupassen, wie es in diesem Beitrag beschrieben wird.


    Die Zeile

    Code
    1. $category = JCategories::getInstance('Content')->get($this->item->catid);


    durch

    Code
    1. $category = 0;


    ersetzen.


    Steht im Script ungefähr bei Zeile 250


    Zwar keine optimale Lösung, aber es funktioniert.

    Hallo Joomla Gemeinde,


    ein altes Problem beschäftigt mich zu Zeit neu und ich finde einfach keine Lösung. In meinen Breadcrumbs erscheinen auch die Bezeichnungen der Kategorien. Daher habe ich hier teilweise doppelte Namen, was auch in den Google Suchergebnissen so angezeigt wird. Das ärgert mich, weil es unprofessionell aussieht und daher bin ich wieder auf der Suche nach einer Lösung.


    Ich habe z.B ein Menü "Strände". Die zugehörigen Beiträge gehören zur Kategorie "Strände". Rufe ich nun einen Beitrag auf, steht in den Breadcrumbs


    Startseite» Strände» Strände» Beitrag


    Hier eine Beispielseite: http://www.mallorca-homepage.de/straende/amonia.html


    Klickt man dann auf das zweite "Strände" erscheint nicht der Beitrag, der mit dem Menü "Strände" verknüpft ist, sondern ein Modul (JA Image Hotspot - Es erscheint eine Karte mit Hotspots), das zwar dem Menü zugewiesen wurde, aber nicht als eigene Seite erscheinen sollte.


    Ich hoffe, ich konnte mich verständlich ausdrücken. Ich arbeite jetzt seit gut einem halben Jahr mit Joomla, aber habe immer noch Probleme mit der Logik die dahinter steckt. Ich hoffe auf eure Hilfe. Irgendwo mache ich einen Gedankenfehler. hmm


    Ich nutze die aktuellen Joomla Version 3.8.3 .


    Beste Grüße
    Thomas

    Danke für die schnelle Antwort und die Mühe sich mit dem Quellcode zu beschäftigen.


    Also vorher wurde daraus kein title-Attribut gemacht, sondern eine Bildunterschrift. An dem Template habe ich nichts verändert.
    An die PHP vom Template wage ich mich nicht ran. Da habe ich keine Ahnung, was ich da anrichte ;(
    Warum das notwendige JavaScript, dass auf das class="caption" lauscht, nicht geladen wird ? ... keine Ahnung. Monatelang ging's. Da muss sich doch bei einen Joomla-Update etwas passiert sein.
    Ich bin jetzt kein html, css, php und sonstiger script Experte um das zu lösen. Darum habe ich ja ein CMS gewählt, in der Hoffnung, dass ich mich dann damit nicht rumärgern muss.


    Ich werde den Copyright Hinweis dann direkt in die Kartengrafik einkopieren. Ist für mich die einfachste Lösung.


    Zitat

    Merkwürdig finde ich, dass auf so was von Hilfesuchenden nicht reagiert wird


    Ich dachte, die Screenshots würden genug aussagen ... sorry.

    Hallo,


    sorry, dachte das wäre eindeutig.


    Also, bei den Beiträgen kann man unter "Bilder und Links" ein sogenanntes Beitragsbild einfügen. Das kann man mit einem alternativen Text und einer Bildunterschrift ergänzen. Nun ist es so, dass die Bildunterschrift im Frontend nicht mehr unter dem Bild angezeigt wird, wie es vorher prima geklappt hat, sondern als alternativer Text für das Bild.
    In meinem Fall ist das Bild eine Karte, und die Bildunterschrift der Copyright Hinweis. Einen alternativen Text hatte ich extra eingefügt. Dieser wird jetzt ignoriert und dafür die Bildunterschrift angezeigt.
    Ich hoffe die beiden Screenshots sind eindeutiger als meine Erläuterungen. ;)


    Backend Screenshot


    Frontend Screenshot


    Der Copyrighthinweis, der im Frontend Screenshot als alternativer Text angezeigt wird, stand vorher unter der Karte.


    Danke für die Geduld und Gruß
    Thomas


    Hallo,


    bei einer Überprüfung meiner Webseite mit einem SEO-Tool wurde mir angezeigt, dass die Sprachangaben widersprüchlich sind.


    Bei der Debug Fehlersuche wird mir angezeigt: "Fehler in den Sprachdateien analysieren"
    JROOT/plugins/system/nrframework/language/de-DE/de-DE.plg_system_nrframework.ini : error(s) in line(s) 55, 56, 57, 58, 59, 60, 61, 62


    Die Sprachen Einstellungen sind eigentlich alle korrekt. Alle weiteren Möglichkeiten - soweit mir bekannt - bin ich ebenfalls noch durchgegangen. Bin allerdings noch Joomla-Frischling.
    Im Quelltext im Browser steht: xml:lang="de-de" lang="de-de"
    Ich habe aktuell Joomla 3.8.2 im Einsatz.

    Ich habe jetzt die für mich einfachste Lösung gewählt.


    Da ich keine Lust hatte über 60 URLs nochmal neu einzugeben, habe ich die redirect Spalte aus der Datenbank nach Excel exportiert. Von dort dann die Spalten "alte URL" und "neu URL" in den htaccess Generator von netgrade.de eingeben. Der hat daraus eine schöne redirect 301 Liste gemacht und die habe ich in meine htaccess-Datei kopiert. Ist zwar keine elegante Lösung, aber funktioniert super.