Beiträge von JoomlaWunder

    Wenn das Tool das macht, was es verspricht, dann wäre das trotz des Preises lohnenswert bei solch einer Aufgabe.

    Allerdings vermute ich, dass hier noch einiges nachkorrigiert werden müsste. Allerdings kenne ich das Tool nicht.

    Hast du mal einen Link zur alten Seite zum Anschauen? Vielleicht fällt jemandem etwas anderes dazu ein.


    Wenn der Verein allerdings nicht einmal ein Budget für dieses Tool hätte, mmh..... Alles andere würde sicherlich deutlich teurer werden.

    Wenn sich allerdings 20 Vereinsmitglieder am Umbasteln beteiligen würden, die sich natürlich auskennen sollten, dann wäre das eventuell eine Alternative. Oder ihr pflegt die Inhalte nach und nach ein.

    Ist das Menü eventuell doch auf Position-1 und darunter schließen lp-top-1 und lp-top-2 an?

    https://static.joomlart.com/im…pli/landing-page-full.jpg


    Vielleicht hast du versehentlich die Position Top2 eines anderen Templates gewählt. Überprüfe das mal! Die haben ja oft gleiche Namen.


    EDIT: Ich habe gerade gesehen, dass auf deiner neuen Seite einiges nicht erreichbar bzw. "gesperrt" ist. Wie lautet denn die Zugriffsebene deines Moduls? Müssten wir uns eventuell einloggen können, um es zu sehen?

    Oder muss ich das speichern, indem ich die Overrides anlege?

    Sobald du ein neues Language-Pack installierst, welches immer zeitnah mit einem Joomla-Update herauskommt, werden die Sprach-Dateien ersetzt. Wenn du deine Änderungen in diesen Dateien vorgenommen hast, dann sind diese weg. Deshalb wurden die Sprach-Overrides eingeführt. Joomla schaut zunächst immer, ob es für die Schlüssel ein Override gibt und nimmt dieses. Wenn es das nicht gibt, werden die Inhalte aus den Sprachdateien genommen.

    Die Antwort auf deine Frage ist deshalb: Ja!

    Hallo,


    ich bin gerade auf ein kleines Problem gestoßen. Im JCE wollte ich 2 Zeichen in einem unterstrichenen Text hochstellen, also über x2 -Symbol bzw. <sup>....</sup>

    Erwartet habe ich folgendes: Dies ist ein Textbeispiel*) hier!


    Nun wird mir der Unterstrich bei beiden hochgestellten Zeichen aber auch hochgestellt angezeigt (Editor und Frontend). Hier im Editor des Forums kann ich das so gar nicht eingeben/darstellen. Der Code ist jeweils der gleiche.



    Woran mag das liegen?


    Ich habe es mit text-decoration: underline; und auch über <u>...</u> versucht.


    Joomla und JCE sind aktuell!

    PHP 7.4

    Getestet mit aktuellem Firefox!

    Ich hab mich da irgendwie verrannt und schaffe es nicht, dass ein Eigenes Modul mit ein paar Zeilen Text auf der Startseite angezeigt wird.

    Weit hergeholt, aber selber schon erlebt: Schrift in gleicher Farbe wie Hintergrund? (Hintergrund im Editor und im Frontend können differieren)

    Schau mal in den fertigen Quellcode im Browser! Vielleicht steht der Text drinnen.

    Oder mal ein Bild ins Modul einfügen!


    Eventuell hast du ein Layout gewählt, wo die Position nicht existiert!

    Link zur Seite?

    Hat denn euer Handwerkspartner auch eine Joomla-Webseite?

    Und es soll dort in die Datenbank?

    Prinzipiell könnte der Partner auch zusätzlich auf eine externe DB zugreifen. Das wäre aber etwas komplizierter und möglicherweise auch ein rechtliches Problem. Das Bilderproblem wäre damit noch nicht geregelt. Müsste man ja auch vom fremden Server abrufen (also von deinem).

    Alles in einem: Da würde ich mich lieber 2x einloggen und C&P nutzen, als mit Programmieren anzufangen.

    Auf der Download-Seite wird angegeben, dass das de-language-Pack nur zu 99% übersetzt ist.

    Wenn du die de-Datei umbenennst in die en-Datei und in der de-Datei nicht alles übersetzt ist, dann kann der Inhalt nicht angezeigt werden. Und auf die en-Datei kann ja nun alternativ auch nicht zurückgegriffen werden, da du diese ja sozusagen bereits verwendest.

    Normalerweise werden nicht übersetzte Inhalte ja dann in englisch angezeigt, wenn keine Übersetzung vorhanden ist.

    Das könnte eine Erklärung für deinen 3.Test sein.

    Mag etwas verwirrend klingen, weiß aber nicht, wie ich das einfacher erklären könnte... ;)

    Du müsstest also mal die Dateien 1 zu 1 vergleichen, wenn du die eine in die andere umbenennst! Sonst kann das zu Fehlinterpretationen führen.


    Wenn du jedoch Probleme mit mehreren Komponenten hast, würde ich zunächst die allgemeinen Spracheinstellungen durchsehen (Frontend- und Backend). Läuft das Backend denn außer den betroffenen Komponenten auf deutsch?

    Schau auch mal direkt beim User nach, ob hier was verstellt ist!


    Welche anderen Komponenten sind betroffen?

    Welche Joomla-Version, welche Jomsocial-Version?


    Mit Jomsocial selber kenne ich mich nicht aus.

    Leider geht es immer noch nicht wen ich den direkten link zum bild aufrufe z.b. http://www.testdomain.de/image/galerie/Album/test.jgp erscheint das bild ohne passwort abfrage


    Die .htaccess habe ich in die Phocagalerie reingelegt.

    Wenn du die .htaccess in den Ordner .../Album legst, dann sollte die Abfrage erscheinen! Teste das mal!

    Sollte eigentlich auch mit dem Ordner /galerie funktionieren.


    EDIT: Was ist das für ein Pfad für die .htpasswd?

    C:\Joomlaordner/image/pw/.htpasswd


    Aber auch der andere angegebene Pfad mit http://www... funktioniert so womöglich nicht. Gebe ihn mal analog zu den Pfaden zum /logs bzw. /tmp-Verzeichnis an, so wie es auch in der configuration.php steht! (ähnlich meinem Beispielcode, nur halt mit deinen korrekten Pfaden)

    Natürlich kannst du jeden Ordner absichern. Dann kommt halt diese zusätzliche Passwortabfrage, sobald drauf zugegriffen wird.


    Da in /images aber nicht nur deine speziellen Dateien abgelegt werden, sondern so einiges, was im Frontend angezeigt wird, macht es keinen Sinn bzw. ist kontraproduktiv, diesen Ordner abzusichern. Du köntest einen Unterordner in /images absichern oder ein Verzeichnis parallel zu images erstellen. Im letzteren Fall stellt sich aber die Frage, ob eine Erweiterung auch darauf zugreifen kann.


    Aber möchtest du wirklich diese zusätzliche Passwortabfrage?


    Du darfst nicht die Joomla-htaccess verwenden, sondern musst eine weitere .htaccess und .htpasswd im zu schützenden Verzeichnis erstellen. Die .htpasswd legt man meist sogar in ein anderes Verzeichnis und stellt entsprechend den Pfad in der .htaccess um.


    Du könntest beispielsweise folgenden Code verwenden:

    Frage bitte nicht, was "limit get" bedeutet. Müsste ich erst googeln!

    In der .htpasswd steht dann der User und das Passwort, etwa so in der Art:


    Nutze für beide Dateien am besten eine Online Generator, da gibt es einige im Web!

    Kann man eine Komponente mit dem Dateimanager des Hosters von einer Webseite A zu einer Webseite b kopieren?

    Die kostenfreie Komponente Acyl-Mailing in meiner alten Webseite war sehr mächtig.

    Nur für den Fall, dass deine Webseite B gerade neu angelegt wird:

    Dann könntest du auch die komplette Webseite A inkl. AcyMailing umziehen und alles Alte rauslöschen und damit weiterarbeiten.


    p.s. Ist die neue Version wirklich so abgespeckt...

    Hi, hab das Plugin unter Joomla 3.9.8 installiert und aktiviert. In der Config taucht es leider nicht auf, nur recaptcha. Irgendeine Idee, wie ich das lösen kann?

    Dein Joomla 3.9.8 enthält einige Sicherheitslücken. Aktualisiere unbedingt auf 3.9.18!

    Wird es jetzt angezeigt?

    Sorry, nein, ich habe zwar einen auf höchste Sicherheit konfigurierten Firefox-Browser, dessen Sicherheits-PlugIns ich aber bei Nutzung der Joomla-Backends deaktiviere. Zudem wurde ich ebenfalls unerwünscht ausgeloggt, als ich einen sehr primitiven Browser (Midori) verwendet hatte.

    Könnte es es an einem browserübergreifenden Sicherheitsplugin/-tool liegen, was auch immer das sein mag. Eventuell wurde es nur nicht deaktiviert.

    Nutzt du irgendeine spezielle Einstellung in einer Firewall?

    Möglicherweise haben auch beide getesteten Webhoster eine ähnliche Konfiguration, die zu diesem Problem führt. Ich selber hatte diese Symptomatik bisher mit keiner Joomla-Version und bei keinem Webhoster. Deshalb ist das alles nur geraten...