Beiträge von vnv-urbex

    Hallo und Guten Morgen,

    ich habe jetzt mal in meiner custom.css Stück für Stück die Einträge gelöscht die mit dem Menü in Zusammenhang stehen. So konnte ich den Fehler eingrenzen. Ich hatte dies der custom.css hinzugefügt und wollte damit erreichen, dass das Menü etwas breiter ist(240px) und die Dreiecke sauberer hinter den Einträgen angezeigt werden. Scheinbar muss ich da was falsch gemacht haben.


    So hatte ich die bestehende Klasse angepasst.

    Beheben wollte ich das Problem...



    LG René

    Hallo, ich muss den Beitrag noch einmal aktivieren. Ich habe gerade festgestellt, dass die Anzeige des Menüs am Smartphone nicht mehr passt. Normal war das Menü am Handy offen, also alle Einträge wurden angezeigt.

    Nun werden nur noch die obere Ebene angezeigt. Tippe ich auf einen Eintrag der oberen Ebene, wird mir die nächste nur kurz und verschoben Angezeigt.



    Im Modul steht Untermenüeinträge anzeigen auf "Ja" Auch soll die Erste und Letzte Ebene angezeigt werden.Erst dachte ich es liegt an der Änderung, also habe ich diese aus der custom.css gelöscht. Aber keine Änderung, scheinbar liegt es nicht an der Änderung.

    Zur Seite...

    Können wir da bitte bei Gelegenheit noch einmal schauen? LG und Danke

    Hallo Anka und chr-hl,

    ich habe die Anpassungen jetzt vorgenommen und es funktioniert. Vielen Dank. Auch habe ich noch padding-left und right eingefügt um so den Abstand noch ein wenig anzupassen. Dann wird es aber am Smartphone gequetscht angezeigt. Also habe ich es jetzt so gelöst...


    Code
    1. .right_column > div {
    2. background: transparenturl(../images/fade-left-column.png) 100% 0 no-repeat; min-height: 250px; padding: 6px 15px 30px 0; margin: -8px 15px 0px 0px;}

    "margin: -8px 15px 0px 0px;"


    Da spricht doch nichts dagegen oder? LG René

    Im Screenshot ist doch links und rechts der Rand zu sehen. Diesen habe ich jetzt als Border dort eingefügt. Halt nur um zu sehen wie es aussehen soll. Praktisch ist das ja Blödsinn. Ich weiß aber nicht, wie ich anders den Rand umsetzen soll. Aber aussehen soll es so. Wie oben beschrieben soll der Contentbereich an den Seiten eingefasst werden und sich farblich etwas absetzen.


    LG René

    Hallo, ich möchte gern den Contentbereich auf meiner Seite einfassen. Allerdings weiß ich nicht wie ich fangen soll. Zur Veranschaulichung habe ich es jetzt mal mit einem Border 200px gelöst. Natürlich funktioniert dies nicht. Wird die Seite mit geringer Auflösung angezeigt, bleibt der Border natürlich gleich und nur der Contentbereicht verkleinert sich.



    Ich möchte aber, dass die Seiten sich dann verkleinern und der Content gleich bleibt. Bis die Auflösung halt so klein wird, dass auch der Content sich anpasst. Dies soll aber nicht auf der Startseite der Fall sein, sondern nur auf den Beiträgen und Kategorien. Daher war meine Überlegung dies über die Seitenklassen zu regeln. Ich könnte ja dann jeder Seite die Klasse zuweisen. Außer man kann die Startseite irgendwie ausschließen.


    Quasi soll die Startseite Full Width sein und die Beiträge so eine Art Boxed. Bei Full Width schweift das Auge immer ab und wenn es so eingefasst ist, bleibt man besser beim Text.


    Ich hoffe ihr könnt mir folgen und habt vielleicht einen Lösungsansatz für mich.


    LG und vielen Dank

    Sorry aber ich finde die richtige Klasse nicht.


    So funktioniert es nicht

    Code
    1. .drop-down li li:after-child > a, .drop-down li li:after-child > span {
    2. content: url(http://www.mozilla.org/favicon.ico);
    3. }

    Und so wirds mir hinter jedem Eintrag angezeigt

    Code
    1. .drop-down li li:after {
    2. content: url(http://www.mozilla.org/favicon.ico)
    3. }

    LG



    EDIT:


    Ich habe es jetzt so einigermaßen hinbekommen, zumindest sind die Pfeile an den richtigen Einträgen.

    Hallo Leute, ich würde gern erkenntlich machen, dass ein bestimmter Menüeintrag noch weitere Einträge enthält. Dazu hätte ich gern ein Dreieck oder ähnliches, welches die Submenüs kennzeichet. Bisher bin ich da nicht weitergekommen, mein altes Template hat zwar diese Dreiecke, aber ich finde nicht heraus wie diese angelegt wurden.

    Template Alt | Template Neu



    Vielen dank für eure Tipps. LG

    Hallo Leute, Danke für eure Hilfe bis hierher. Ich glaube es ist besser, wenn ich die alten Icons lasse und stattdessen sparsam mit diesen umgehe. So kann ich auch besser bestimmte Menüpunkte hervorheben. Wäre sicher eh nen bissel übertrieben. Vielleicht schreib ich mal dem Template Support, ob die das updaten.


    Vielen Danke euch ;-) und schönes WE

    Also ich habe jetzt...


    Dies meiner Template index.php hinter <head> eingefügt

    Code
    1. <link href="/templates/joomspirit_128/css/all.css" rel="stylesheet"> <!--load all styles -->

    Alles css Dateien aus dem Awesome Archiv(Ordner CSS) in den Template CSS Ordner kopiert.


    Den Ordner Webfonts aus dem Awesome Archiv in mein Template kopiert.


    Dann habe ich noche folgende Zeile in der index.php meines Templates gefunden und gelöscht.

    Code
    1. $doc->addStyleSheet($filepath.'/css/bootstrap.css' , 'text/css', 'all');
    2. $doc->addStyleSheet($filepath.'/css/font-awesome.css' , 'text/css', 'all');
    3. $doc->addStyleSheet($filepath.'/css/template.css' , 'text/css', 'all');

    Ich habe die alte fonts-awesome.css und den fonts Ordner gelöscht.


    Bis dahin kein Erfolg, außer dass halt die alten Icon nimmer funktionieren, was ja klar war.

    Hallo, ja da gibt es schon passendere Icons. Die schon bestehenden kann ich ja dann wechseln.

    Allerdings bekomme ich die neue Version nicht installiert. Normal muss ich ja nur den Schritt "Using Web Fonts with CSS" ausfüheren. Den Code muss ich sicher in die index.php meines Templates einführen.


    Code
    1. <head> <link href="/your-path-to-fontawesome/css/all.css" rel="stylesheet"> <!--load all styles -->
    2. </head>
    3. <body> <i class="fas fa-user"></i> <!-- uses solid style --> <i class="far fa-user"></i> <!-- uses regular style --> <i class="fal fa-user"></i> <!-- uses light style --> <!--brand icon--> <i class="fab fa-github-square"></i> <!-- uses brands style -->
    4. </body>

    Den Teil im head kommt in den head und der andere in den Body, allerdings gibts kein <body> in meiner index.php.


    Also ich würde schon gern die neue installieren, aber ich steig da echt nicht durch.


    LG

    Hallo, ja die bestehenden kann ich auch ganz einfach hinzufügen wie Re:Later schon erkannt hat. Jetzt möchte ich aber ein anderes hinzufügen, welches im Template nicht inbegriffen ist. Zum Beispiel DIESES hier.


    Ich habe jetzt der font-awesome.css folgendes hinzugefügt.


    Code
    1. .fa-kaaba:before {
    2. content: "\f66b";
    3. }

    Jetzt wird mir zwar etwas angezeigt, aber nur das Sympol für das nicht gefundene Symbol.

    Hallo Leute,

    sorry aber ich check es einfach nicht. Mein Template nutzt Font Awesome und ich würde gern weitere Icons in meinem Hauptmenü nutzen. Habe mir jetzt schon ein paar Anleitungen angesehen, allerdings scheinen diese nicht für mich zu zutreffen. Diese hier zum Beispiel bezieht sich ja auf Einbindung in ein HTML Element(eigenes Modul) oder? Bei mir ist ja schon alles vorinstalliert und die font-awesome.css vorhanden. Nur wie kann ich weitere Icons hinzufügen?


    LG und Danke

    Hallo Christine, vielen Dank damit funktioniert es und ich konnte die Spalte fürs erste anpassen. Weiteres kann ich ja dann später Stück für Stück machen. Bin gestern noch bei anderen Sachen hängen geblieben und Antworte daher erst Heute ;-) Auch dir Karem vielen Dank für deinen Tipp.


    Besten Dank Euch und LG

    Hallo und guten Morgen,

    ich würde gern die rechte Spalte meiner Webseite anpassen, dabei geht es um den Abstand zwischen den Zeilen. Den Abstand kann ich mit der folgenden Zeile ändern, allerdings ändert sich dann auch der Abstand im Mainmenü.


    Code
    1. .nav > li > a {
    2. position: relative; display: block; padding: 10px 15px;
    3. }

    Ich habe mir auch schon eine Menüklassensuffix erstellt und in die custom.css eingetragen, aber da bekomme ich einfach den Zeilenabstand nicht hin.


    Code
    1. .modulerechts {
    2. /* text-transform: uppercase; */
    3. letter-spacing: 1px;
    4. padding: 0px 0px 0px 0px;
    5. }


    Danke für eure Tipps und liebe Grüße.