Beiträge von rudi.w

    So, nun endlich umgestellt auf MySql 5.6!!

    Update macht der Provider keines, er hat deshalb einfach die DB auf einen anderen Server verschoben.

    Dann war nur in der configuration.php die IP Adresse zu aktualisieren und alles lief reibungslos. DB dann nochmal neu importiert zwecks utf8mb4, denn das hatte ich ja vorher händisch auf utf8 gestellt pardon, und somit ist jetzt erst mal für ein Weilchen Ruhe.


    Dann noch PHP umgestellt und wie erwartet/erhofft/vermutet läuft die Webseite nun auf PHP 7.1.11 ohne jegliches Problem beer


    Danke an alle für die Tipps und Denkanstöße.



    LG Rudi

    Hey Re:Later,


    Zitat

    - Fehler berichten auf Maximum in der configuration.php

    - Debug aktivieren in der configuration.php

    habe nun auch diese Optionen getestet, leider nix Neues.


    Bei Version 7.1.11 kam erstmal eine Fehlermeldung mit Angabe einer php-Datei:

    Warning: session_start(): Failed to read session data: user (path: /tmp) in ../libraries/joomla/session/handler/native.php on line 260

    Error: Failed to start application: Failed to start the session


    Habe dann nochmal die Einstellung für den /tmp Ordner gecheckt, ist 100% korrekt eingegeben.

    Dann in der configuration.php den $session_handler von 'database' auf 'none' geändert, dann war der Hinweis auf die php-Datei weg, aber es blieb der Fehler:

    Error: Failed to start application: Failed to start the session



    In der Zwischenzeit habe ich nun dem Provider eine Anfrage auf Aktualisierung der MySql Version geschickt und jetzt warte ich erstmal ab, ob es nach dem Update funktioniert.



    LG Rudi

    Hey JoomlaWunder,


    hatte deine Antwort nicht gesehen, weil ich zur selben Zeit auf Re:Later geantwortet habe.

    Die Tabelle mit den technischen Voraussetzungen hatte ich mir zuvor schon mal angeschaut, aber irgendwie die MySql total übersehen, keine Ahnung warum :sleeping::sleeping:.


    Meine Vermutung, dass es an der MySql-Version liegt, erhärtet sich zusehends!

    Werde wie schon in meiner vorigen Antwort erwähnt, den Provider zwecks Update der MySql kontaktieren.

    Hallo,

    Zitat

    Die MySQL ist veraltet. Wenigstens 5.5 sollte es schon sein wegen utf8mb4-Unterstützung, wobei die 5.5 auch schon nahezu abgelaufen ist.

    Mit 5.0 kann es auch u.U. zu Import-Problemen der DB kommen.

    das hatte ich vermutet, werde mal beim Provider nachfragen zwecks Umstellung auf aktuelle Version.

    Ich hatte effektiv schon Probleme die DB zu importieren genau wg. utf8mb4, habe das in der .sql auf utf8 geändert, dann klappte der Import.


    Aruba ist einer der größten Provider in Italien.

    Eine PHP Umstellung ist praktisch ohne Zeitverzögerung aktiv und der MySql-Host wird immer als IP angegeben, habe das mit anderen Webseiten bereits zigfach praktiziert und bisher nie Probleme gehabt. Das kann aber auch nur ein glücklicher Zufall sein hmm.


    Zitat

    Kann auch sein, dass die Anmeldung/Session irgendwie festhängt wegen abweichenden Pfaden in verschiedenen PHP-Versionen.

    Alles schon probiert, bis auf die Tipps mit der configuration.php, das werde ich heute dann mal testen.
    Hoffentlich kommt was dabei raus ...

    Hallo Community,


    habe heute eine HP auf Joomla 3.8.12 upgedatet und es ist soweit auch alles OK, die Webseite läuft.


    Leider aber noch auf PHP 5.5.38 und da der Provider (Aruba) auch PHP 5.6.32, PHP 7.0.25 und PHP 7.1.11 anbietet habe ich versuchsweise umgestellt, aber dann gibt es folgende Fehler:

    7.1.11 - Error: Failed to start application: Failed to start the session

    7.0.25 - Error: Failed to start application: Could not connect to MySQL server.

    5.6.32 - Error: Failed to start application: Could not connect to MySQL server.


    Dieselbe Webseite läuft bei mir lokal auf PHP 7.2.7 ohne jegliche Probleme, selbe Version inkl. Erweiterungen.

    Lokaler Server: MySQL, Version: 5.7.23-0ubuntu0.18.04.1 - (Ubuntu)

    Online Server: MySQL, Version: 5.0.92-50-log


    Habe mittlerweile bereits stundenlang im Netz gesucht aber bisher keine Lösung gefunden.

    Hat jemand von euch eine ähnliche Erfahrung gemacht und kann mir einen Hinweis geben, wie das Problem behoben werden kann?


    LG Rudi