Beiträge von peterpw

    Ich verwalte eine Website, in der ein Kalender in zwei Sprachen (deutsch und französisch) geführt wird. Im deutschen Kalender gibt es keine Probleme, aber im französischen.


    Die Termine, die in dem Modul „JEvents - Latest Events Module“ (Position7) angezeigt werden sind korrekt, weil JEvents dafür die Möglichkeit einer individuellen Anpassung der Formatierung anbietet, die ich benutzt habe. Siehe Anlage: Termine-Modul.jpg

    Wenn ich aber die Liste der Termine über einen entsprechend eingerichteten Menüpunkt aufrufe, stimmt das Datumsformat nicht mehr. Problematisch ist vor allen Dingen, dass aus 14h30 2:30 geworden ist. Siehe Anlage Termine-Menu.jpg


    Im Konfigurationsmenü bietet JEvents mir nur folgende Optionen an:

    1. Französisch - Englisch
    2. Amerikanisch
    3. Kontinental - Deutsch
    4. aus Sprachdatei.

    Von diesen habe ich die letzte, also aus Sprachdatei aktiviert.


    Mein Wunschformat wäre: jeudi, le 16 mai 2019 à 14h30

    Hat jemand eine Idee, wie das realisiert werden könnte?


    Vielen Dank im Voraus

    Peter


    Infos zum System:

    Joomla 3.9.5

    JEvents 3.4.50

    Ein kleines Stück bin ich weiter gekommen; aber gelöst ist mein Problem noch nicht.


    Wenn ich den Menüpunkt "Impressum", der auf einen einzelnen Beitrag mit den einschlägigen Texten verweist, sichtbar lasse, dann funktioniert alles prima.


    Wenn ich aber - wie JoomlaWunder vorgeschlagen hat - das Menü verstecke, dann wird nicht mehr der Link

    https://example.org/de/fusszeile

    generiert, sondern

    https:/example.org/de/component/content/article/impressum?Itemid=198

    Damit erhalte ich die Fehlermeldung „Die angeforderte Seite konnte nicht gefunden werden!“


    Ich habe zwar einen anderen Weg gefunden, wie ich das Menü, das zum Impressum führt, verstecken kann, aber der nutzt eine Besonderheit dieser Website aus und dürfte kaum übertragbar sein.


    Die Website ist zweisprachig und enthält neben dem Hauptmenü, das eigentlich leer bleiben soll, ein Menü für deutsche und eins für die korrespondierenden französischen Inhalte. Ich habe das Menü "Impressum" einfach in das (eigentlich leere) Hauptmenü verschoben, das im Normalfall nicht angezeigt wird.


    Wie müsste ich vorgehen, wenn ich eine einsprachige Website betreuen würde?


    Vielen Dank im Voraus

    Peter

    Vielen Dank für die Information.


    Ich hatte in der Hektik die Regel vergessen, das man zum Anonymisieren die Adresse example.org nutzen soll. Tausendmal Entschuldigung!!!!

    Gibt es eine die Möglichkeit, dass ich das nachträglich korrigiere?


    Leider habe ich wahrscheinlich erst Freitag Zeit, deinen Vorschlag auszuprobieren. Dann melde ich mich aber sofort.


    Gruß

    Peter

    Zur Entlastung des Hauptmenüs habe ich im Footer Links zum Impressum bzw. zum Datenschutz gesetzt. In besonderen Fällen möchte ich auch aus Beiträgen heraus auf diese Ausführungen verlinken (z.B. wenn es um Copyright geht). Wenn ich diesen Link dann aufrufe, erhalte ich die Fehlermeldung, dass die Seite nicht verfügbar sei. Diese Meldung ist insofern korrekt, als das Impressum dort ist, wie es in der URL angezeigt wird.


    Dieses Phänomen tritt unabhängig davon auf, ob ich diesen Link mit meinem Editor (JCE) oder händisch im Quelltext eintrage.


    Bei der Fehlersuche ist mir aufgefallen, dass im Normalfall die URLs suchmaschinenfreundlich angezeigt werden. https://example.org/de/staedtepartnerschaft. Beim Impressum hingegen, dessen Link ich über ein Modul im Footer hinterlegt habe, fängt die URL wie folgt an:https://example.org/de/?view=a…ressum&catid=33:fusszeile. Der von Joomla generierte Link lautet hingegen: https://example.org/de/impressum.


    Hat jemand eine Idee, wie ich das Problem lösen könnte?


    Ich nutze Joomla 3.9.2 mit dem Template Protostar


    Vielen Dankt im Voraus

    Peter

    Sicherheitshalber habe ich noch ein wenig - trotz meiner schlechten Englisch-Kenntnisse - auf der von Astrid genannten Seite gestöbert und dort ( http://bj.zemplate.com/protost…emplate/protostar-options) hat sich dann bestätigt, was ich vorhin noch als Vermutung ausgesprochen habe:

    Zitat

    Template Colour: this hex color sets things like the Menu Buttons, the bar at the top and a few other styling accents.

    Hier ist also der Ort, an dem ich die Link-Farbe festlege.

    Damit ist dieses Problem für mich vorerst gelöst.

    Allen, die mich dabei unterstützt haben

    Vielen Dank

    Peter

    Die Linkfarbe kannst Du in den Templateoptionen einstellen.

    Ich habe gesehen, dass man die Farbe des Templates einstellen (siehe Screenshot) kann. Und wenn meine Beobachtungen richtig sind, dann ist die Farbe, die man für das Template festlegt, gleichzeitig die Farbe für Links. Oder gibt es noch an irgendeiner versteckten Stelle die Möglichkeit, die Linkfarbe separat einzustellen?


    PS: Vielen Dank an Astrid, die Seite kannte ich schon.

    mein Problem:

    Bei einer von mir betreuten Website habe ich einige Deklarationen in die user.css eingetragen, die auch den gewünschten Effekt zeigen. Es gibt aber ein Ausnahme, nämlich Links. Die zeigen eine früher verwendete Farbe an - aber nicht diejenige, die ich in die user.css eingetragen habe.


    Ursachenforschung:

    Im Seitenquelltext wird deutlich, dass im Header Style-Deklarationen aufgeführt sind, die entsprechend dem Kaskadenprinzip diejenigen aus der user.css überschreiben. Hier der Auszug:


    <style>

    h1, h2, h3, h4, h5, h6, .site-title {

    font-family: 'Open Sans', sans-serif;

    }

    body.site {

    border-top: 3px solid #f0a535;

    background-color: #f0a535;

    }

    a {

    color: #f0a535;

    }

    .nav-list > .active > a,

    .nav-list > .active > a:hover,

    .dropdown-menu li > a:hover,

    .dropdown-menu .active > a,

    .dropdown-menu .active > a:hover,

    .nav-pills > .active > a,

    .nav-pills > .active > a:hover,

    .btn-primary {

    background: #f0a535;

    }

    </style>


    mögliche Ursache:

    Nach meinen Recherchen liegt es offensichtlich daran, dass die index.php von Protostar (Ordner: /templates/protostar) diese Werte irgendwo ausliest und dann mit jeder Seite ausliefert.


    bisheriger Lösungsversuch:

    Ich habe in der index.php die betreffenden Zeilen (etwa Zeile 60 ff.) auskommentiert. Dieser Ansatz hält aber nur bis zum nächsten Update von Joomla, weil dann meine modifizierte Datei wieder überschrieben wird.


    Meine Fragen:

    - Kann man das Überschreiben auf andere Weise ausschalten?

    - Wo könnte ich die von mir gewünschten Werte für die Deklaration von Links eintragen?


    Zusatzinformationen:

    Joomla 3.8.12

    Template Protostar

    Eingeloggt in der Rolle eines Administrators


    Vielen Dank im Voraus

    Peter