Beiträge von jgon

    Guten Tag Liebe Forengemeinde,


    bislang habe ich meine Website (http://mentor-niederrhein.de) nur für "normale" Endgeräte geschrieben. Sie kann auch auf einem Smartphone/Tablet einigermaßen angesehen werden. Leider funktionieren die Menüs nur, wenn man an die Geräte eine Maus anschließt. Ich vermute ´mal, dass dies mit dem CSS bzw. JavaScript zusammenhängt. Welcher Befehl bzw. welcher CSS-Eintrag wird benötigt, um durch ein Antippen auf Touchdisplay den entsprechenden Event auslösen zu lassen?


    Vielen Dank

    Jürgen

    Hallo allerseits,


    nachdem ich in joomla\components\com_users\views\login\tmpl\default_login.php das gelöscht hatte, was für die Buttons zuständig war, erschien plötzlich wieder die Profilbearbeitung. Ich habe dies dadurch gelöst, dass ich die Inhalte des Ordners "profile" im Verzeichnis "views" durch Inhalte aus "login" überschrieben habe, nämlich mit der "view.html.php" und im Verzeichnis tmpl mit "default_logout.php" als "default.php" und "logout.xml".

    Jetzt ist das Profil komplett raus :)

    Hallo allerseits,

    vielen Dank für eure Hilfe, aber ich hab´s jetzt in joomla\components\com_users\views\login\tmpl\default_login.php gelöscht. Hoffentlich wird´s mir beim nächsten update nicht überschrieben. Ich habe nicht mehr gefunden, wo man diese Dateien überschreiben kann :(

    Ich habe auch noch andere Probleme (s.o.). Kann man die Anzahl der Einträge im Kategorieblog nicht irgendwo einstellen? Ich find´s einfach nicht :( - Hat sich erübrigt - "Führende" im "blog-Layout" hochstellen.

    Liebe Forengemeinde,


    nun bin ich nach längerer Pause 'mal wieder dazu gegekommen, mich mit joomla zu beschäftigen.

    Dabei sind mir ein paar Probleme aufgefallen.

    Ich arbeite unter einem modifizierten Protostar (Mentor s.u.) für die Seite mentor-niederrhein.de. Ich weiß, dass sich in dem Template noch Fehler befinden, aber bislang funktioniert es halbwegs. Vielleicht sollte die Anfrage auch an drei aufgeteilt werden?


    com_user habe ich so abgeändert, dass die automatische Umleitung auf die Profilseite unterbleibt. Allerdings gibt es immer noch die Buttons "Benutzername vergessen" und "Passwort vergessen", beide sinnlos, da es keine über e_mail-Adressen angemeldete Benutzer gibt. Benutzernamen und Passwörter werden vom admin vergeben und können nicht geändert werden. Ich würde sie gern auskommentieren, finde aber nicht, wo sie stehen.


    Als nächstes habe ich einen Kategorieblog mit über 25 Einträgen. Nach 25 Einträgen ist die Seite zu Ende und ich muß auf die nächste Seite wechseln. Da ich über Anker auf die einzelnen Einträge zugreife, ist dies äußerst lästig. Da auf dieser Seite interne Daten stehen, kann ich hier keinen Link bieten.

    Dateien

    • mentor.zip

      (818,51 kB, 21 Mal heruntergeladen, zuletzt: )

    Hallo Cristiane,


    die Textfiltereinstellungen hatte ich ja korrekt gesetzt. Dennoch haben mir die diversen Editoren den code rausgehauen. Jetzt habe ich für SU "kein Editor" gesetzt. Nun bleibt der code drin. Damit kann ich gut leben, da ich ohnehin nur selten den Editor benutze und meist html code.


    Vielen Dank

    Jürgen

    Hallo allerseits,


    ich habe auch wieder 'mal Probleme mit scripten. Ich habe inzwischen mehrere joomla-Installationen. Bei den meisten funktioniert der Textfilter trotz richtiger Einstellung nicht. Auch als SU werden mir die scripte gelöscht. Ich habe keine Ahnung, woran dies liegen könnte. Teilweise sind es Installationen, die neu erstellt wurden und lediglich mein Template eingespielt wurde. Mein Template wurde hier schon einmal veröffentlicht: Template lässt sich nicht installieren

    Bei einer Installation bleibt das script erhalten. Dort habe ich allerdings nur das Template ohne Datenbank nicht übernommen. Ich habe keine Ahnung, woran dies liegen könnte.


    Hier meine Datenbank ohne die user-Daten:db13318296-1.txt Ich musste allerdings die Endung sql in txt umwandeln.



    Jürgen

    Guten Abend liebe Forengemeinde,


    ich habe lokal unter xammp die neueste joomla-Version installiert und wollte mein als zip-download erstelltes Template dort installieren. Allerdings bekomme ich folgende Fehlermeldung:

    forum.joomla.de/core/attachment/3691/


    Ich weiß, dass das Template ziemlich grottig ist. Dennoch sollte es doch eigentlich installiert werden können. Folgende Files und Ordnet enthält das zip-File:



    Ich hoffe, ihr habt eine Idee, was dort los ist.

    Vielen Dank

    Jürgen

    deltapapa : Vielen Dank für Deine Mühe, insbesondere für den Datenschutzhinweis. Ich hoffe das ist jetzt so in Ordnung. Ich habe übrigens das Template kopiert und "Mentor" genannt, bevor ich es verändert habe.


    QAnka: Vielen Dank, ich habe Dir geantwortet.

    Guten Morgen time4Mambo,

    viene Dank für die rasche Antwort.


    Zur Zeit habe ich dies unter

    http://www.mentor-niederrhein.…ir-sind/kreis-wesel/wesel

    eingebunden.


    Ich habe ´mal den Quelltext der Seite angehängt (wesel.txt). Ich mußte ihn allerdings in *.txt umbenennen, damit er hochgeladen werden konnte. Wo das #dokument herkommt, ist mir auch schleierhaft.

    Allerdings wird bei mir lokal auch der iframe nicht angezeigt. Liegt es evtl. auch am Firefox?


    Ich finde übrigens beimmeiner joomla-Installation keinerlei Hinweise auf einen "Wrapper".


    Jürgen

    Guten Abend liebe Forengemeinde,


    ich habe eine "maps" als eigene Seite konstuiert. Sie läßt sich auch als Link aufrufen (z.B. http://mentor-niederrhein.de/media/Mentor/Wesel.html ). Allerdings hätte ich diese Seite gern in das andere Layout von Mentor-Niederrhein eingebunden. Daher habe ich einen Beitrag mit einem iframe geschrieben:


    <h1>Diese Schulen betreuen wir in Wesel und Brünen:</h1>

    <p><iframe width="300" height="150" scr="Mentor-Niederrhein.de/media/Mentor/Wesel.html"></iframe></p>


    Es wird im Editor auch ein Rahmen erzeugt. Dieser bleibt aber leer.

    Muß ich irgendwo im Joomla noch freigeben, dass iframes ausgeführt werden. Dem Editor habe ich schon beigebracht, iframes zu akzeptieren.


    Vielen Dank für Eure Mühe

    Jürgen