Beiträge von frieder

    Hallo christine2,

    ja 400 Untermenüs. Im Frontend erfolgt der Aufruf über ein Klappmenü von Zoolander (ich arbeite mit ZOO). Und das beantwortet deinen Tipp: Ich habe keine Ahnung, wie das zu bewerkstelligen wäre. Aber danke.


    Hallo JoomlaWunder,

    Im Backend bekomme das wieder einigermaßen in die Reihenfolge. Leider springen einzelne Punkte bei diesem Umstellungsprozess wieder zurück. Bis ichs dann irgendwann wieder in der Reihenfolge habe.

    Genauso im Frontend. Da stimmts aber gerade.


    Schlussfolgerung: Ich leg jetzt gleich alle noch fehlenden Menüpunkte an, veröffentliche sie halt noch nicht. Dann habe ich den Mist jetzt zum letzten Mal.

    Danke.

    Hallo,

    ich habe ein Menü mit knapp 400 Unterpunkten (Kfz.-Kennzeichen). Wobei noch nicht alle Kfz.-Kennzeichen enthalten sind.


    Wenn ich ein fehlendes Kfz.-Kennzeichen im Backend über Menü einfüge, kann ich nur den übergeordneten Eintrag auswählen, nicht aber das Kennzeichen das davor stehen soll.


    Beispiel: „ab“ soll eingefügt werden.

    Ich kann nur den übergeordneten Eintrag auswählen. Folge: Die ganzen Reihenfolgen, nicht nur beim „a“, werden durcheinander gewirbelt.


    • Kfz.-Kennzeichen (übergeordneter Eintrag)
    • -a
    • -aa
    • -ac


    Ich habe danach versucht, alles in die richtige Reihenfolge zu bringen. Also im Menü-Punkt „ab“ unter „Reihenfolge“ aa (Eintrag davor) ausgewählt. Das funktioniert zwar zuerst, wird später aber wieder entkoppelt. Bei „ab„ steht dann unter Reihenfolge nicht mehr „aa“, sondern „ab“.


    Ist es wirklich nur möglich, die Reihenfolge durch Verschieben der Menüpunkte mittels der 3 Punkte zu beeinflussen?

    Danke.

    Mit FoxContact sind Uploads möglich. Einfach und günstig (10€). Allerdings hochladen in einzelne Sektionen habe ich nicht gebraucht. Ist vielleicht auch nicht möglich. Müsste man evtl. jeweils händisch zuordnen.

    Nachtrag: auf der Homepage über Fox Contact eingehende Dateien müssen zuerst auf den PC exportiert werden. Sofern Sie aber auf der Homepage verwaltet werden müssen, müssen sie wieder hochgeladen werden. Umständlich.

    Hallo GHSVHS.de,

    ja ich hab das Verzeichnis "Programme (F)" selbst angelegt. Es passt. Hintergrund: In meinem Leben ist mir der Windows-PC schon zwei mal abgestürzt. Und wenn ich dann nur Windows auf C neu installiere, kann ich die installierten Programme noch sehen. Sie funktionieren zwar nicht mehr. Ich kann dann aber nachinstallieren.

    Hallo JoomlaWunder,

    Ich hab jetzt in der php.ini die Werte auf "http://php.net/upload-max-filesize upload_max_filesize=20M" gesetzt. Funktioniert auch nicht.

    Ich habe anhand eurer Hinweise aber gemerkt, dass es viele Fehler- und Einstellmöglichkeiten gibt (von denen ich dann manche nicht einmal finde). Eine Neuinstallation (es geht ja nur um Versuche) wird schneller zu machen sein. Deshalb würde ich sagen, danke und es hat sich erledigt.

    Danke JoomlaWunder.

    .htaccess habe ich nicht angepasst. Bisher hats mit der Installation von Programmen funktioniert.

    Installiert/Aktualisiert wird im Backend von Joomla >Kontrollzentrum >Aktualisierungen.

    XAMPP v3.2.4

    Kann evtl. die Aktualisierung zu groß sein. Irgendwo habe ich (bei einer anderen Installation?) mal die Upload-Größe eingestellt. Dazu bräuchte ich aber vermutlich die php.ini. Die habe ich jetzt aber nach längerem Suchen nicht gefunden. Zumindest nicht im Root-Verzeichnis bzw. unter Template. Liegt sie in einem anderen Verzeichnis?

    Hallo,

    ich habe vor einigen Monaten eine laufende Installation per Akeeba auf Xampp auf meinem PC installiert um glgt. Dinge auszuprobieren. Jetzt wollte ich in dieser Installation Joomla von 3.9.19 auf 3.9.23 updaten. Es erschien aber die Fehlermeldung (mit Pfadangabe), dass die Datei LICENSE.txt nicht gefunden wird. Also habe ich von der laufenden Installation diese Datei in das entsprechende Verzeichnis auf meinem PC kopiert.

    Beim erneuten Versuch der Joomla-Aktualisierung verschwand (???) die Datei LICENSE.txt nach drücken von "Aktualisierung installieren" und es erschien wieder die Fehlermeldung.

    Falls jemand eine Lösung hat, wäre ich dankbar. Falls nicht, ist es nicht so problematisch. Ich müsste halt eine erneute Akeeba-Installation vornehmen.

    Danke.

    @Re:Laster


    ok. Plugins bringen eher selten etwas.


    Auf das Thema bin ich gekommen, da in Seobility angezeigt wird, dass es ein Fehler sein soll, der eher dringend beseitigt werden sollte.

    Für Hamburg habe ich bspw. 13 Seiten mit identischen Seitentiteln und natürlich auch identischen Meta-Description. Beispiel:

    Zusätzlich zu freie-und-hansestadt-hamburg gibt es noch 70 weitere Städte mit mehreren Seiten.




    Beiträge, die nur aus einer Zahl bestehen habe ich nicht. Eine Sitemap mit allen Artikel habe ich bei Google eingereicht.


    Meine Frage: Kann ich Google sagen, dass alle Seiten mit Zusatz /1 bis /15 nicht gecrawlt werden? Ich habe in der GSC gesucht aber nichts gefunden. Wenn es allerdings programmiert werden muss, werde ich passen.

    Hallo,

    meine Seite mit vielen Adressen "leidet" an doppelten Meta-Description und doppelten Seitentiteln. Dadurch verursacht, dass die Adressen einer Kategorie nicht auf eine Seite passen und deshalb auf 3 oder 4 Seiten gelistet werden. Die Adressen werden über ZOO von Yootheme veröffentlicht.


    Das Problem müsste, wenn ich es richtig verstehe, über einen Canonical-Tag gelöst werden. Ich hab nicht viel Ahnung. Das Plugin System-SEF ist aktiviert, falls das notwendig wäre. Die Domain habe ich aber nicht eingetragen.

    Ich habe zwei Lösungen gefunden. Aber welche ist besser oder überhaupt geeignet:


    https://extensions.joomla.org/extension/custom-canonical/


    oder


    über dies Zeilen (gefunden bei flupdiwup.de) im Head-Bereich:

    <?php

    // ermittle die vollständige Adresszeile

    $urlcan = $_SERVER['REQUEST_URI'];


    // generiere ein Array aus der Url, Trennzeichen /

    $piecescan = explode("/",$urlcan);


    // die gewünschte Domain mit dem Slashzeichen / am Ende

    $canonical = "https://www.IhreJooomlaDomain.de/";


    // setze die Adresse wieder zusammen (ohne die Domain)

    // und füge die gewünschte Domain am Anfang ein

    for ($i=1; $i<count($piecescan)-1; $i++)

    { $canonical .= $piecescan[$i]."/"; }


    // der letzte Teil der Url ohne das Slashzeichen /

    $canonical .= $piecescan[$i];


    // schreibe das canonical Attribut in den Header vom Template

    echo '<link rel="canonical" href="'.$canonical.'" />';

    ?>


    Kann mir jemand einen Tipp geben oder etwas Besseres empfehlen. Danke.

    Hallo JoomlaWunder,

    das mit Menü-Alias funktioniert leider auch nicht. Aber das Benutzerdefinierte Modul müsste die Lösung sein. Denn das horizontale Menü besteht sowieso nur aus Buchstaben, die sich beim Drüberfahren verfärben und unterstrichen werden. Habs noch nicht probiert, aber die Farben müsste ich anpassen können. Danke.


    Hallo GHSVS,

    das beruhigt. Dann bin ich auf der richtigen Spur. Danke.

    Hallo,

    ich habe zwei Fragen zu Menüs/Filter:


    Ist es möglich, in zwei verschiedenen Menüs jeweils einen Menüpunkt mit gleichem Alias zu verwenden bzw. gibt es eine Umgehungslösung? Bei gleichem Eintrag erscheint der Hinweise: Der Alias „xxx“ wird bereits im Menüeintrag „xxx“ im Menü „Hauptmenü“ verwendet . Ein Splittmenü kommt nicht in Betracht.


    Und nur sicherheitshalber: Ein Verzeichnis mit vielen Artikeln (Adressen) ist auf meiner Homepage nur über einen Filter zugänglich. Meines Wissens kann Google diese Artikel so nicht finden und indizieren. Auch bei der Erstellung der Sitemap, wurden diese erste gefunden, nachdem ich ein Menü erstellt/veröffentlicht habe. Die vollständige Sitemap, in der jeder Artikel (Adresse) gelistet ist, habe ich bei Google eingereicht. Meine Frage: Kann Google diese Seiten so finden?


    Danke.

    Es geht um postalische Adressen. Es reichte, wenn ein Nutzer einen "Fehlerbutton" drückte. Anhand der in Plesk ausgeworfenen URL konnte ich auf meiner Homepage die postalische Adresse finden und korrigieren.

    Ich weiß nicht mehr in welchem Unterverzeichnis von Plesk die URL ausgeworfen wurde. Kannte mich mit Plesk nicht so aus. Aber das Unterverzeichnis mit der Fehler-URL habe ich zumindest gefunden.


    Und jetzt dachte ich, ich könnte so etwas mit Awstats auslesen. Wenn Awstats aber nur Statistikdaten auswertet, ist das natürlich falsch.


    Meine Frage war, ob es eine andere Erweiterung gibt, die mein Problem löst. Natürlich meldet nicht jeder User, wenn er eine falsche postalische Adresse auf meiner Homepage findet. Aber hin und iweder kam eine Fehlermeldung.

    Hallo,

    ich veröffentliche auf meiner Homepage Adressen, die sich ändern können. Damit Besucher eine fehlerhafte Adresse melden können, suche ich eine Möglichkeit, dass falsche Adresse vom Besucher nur kurz markiert werden und ich bspw. im Backend eine Rückmeldung erhalte.


    Ich habe in einem früheren Joomla-Forum ein solches Plugin erhalten. Der Programmierer nannte es „Hello World“. Das Programm hat den Zweck gut erfüllt. Die Fehlermeldung konnte ich auf dem Server über Plesk auslesen. Ich bin jetzt zu Strato gewechselt. In meinem Paket (Managed Server) wird Plesk laut meiner Rückfrage bei Strato nicht angeboten. Ich könnte mögliche Fehlermeldung also nicht auslesen bzw. weiß nicht wo dies in meinem Paket ginge.


    Meine Frage: Kann mir jemand ein gleiches (auch kostenpflichtiges) Programm nennen oder mir sagen, mit welchem Suchbegriff ich auf https://extensions.joomla.org/ fündig werden könnte.


    Danke.

    NACHTRAG: Habe von Awstats gehört, mit dem Serverdaten ausgelesen werden können. Aber ich habe es trotz Anleitung (https://www.linux-bibel-oester…en-webserver-unter-linux/) weder in Linux zum Laufen bekommen noch könnte ich es auf dem Server installieren. Schon vom Lesen (cgi) wurde mir schwindlig.

    Weiss gerade nicht wo mir der Kopf steht. Bin jetzt in Windows und habe Joomla und dann ZOO in Xampp (MySQLi) installiert. Funktioniert alles.


    Die configuration.php habe ich im Linux-Xampp erstellt, weil dies am Ende der Joomla-Installation in Xampp/Linux so angegeben war. Der Inhalt der Datei war vorgegeben. Musste ich nur in Editor einfügen und speichern.

    Bin jetzt in Windows. Muss was auprobieren. Wenn ich in Linux bin, werde ich entsprechend deinen Angaben nachschauen.

    Ich glaub, Windows ist für mich mit wenig Ahnung, besser als Linux. Danke.